DSM AES plugin not working with W2K Pro UltraVNC Server

Should you have problems with the DSM plugin, here's the place to look for help or report issues.

DSM AES plugin not working with W2K Pro UltraVNC Server

Postby ggithens » 2008-07-22 15:42

I just started using the latest 1.0.0 AES DSM plugin with UltraVNC on several computers. I got it to work right on some Windows Server 2003 and Windows XP machines but I can't get it to work on a Window 2000 Professional one. Every time I try to connect I get the following error on the server;

Image

and the following error on the viewer

Image

and the server service shuts down. I have set the one that is not working up the same way that I set up the ones that do work.

Please help.
ggithens
 
Posts: 3
Joined: 2008-07-22 15:28

Re: DSM AES plugin not working with W2K Pro UltraVNC Server

Postby ggithens » 2008-07-22 15:43

By the way the Windows 2000 Professional Machine is the server when I am having this problem.
ggithens
 
Posts: 3
Joined: 2008-07-22 15:28

Re: DSM AES plugin not working with W2K Pro UltraVNC Server

Postby ggithens » 2008-07-22 18:17

Update - I have switched to the MSRC4 plugin and that worked fine, but I would prefer to use the AES plugin if I can get it to work. Please help!
ggithens
 
Posts: 3
Joined: 2008-07-22 15:28

Re: DSM AES plugin not working with W2K Pro UltraVNC Server

Postby docdoc » 2009-09-24 09:16

Bump. Same problem for me:

W2k host and AESV2 plugin = crash.
If I set MSRC4 plugin and connect from clinet, it works, then I switch to AESV2 and works, connection with AES! Too good, but it crashes back as soon as the VNC service is restarted, making it almost useless.:-(

W2k host and new AESv3 plugin = error even clicking on "Config" button (I suspect it doesnt work under W2k because it compains about a missing entry in KERNEL32!)

No way to use AES under W2k in a reliable way?
docdoc
 
Posts: 5
Joined: 2009-09-22 10:28

Re: DSM AES plugin not working with W2K Pro UltraVNC Server

Postby adzm » 2009-09-25 01:20

OpenSSL works with win2k so any incompatibilities are on my end. Surprisingly I have had difficulty finding a win2k machine to test with, so I ended up creating a virtual machine. I'll take a look at this ASAP. Thanks for your help!
adzm
20
20
 
Posts: 63
Joined: 2009-04-29 18:59

Re: DSM AES plugin not working with W2K Pro UltraVNC Server

Postby docdoc » 2009-09-25 08:27

Thank you for your prompt answer...;-)

To reproduce the problem simply click "Config" button on Admin properties after selecting either AESV3 or SecureVNC (the problem is the same) and it complains about that missing entries on KERNEL32.DLL,

If you could solve the problem or give me some workaround (but a reliable one..;-)) you solve me a problem because I need to activate AES encryption on some servers (RC4 is too weak..).

Thanks, I'm looking forward for an answer!:-)

edit: AESV3 complains about ""InterlockedFlushSList", while SecureVNC pops out with "InterlockedPushEntrySList", I checked on MSDN and confirmed both methods are present only on Xp and newer...
Last edited by docdoc on 2009-09-25 08:34, edited 1 time in total.
docdoc
 
Posts: 5
Joined: 2009-09-22 10:28

Re: DSM AES plugin not working with W2K Pro UltraVNC Server

Postby adzm » 2009-10-15 22:50

New builds are now available for Windows 2000 support.
adzm
20
20
 
Posts: 63
Joined: 2009-04-29 18:59

Re: DSM AES plugin not working with W2K Pro UltraVNC Server

Postby docdoc » 2009-10-16 09:59

Thanks! I'll give them a try ASAP! :-)
docdoc
 
Posts: 5
Joined: 2009-09-22 10:28


Return to DSM plugin

Who is online

Users browsing this forum: No registered users and 3 guests