Problem building .msi installer to deploy over GP

Should you have problems with the MS logon plugin, here's the place to look for help or report issues.

Problem building .msi installer to deploy over GP

Postby sgiovanni » 2008-01-18 03:51

I want to deploy UltraVNC to my company over Group Policy. I have built an .msi installer for it used Advanced Installer from Caphyon and it installs perfectly. As part of this installer I had it grab my registry settings from HKLM\Software\ORL\ so it *should* take my settings which specify a password and "Requre MS Logon."

Yet for some reason when I try to connect to it I get only the password dialog, not username and password, and when I enter the correct VNC password it tells me VNC Authentication failed!!

I'm at a loss. Can anyone help?
sgiovanni
 
Posts: 3
Joined: 2008-01-18 03:29

Re: Problem building .msi installer to deploy over GP

Postby ChrisP » 2008-01-22 13:04

you also have to put the HKLM\Software\WinVNC3 Section into your msi files. there should be a key called MSLogonRequired and one NewMSLogon

hope this helps.
ChrisP
8
8
 
Posts: 15
Joined: 2007-04-20 06:13

Re: Problem building .msi installer to deploy over GP

Postby sgiovanni » 2008-01-22 13:33

I ended up going with the latest stable version instead of the release candidate and that cleared up my problem. Also, to set a password in the registry (so UltraVNC doesn't complain about not having one set even though you don't care because you use MS Logon), do the following:

Open regedit and navigate to HKLM\SOFTWARE\ORL\WinVNC3\Default and add a REG_DWORD named AllowProperties with a value of 1 and then add a REG_BINARY named Password with a value of basically anything: c10340c02212a199 for example.
sgiovanni
 
Posts: 3
Joined: 2008-01-18 03:29

Re: Problem building .msi installer to deploy over GP

Postby eric miller » 2008-01-24 21:21

SGIOVANNI--I also have created an .msi with the advanced installer application that I had deployed via GPO. Works wonderfully. But I have a question for you.

Did your .msi install winvnc.exe as a service correctly to your target machines? No luck (yet) here. As so far I am limited to connecting to active logon sesions.

-My VNC source configuration that I am pushing out to my workstations is requiring MSlogon. I am getting permission to start service errors upon installation.
-My work around has been to just simply place the winvnc.exe into the allusers/startup folder- so that I can connect once they are actively logged on.
eric miller
 
Posts: 2
Joined: 2008-01-04 15:25
Location: memphis, tn

Re: Problem building .msi installer to deploy over GP

Postby sgiovanni » 2008-03-27 01:47

Eric, sorry I just saw your post. If you're still having trouble email me, I sent you my email address in a PM.
sgiovanni
 
Posts: 3
Joined: 2008-01-18 03:29


Return to MS logon plugin

Who is online

Users browsing this forum: No registered users and 4 guests

cron