MS Logon II - Auth. failed for a non admin account

Should you have problems with the MS logon plugin, here's the place to look for help or report issues.

MS Logon II - Auth. failed for a non admin account

Postby Tifus » 2009-04-27 08:02

Hello,
UltraVNC Win32 server 1.0.5 is in service mode and use the following configuration:

Image

Image


WinVNC-authSSP.log wrote:Fri Apr 24 19:28:10 2009 - CUPSD2: Access is 0, user MYDOMAIN\X00001 is not authenticated, access granted is 0x0


mslogon.log wrote:24/04/2009 19:41:35 Invalid attempt (not authenticated) from client 10.xxx.xxx.xxx using X00001 account



As you can guess, I can't establish a connection with the client to server without the following error:
Image

Can you tell me where is the problem please?
-The domain account X00001 is correctly member of one of a UltraVNC Security group.
-It has valid password, is not locked.
-Even if UltraVNC is used for MS Logon II, I put a unique VNC Password as recommended
-With an other account member of the same UltraVNC Security Group, it works because this account is administrator on the workstation.
-ForceGuest (LSA) is disable. Changing this value do (with a reboot) nothing better.
Last edited by Tifus on 2009-04-27 08:07, edited 1 time in total.
Tifus
 
Posts: 2
Joined: 2009-04-27 06:42

Re: MS Logon II - Auth. failed for a non admin account

Postby redge » 2009-04-27 22:18

can you try update your vncviewer + winvnc


vncviewer 1.0.5.7
http://www.uvnc.eu/download/vncviewer1057.zip

changes
viewer changes:
-fix mslogon +dsm plugin not asking user/passwd

-----------

winvnc 1.0.5.7.2
topic #15182

server changes 1.0.5.7.2
viewer no change

-performance: less cpu on slower PC's (older video cards)
-performance: idle detection added, this should lower the cpu usage
when remote desktop is almost static.
-performance: vnclog: Even when disabled , it was still using some cpu,
corrected.
Changes are tested without hooking or driver. Using the hook or the driver the impact is less.


server changes 1.0.5.7.1
viewer no change

-usage box updated ( -run need to be the last option)
-server crash fixed ( some screen resolutions crashed server)
-possible the frozen viewer is fixed ( not tested, i can't repeat it)
-CPU throttle added to keep winvnc below 20%, without driver and hooking this could become quite high


server changes 1.0.5.7

-added option -sc
*server exit on viewer disconnect
*server keep connected on desktop change ( like uac).
You still can't control because running as application you
don't have permission, but you can see the remote person
do the task and get full control back when UAC popup or
elevated window is closed.
usage: winvnc.exe -sc -run
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: MS Logon II - Auth. failed for a non admin account

Postby SmokedIronMade » 2009-04-28 19:09

I got a similar issue with current version. It won't let me use the MS-Logon when using the dsm plugin (MSRC4Plugin.dsm), so i decided to try replacing vnc viewer and server executables for the ones above and now the viewer and server do not recognize the plugin, it is showing a message to check integrity of the plugin, but it was working just fine before replacing the executables.

Is there something else i need to do for trying the beta with MS-Logon and DSM?

Thanks!
SmokedIronMade
 
Posts: 6
Joined: 2009-04-21 20:38
Location: Caracas, Venezuela

Re: MS Logon II - Auth. failed for a non admin account

Postby SmokedIronMade » 2009-04-28 19:15

SmokedIronMade wrote:I got a similar issue with current version. It won't let me use the MS-Logon when using the dsm plugin (MSRC4Plugin.dsm), so i decided to try replacing vnc viewer and server executables for the ones above and now the viewer and server do not recognize the plugin, it is showing a message to check integrity of the plugin, but it was working just fine before replacing the executables.

Is there something else i need to do for trying the beta with MS-Logon and DSM?

Thanks!


I just fixed it, for some reason the plugin file was damage, it was 75KB and in the other computer it was only 16KB, so i replace it. BTW, a -tmp.d1 file copy of the plugin was generated some way.

Thanks!
SmokedIronMade
 
Posts: 6
Joined: 2009-04-21 20:38
Location: Caracas, Venezuela

Re: MS Logon II - Auth. failed for a non admin account

Postby SmokedIronMade » 2009-04-28 19:23

SmokedIronMade wrote:I just fixed it, for some reason the plugin file was damage, it was 75KB and in the other computer it was only 16KB, so i replace it. BTW, a -tmp.d1 file copy of the plugin was generated some way.

Thanks!


I think the issue with the dsm file might be due the version included with the 64 bits installer is damage.
SmokedIronMade
 
Posts: 6
Joined: 2009-04-21 20:38
Location: Caracas, Venezuela

Re: MS Logon II - Auth. failed for a non admin account

Postby Tifus » 2009-05-04 06:10

I tried with the last version and it's exactly the same.

But I found the solution :
In the applied GPOs on my workstation there is a rule named Access this computer from the network that doesn't contain the group Users.

You can find this rule by launching the command rsop.msc and then go there: Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> User Rights Assignment


The only thing that bother me a little here, the old version (WinVNC) don't require this change. Maybe MSLogon II use a different way to authenticate itself ?

Thanks for your comments.
Last edited by Tifus on 2009-05-04 06:11, edited 3 times in total.
Tifus
 
Posts: 2
Joined: 2009-04-27 06:42

Re: MS Logon II - Auth. failed for a non admin account

Postby gamegarro » 2009-07-06 01:22

Thank you for your discussion. The same problem happened to me. It is very helpful to me. 8)
gamegarro
 
Posts: 1
Joined: 2009-07-06 01:20


Return to MS logon plugin

Who is online

Users browsing this forum: No registered users and 1 guest