ms login vs. win98se

Should you have problems with the MS logon plugin, here's the place to look for help or report issues.

ms login vs. win98se

Postby sgt-d » 2005-04-05 17:40

i am trying to use ms login i (not ii) with windows 98se (which i have seen mentioned repeatedly throughout this forum) and i am having no luck whatsoever.

i have setup win98se for multiple users through control panel, each user has their own settings, desktop, etc.

that's about all there is in windows 98. there are no groups, just users.

so then i open the ms login settings page. the information in the dialog is a bland combination of vague and/or amiguous. i don't know what i'm supposed to put in there. i've tried entering one of the win98 user names. i tried checking local. i tried checking domain. i tried checking both. i tried unchecking both. nothing works. every connection attempt ends with "vnc authetication failed". blah.

so, what are you supposed to do? there is no help anywhere. i found a few urls for help pages in the forums, but they are all dead links now.
sgt-d
40
40
 
Posts: 81
Joined: 2005-03-29 04:46

Postby redge » 2005-04-05 18:40

UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Postby sgt-d » 2005-04-05 18:46

thank you, this helps. i'm trying some new things now.

also:

"Win 9.x require 2 dlls radmin32.dll and rlocal32.dll this can be found in the nexus.exe" <- link doesn't point to nexus.exe
Last edited by sgt-d on 2005-04-05 18:47, edited 1 time in total.
sgt-d
40
40
 
Posts: 81
Joined: 2005-03-29 04:46

Postby Furty » 2005-04-05 18:51

I haven't tried with Win98, but you need to tell us first what exactly you are intending to do.

1. you can't authenticate against users, just groups
2. afaik it is not possible to have local groups on Win9X, so there is no point in trying "Local"
3. if you don't log on to a domain controller there is no point in trying "Domain"

Only if 3 is true for your setup, please post the output of testauth.exe

-----------------------------------------------------------
btw: can any of the developers correct the following texts in testauth.exe? ;)
controler -> controller
"and not a service" -> "(and not as service)" - maybe remove completely?
"Enter to quit" -> line feed is missing before
Furty
8
8
 
Posts: 21
Joined: 2005-03-16 08:46

Postby sgt-d » 2005-04-05 20:41

in the simplest form i am just trying to enforce some kind of "windows authentication" for each login instead of a single password for access.

i was hoping that i could build a list of users/groups on a windows xp box and be able to use that.... but while 98 can use the xp user/groups for folder shares, i can't seem to get it to work with the ms login.

i found nexus.exe and i've put the dll's in the ultravnc folder, i'm assuming that's where they go. documentation for any of this is quite scarce.

i am trying to access my win2k server's users/groups now, hopefully that will work.

i just don't want a "one password for all" solution.
sgt-d
40
40
 
Posts: 81
Joined: 2005-03-29 04:46

Postby Marscha » 2005-04-06 06:05

Win9x has no security concept (compared to NT, W2K, WXP).
Win9x just assigns different profiles to "users", they are no security entities.
Regarding MS-Logon (I or II), Win9x "users" cannot be used for authentication.

Please try MS-Logon I with W2K domain groups (requires a W2K domain controller).
I'm not sure if it also works with W2K server groups without a domain.

Sorry if this doesn't fit your scenario but this is a limitation of Win9x, not UltraVNC.
Marscha
Former moderator
Former moderator
 
Posts: 471
Joined: 2004-05-14 06:48

Postby sgt-d » 2005-04-06 13:51

my win2k server isn't running as a domain controller and i had no luck getting ms login i working this way.

i do have an nt4 server running as a domain controller. i'm trying that now.
Last edited by sgt-d on 2005-04-06 14:40, edited 2 times in total.
sgt-d
40
40
 
Posts: 81
Joined: 2005-03-29 04:46

Postby sgt-d » 2005-04-06 20:42

i created a new global group named "vncadmin" on the nt4 server (our primary domain controller) and i added three user accounts to this group.

during testauth there are some ambiguous questions like "enter group". i assumed it wanted the name of the nt4 group, so i tried vncadmin (all upper and all lower) and i also tried 1 and 2 in case it was wanting to know the "group" in the ms login settings.

also the "loc=1 dom=3 local+domain=3" prompt is confusing. shouldn't dom=2? anyway, i tried 2 and 3.

my results are a mixture. the password seems to be checking out ok, but it still fails:

C:\Program Files\UltraVNC>testauth

Enter user name : sgt-d

Enter password : ********

Enter group : vncadmin

loc=1 dom=3 local+domain=3 : 3

Trying authlogonuser.dll
This only works on XP>
test is runnning as application and not a service
------------------------
------------------------
authlogonuser.dll not foundbased on authlogonuser.dll user has NO access
Trying auth.dll
------------------------
------------------------
DOMAIN USERS
VNCADMIN
No Domain group found
Domain password check OK
Local password check OK
AcceptSecurityContext failed with 8009030C
AcceptSecurityContext failed with 8009030C
based on auth.dll user has NO access Enter to quit
sgt-d
40
40
 
Posts: 81
Joined: 2005-03-29 04:46

Postby sgt-d » 2005-04-06 21:02

nevermind, i got it to work finally. sheez. pain in the butt.

the nt4 group name had to be capitalized in the ms login settings.
sgt-d
40
40
 
Posts: 81
Joined: 2005-03-29 04:46


Return to MS logon plugin

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron