Problem MslogonII push install

Should you have problems with the MS logon plugin, here's the place to look for help or report issues.

Problem MslogonII push install

Postby code39 » 2012-11-07 09:26

Hello,

I created batch to push intall UVNC server using .ini file with basic configuration.
I push on WiXP pro machine and no problem for installing but only 20% of machine accepted my account, 80% refused.
And when I look seetings of MSlogon, UVNC don't copy for these 80% domain account I have selected, but why ??
Do you have idea ?

Image

Thanks in advance for your support ! :)
code39
 
Posts: 2
Joined: 2012-10-31 13:57

Re: Problem MslogonII push install

Postby Bonji » 2012-11-07 15:12

The MSLogon groups/users are stored in the registry and not the ini file. When you push UltraVNC with MSLogon config, you also need to figure out how you want to push this registry setting.

Win32: HKLM\Software\ORL\WinVNC3\ACL
Win64: HKLM\Software\Wow6432Node\ORL\WinVNC3\ACL

It's very easy if you only include domain accounts as they will be the same across all computers on the same domain. You can just push the same registry settings to all computers (via a script, program, or just importing a .reg file).

It gets more complicated if you want to include local accounts such as the local Administrator. Since the ACL value uses the SID of each account I determine the SID of the local computer's Administrator account and then dynamically build the ACL BINARY value to include it plus all the domain accounts I want. My method is pretty convoluted, but it works very well without depending on additional programs. You can also use the program that comes with UltraVNC to modify MSLogon settings (mslogonacl.exe), and while simpler I found it to be more realible to just have my own program determine the ACL value and push it directly.
-Ben
Bonji
100
100
 
Posts: 325
Joined: 2008-05-13 14:54


Return to MS logon plugin

Who is online

Users browsing this forum: No registered users and 1 guest