not possible to connect after a while

Should you have problems with the MS logon plugin, here's the place to look for help or report issues.

not possible to connect after a while

Postby jfraga » 2013-03-08 15:36

Hi

I have enabled MSlogonV1 (Utra VNC 1.0.4 installed as a service) on several computers (around 300). I was able to connect on each computers.
After few days and on some computers (not all) (windows 2008 server R2 and XP), it's not possible to connect anymore with this authentication scheme.


The only way is to restart the service.

See the mslogon.log during the issue :
6/3/2013 14:03 Connection received from 127.0.0.1 using secretaccount account
6/3/2013 14:03 Connection received from 127.0.0.1 using secretaccount account
7/3/2013 10:41 Connection received from 127.0.0.1 using secretaccount account

Credentials are accepted (can be seen in the connection status window) but the server disconnect the connection (connection closed due to communication error)

This issue seems to be the same as the following link : http://forum.ultravnc.info/viewtopic.ph ... 3895950c75

Do you have any idea ?

Thanks for your assistance.

Regards
jfraga
 
Posts: 2
Joined: 2013-03-08 15:17

Re: not possible to connect after a while

Postby Rudi De Vos » 2013-03-09 21:11

1.0.4 is an old version.
Could you try if the latest version (1.1.8.3) also has this issue.

For fast test,
rename old server winvnc.exe
copy winvnc.exe
And use the new vncviewer.exe on the other pc.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5411
Joined: 2004-04-23 10:21

Re: not possible to connect after a while

Postby jfraga » 2013-03-11 14:55

Thanks for your answer.

Unfortunately, I'm not able to reproduce this issue by myself and the problem is solved if I restart the service.

I have launched the viewer with the debug log enable. it gives me the following output.


Started and Winsock (v 2) initialised
bufsize expanded to 4352
Registered connection with app
Clipboard changed
Don't send initial clipboard!
Connected to X.X.X.X port 5920
RFB server supports protocol version 3.4
Connected to RFB server, using protocol version 3.4
Command line MS-Logon.
MS-Logon (DH) authentication succeeded.
rdr::Exception (2): rdr::EndOfStream: read

Have your already seen this message ?
rdr::Exception (2): rdr::EndOfStream: read
jfraga
 
Posts: 2
Joined: 2013-03-08 15:17


Return to MS logon plugin

Who is online

Users browsing this forum: No registered users and 2 guests

cron