Unknown authentication scheme

Should you have problems with the MS logon plugin, here's the place to look for help or report issues.

Unknown authentication scheme

Postby soaro77 » 2006-07-18 00:32

Last week at work my PC got re-imaged with Windows XP. Previously I was running Windows 2000 and was using UltraVNC without any problems.

I installed UltraVNC on my new Windows XP and cannot login. When I try to connect from another computer I get "Unknown authentication scheme". I don't even receive a login prompt, just a little dialog box displaying the Unknown authentication scheme error. I tried connecting from my computer to itself (I turned on the loopback flag) and it connected just fine. But it will not connect from another computer.

I'm running UltraVNC 1.0.2. Trying to use MS-Logon II. All other settings default. I tried it from someones computer sitting in the next cube over so no firewall. I disabled the Windows XP firewall. I tried Classic and received the same error. I get this same error from both the VNC viewer and the Java applet. I checked the ForceGuest flag and it is correct.

The one thing I haven't checked is that I do not have a local login into the computer. I'm using my network login. But since I'm not even getting a login prompt at all, I don't expect this to fix the problem. I also haven't tried uninstalling 1.0.2 and installing 1.0.1.

Does anyone have any idea what else I could check or do to get this working? I'm at a complete loss of what else I can do besides creating a local account and reinstalling 1.0.1. I would really appreciate any ideas anyone might have.

What causes this error to happen? I couldn't even find much on it on a Google search.
Last edited by soaro77 on 2006-07-18 00:32, edited 1 time in total.
soaro77
 
Posts: 2
Joined: 2006-07-18 00:10

Re: Unknown authentication scheme

Postby Marscha » 2006-07-18 05:50

My guess is you are using a 1.0.1 viewer (or older) and try to connect to a 1.0.2 server.
With UltraVNC 1.0.2, the authentication protocol for MS-Logon (both I and II) changed.
So older viewers are not able to connect.
This is a documented change due to security issues.
Marscha
Former moderator
Former moderator
 
Posts: 471
Joined: 2004-05-14 06:48

Re: Unknown authentication scheme

Postby soaro77 » 2006-07-18 15:24

Thank you very much. That was the problem. Tried it this morning and with 1.0.2 viewer it works just fine. Thank you for the quick response.
soaro77
 
Posts: 2
Joined: 2006-07-18 00:10

Re: Unknown authentication scheme

Postby pvpsc » 2006-07-25 15:02

I run version 1.0.1 on my client. I upgraded a workstation to 1.0.2 the other day, and got this error. A quick google search led me to this thread. So I uninstalled version 1.0.2 on this machine and re-installed 1.0.1. I still get the same error.
I repeated the process, uninstalling the newly re-installed 1.0.1 and than re-installing 1.0.1. Error persists.

Any thoughts on this?

All suggestions are welcome.

Thanks

-peter
pvpsc
 
Posts: 1
Joined: 2006-07-25 14:59

Re: Unknown authentication scheme

Postby xlescalier » 2006-08-23 14:51

Does this mean that version 1.0.2 is not only no longer backward compatible, but that it is no longer compatible with other VNC-compliant viewers?

Xavier.
xlescalier
 
Posts: 1
Joined: 2006-02-08 17:20

Re: Unknown authentication scheme

Postby Marscha » 2006-09-27 08:08

MS-Logon II in 1.0.2 is not backwards compatible due to security concerns.
The 1.0.2 viewer still understands the older MS-Logon II.
All MS-Logon versions are UltraVNC-only.
Marscha
Former moderator
Former moderator
 
Posts: 471
Joined: 2004-05-14 06:48


Return to MS logon plugin

Who is online

Users browsing this forum: No registered users and 2 guests