uVNC SC+Repeater+Encryption HELP

Single Click discussions / bugs

uVNC SC+Repeater+Encryption HELP

Postby DckX » 2012-06-28 23:18

Greetings Everyone!

My question is in regards of how to make SingleClick work with encryption. (I am currently using uVNC ver. 1.0.9.6.2; Win7 x32)

I tried using MSRC4Plugin.dsm as stated in the following page:
http://www.uvnc.com/onlinehelp/7.html

I have also tried using the SecureVNCPlugin.dsm as stated on the following page:
http://forum.ultravnc.info/viewtopic.php?t=27633&start=5

When using MSRC4Plugin or SecureVNCPlugin, the viewer gets a message box that says: "You have specified an encryption plugin, however this connection is unencrypted! Do you want to continue?"

Is there any way to make it work?
DckX
 
Posts: 7
Joined: 2012-06-28 22:55

Re: uVNC SC+Repeater+Encryption HELP

Postby DckX » 2012-07-03 18:22

Thanks for the quick reply YY!

Here is what my helpdesk.txt looks like:
Code: Select all
[HOST]
Test 1
-plugin -id 1239 -connect repeaterIP:5500 -noregistry


My viewer setup is as follows:
Image

I got the following error(s):
Image

Can you clarify how to use the keys generated by SecureVNCPlugin.dsm? Do I have to leave both pkey and pubkey in the uVNC root directory?

Also, is there a way to save the repeater address and port of the configuration as of right now I have to enter it every time I intend to use it, and maybe use it as a service? ( I have tried clicking on the save connection settings as default, but it only saves the VNC server and dsm portions)

Thanks in advance.
DckX
 
Posts: 7
Joined: 2012-06-28 22:55

Re: uVNC SC+Repeater+Encryption HELP

Postby YY » 2012-07-12 15:55

DckX wrote:I have also tried using the SecureVNCPlugin.dsm as stated on the following page:
http://forum.ultravnc.info/viewtopic.php?t=27633&start=5

When using MSRC4Plugin or SecureVNCPlugin, the viewer gets a message box that says: "You have specified an encryption plugin, however this connection is unencrypted! Do you want to continue?"


Other than the said procedure of creating a SC.exe using SecureVNCPlugin, did you have the correct statement inside the "helpdesk.txt" instructing your SC.exe to use encryption? And also a correct setting at Viewer ?


Since you mentioned the connection was via repeater,

The syntax inside the helpdesk.txt should be something like this:
Code: Select all
[HOST]
To Repeater with Encryption
-plugin -ID 1234 -connect repeater_IP:5500 -noregistry



The setting at the VNCviewer should be like this:
Image
YY
200
200
 
Posts: 996
Joined: 2006-11-13 15:11

Re: uVNC SC+Repeater+Encryption HELP

Postby YY » 2012-07-14 16:54

DckX wrote:Here is what my helpdesk.txt looks like:
Code: Select all
[HOST]
Test 1
-plugin -id 1239 -connect repeaterIP:5500 -noregistry

This should be OK


DckX wrote:My viewer setup is as follows:
Image

Although the image is too small and difficult to recognize, but looks like you had entered the correct parameters.


DckX wrote:I got the following error(s):
Image

This is the problem: Looks like the SC.exe you created NOT HAVING the SecureVNCPlugin (or any other DSM Plugin) included.

Did you generate it with the exact steps as mentioned in http://forum.ultravnc.info/viewtopic.ph ... 33&start=5

Please use 7-Zip to open the SC.exe, to check if the SecureVNCPlugin.dsm (of course, it should be renamed as msrc4plugin.dsm) is existed.


DckX wrote:Do I have to leave both pkey and pubkey in the uVNC root directory?

The pkey is used by the viewer side.

The pubkey is used by the uVNC server, or in your case, the generated SC.exe
However, the online creator doesn't support the use of SecureVNCPlugin, that's why I need to derive the procedure as mentioned in http://forum.ultravnc.info/viewtopic.ph ... 33&start=5

IN FACT, you are not necessary to have the key pairs with SecureVNCPlugin operation . Without the pre-generated keys, the SecureVNCPlugin will create an NEW & RANDOM keys pair automatically for each connection session. But if having the pre-created keys, the connection ALWAYS use that keys for encryption.


DckX wrote:Also, is there a way to save the repeater address and port of the configuration as of right now I have to enter it every time I intend to use it, and maybe use it as a service? ( I have tried clicking on the save connection settings as default, but it only saves the VNC server and dsm portions)

I clicked the " save connection settings as default" box in my test. It was able to save all the entered parameters such as: VNC server, dsm portions, and repeater address and port as well.

I had tested viewer 1.0.9.6.1 & 1.0.9.6.2 (32 bit version) on WinXP, both working properly.

What version is the viewer you tested, and what is the OS ?
YY
200
200
 
Posts: 996
Joined: 2006-11-13 15:11

Re: uVNC SC+Repeater+Encryption HELP

Postby DckX » 2012-07-16 16:18

The viewer version is 1.0.9.6.2.
OS: Win 7 Pro x32
DckX
 
Posts: 7
Joined: 2012-06-28 22:55

Re: uVNC SC+Repeater+Encryption HELP

Postby DckX » 2012-07-16 16:40

I tried not including any keys on the generated SC. This is the error I get:
Image

Server closed connection
-The server is running as application
DckX
 
Posts: 7
Joined: 2012-06-28 22:55

Re: uVNC SC+Repeater+Encryption HELP

Postby YY » 2012-07-16 17:10

Investigate your original generated SC first:

Have you used 7-Zip to open it, and checked if the SecureVNCPlugin.dsm (renamed as msrc4plugin.dsm) existed ?
YY
200
200
 
Posts: 996
Joined: 2006-11-13 15:11

Re: uVNC SC+Repeater+Encryption HELP

Postby DckX » 2012-07-16 17:37

Yes I have checked the SC package with 7zip... the dsm plugin is there.
DckX
 
Posts: 7
Joined: 2012-06-28 22:55

Re: uVNC SC+Repeater+Encryption HELP

Postby YY » 2012-07-17 04:53

DckX wrote:I got the following error(s):
Image

You got this error, that means the connection was successfully established at the repeater, only the viewer found that the server was not using encryption.

However, based on your verification: the [HOST] statement inside helpdesk.txt is corrected (to use encryption), the dsm plugin is inside the SC package.

I had never seen this happened in my past tests, so I don't have any idea. :-?

Just one final question: How many [Host] definition/statement existed inside the helpdesk.txt ?

Are you sure the one you posted were running in your test ?
YY
200
200
 
Posts: 996
Joined: 2006-11-13 15:11

Re: uVNC SC+Repeater+Encryption HELP

Postby DckX » 2012-07-17 15:52

The helpdesk.txt file contains 6 [Hosts]

Code: Select all
[HOST]
Test 1
-plugin -id 1234 -connect repeaterIP:5500 -noregistry

[HOST]
Test 2
-plugin -id 1235 -connect repeaterIP:5500 -noregistry

[HOST]
Test 3
-plugin -id 1236 -connect repeaterIP:5500 -noregistry

[HOST]
Test 4
-plugin -id 1237 -connect 107.0.172.247:5500 -noregistry

[HOST]
Test 5
-plugin -id 1238 -connect repeaterIP:5500 -noregistry

[HOST]
Test 6
-plugin -id 1239 -connect repeaterIP:5500 -noregistry
DckX
 
Posts: 7
Joined: 2012-06-28 22:55

Re: uVNC SC+Repeater+Encryption HELP

Postby YY » 2012-07-18 01:54

- You had specified to use dsmplugin in the helpdesk.txt;
- the dsmplugin does exist inside the SC package;
- the connection can be established, but the viewer complaining the server is not using any dsmplugin.


Sorry I can explain why this happened :-? :-? :-?
YY
200
200
 
Posts: 996
Joined: 2006-11-13 15:11

Re: uVNC SC+Repeater+Encryption HELP

Postby DckX » 2012-07-19 19:52

leaving the SecureVNCplugin.dsm aside... would using the stock dsm plugin help?

Thank you for the help.
DckX
 
Posts: 7
Joined: 2012-06-28 22:55


Return to SC

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron