SC Suggestion: Setting on what version to send to Viewer

Single Click discussions / bugs

SC Suggestion: Setting on what version to send to Viewer

Postby markd89 » 2016-11-27 20:59

Hi,

I've been trying to get SC to connect to a viewer under Linux (https://forum.ultravnc.net/viewtopic.php?f=15&t=31894&sid=cb24857658a7f387e1b9a586715cd126&sid=cb24857658a7f387e1b9a586715cd126#p100838)

After much digging, I found that SC sends VNC version 3.16 to the Viewer. The viewers that I have found for Linux support 3.3,3.7,3.8 and so they break on 3.16.

One person I found hacked the viewer so that when 3.16 is sent, the viewer uses the 3.3 protocol and that worked for him with SC.

My suggestion is for a line in helpdesk.ini

ReportedVersionOverride=###

where ### can be 3.3 (or some other value). If ReportedVersionOverride is not present in helpdesk.ini then we'd keep sending 3.16.

What do you think?

Is there an easier way to hack the version that SC sends?

Thanks!
Mark
markd89
 
Posts: 3
Joined: 2015-08-18 15:26

Return to SC

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron