Repeater 2011 resolving host by name failed

SC<->proxy<->Repeater<->proxy<->viewer

Repeater 2011 resolving host by name failed

Postby markus_goe » 2013-01-18 17:15

I have Repeater 2011 V2.00 running on windows server 2008 R2

resolving hostname faild, but only when ther is a minus hyphen ('-') in the hostname

for example when i try to access host SERVER1:
resolving host by name: SERVER1
resolved: SERVER1(192.168.0.82)
connecting to 192.168.0.82:5900

for example when i try to access host IT-PC1:
resolving host by name: IT
failed to resolve locally

for example when i try to access host FIBU-PC2:
resolving host by name: FIBU
failed to resolve locally

same problem when i try the FQDN with a Minus
for example when i try to access host PC1.MY-COMP.LOCAL:
resolving host by name: PC1.MY
failed to resolve locally

so the problem is, the Minus and every thing after the Minus, will be Cut off

i have also tryed 'IT-PC1' and "IT-PC1" but does not work. :(

when i make an Alias in the DNS IT_PC1 => IT-PC1 it works with IT_PC1
but this is rearly not what i like to do for all clients.

any ideas :idea: ?

a Minus in a hostname is RFC conform:
http://en.wikipedia.org/wiki/Hostname
--------------------------------------------------------------------------
Restrictions on valid host names
The Internet standards (Request for Comments) for protocols mandate that component hostname labels may contain only the ASCII letters 'a' through 'z' (in a case-insensitive manner), the digits '0' through '9', and the hyphen ('-'). The original specification of hostnames in RFC 952, mandated that labels could not start with a digit or with a hyphen, and must not end with a hyphen. However, a subsequent specification (RFC 1123) permitted hostname labels to start with digits. No other symbols, punctuation characters, or white space are permitted.
--------------------------------------------------------------------------
markus_goe
 
Posts: 2
Joined: 2013-01-18 16:34

Re: Repeater 2011 resolving host by name failed

Postby markus_goe » 2013-02-05 18:51

a new version form "repeater webgui 2011" can by downloaded and solved my problem

4) Connect Viewer ID+ABCD:1234 ( update 2013: - replaced by +, else hostnames with a "-" can't be used.
markus_goe
 
Posts: 2
Joined: 2013-01-18 16:34


Return to SCIII

Who is online

Users browsing this forum: No registered users and 1 guest