Unable to connect LAN Computers

New to UltraVNC? Your questions are welcome in this subforum. :surprise:

Unable to connect LAN Computers

Postby GXR » 2013-11-12 16:27

installed the latest build on multiple LAN computers. Made sure firewalls were off or ports 5900/5800 were open. Unable to connect to any computers on the LAN (ex. localpc1 to local pc2). Keep getting connection refused. When I run netstat -an it shows localhost listening on 5900 and 5800 but I am still unable to connect to a LAN pc if i type 192.168.1.20 for the host name regardless if it is Win XP or Windows 7 PC.

I don't know what else to do to get the connection between LAN computers please help.
GXR
 
Posts: 3
Joined: 2013-11-12 16:21

Re: Unable to connect LAN Computers

Postby Rudi De Vos » 2013-11-12 18:33

So you are trying to connect
192.168.1.20 to 192.168.1.21
Both pC on the same LAN in the subnet and you get "connection refused"

First test
1) Loopback mode (server and viewer on the same pc)
connect viewer to localhost
make sure that the server is started manual ( no service)
This need to work else all next tests wil fail
2) If you get it working, hover over the systray and see what ip address the server is on.
No try from another pc to connect to this ip address
3) Try with a name
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5909
Joined: 2004-04-23 10:21

Re: Unable to connect LAN Computers

Postby GXR » 2013-11-21 16:47

Hi sorry for the delay. i had gone on vacation

Yes trying to connect 192.168.1.20 pc to 192.168.1.21 or any other pc on LAN. I have also tried using their host name and it still would not connect. Firewalls are turned off, loopback connection is set to allow. Passwords are correct.

I tried it again with your suggestions again and it failed.

If I do test on localhost on one of the computers it connects and shows me numerous stacked windows of my screen. However, it fails to connect to server on any other PC windows 7 or xp. I'm stumped.
GXR
 
Posts: 3
Joined: 2013-11-12 16:21

Re: Unable to connect LAN Computers

Postby Rudi De Vos » 2013-11-21 20:39

Sorry, i'm out of options.
If you are able to connect to the localhost, but can't connect to this PC from another pc something is blocking the network.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5909
Joined: 2004-04-23 10:21

Re: Unable to connect LAN Computers

Postby GXR » 2013-11-25 02:45

i figured out the problem. I had UltraVNC set to Auto for ports. Turns out I had another program using port 5900. When I changed UltraVNC to manual and use port 5901 it worked perfectly. Apparently UltraVNC if set to Auto just goes to the next available port in the range.

Hopefully this may help another user.

I appreciate your help.
GXR
 
Posts: 3
Joined: 2013-11-12 16:21


Return to Beginner questions

Who is online

Users browsing this forum: No registered users and 4 guests