UltraVNC x64 v1.2.1.1 not allowing multiple connections

New to UltraVNC? Your questions are welcome in this subforum. :surprise:

UltraVNC x64 v1.2.1.1 not allowing multiple connections

Postby creehanjt » 2016-08-16 15:44

I am experiencing an issue after installing v1.2.1.1 winvnc server is not allowing more than one connection at a time. The second client connection DOES connect to the server PC but the display is black or gray. I do not experience this with v1.2.1.0

I see something mentioned in the install release notes about this but I am unclear as to whether this means the issue was fixed or is some type of new feature?

* Ultr@VNC - Latest modifications - History

** V1.2.1.1 April 2016
Vnchooks: make sure the correct versions are attached, some older crashed
-black screen on connection/ grey screen on connection and deadlock
-on disconnect server icon stayed yellow, blocking new connections

-black viewer with icons without file transfer.
-fixed mem leaks/resource leak
Fix overrun crash
Timeout reconnect fix
Closing no reconnect fix
Auto refresh after idle

Update jpeg lib

** V1.2.1.0 January 2016
Server: added rdp session select
Server: added alternate shell when you use another shell the explorer.exe it doesn’t work correct
Viewer: added remember last location ( host based)

Artifacts on win8>
Faster reconnect on session switch
Repeater:reconnect, some port scanners could kick connections, stability
Posts: 1
Joined: 2016-08-15 19:31

Re: UltraVNC x64 v1.2.1.1 not allowing multiple connections

Postby Rudi De Vos » 2016-08-16 18:10

This should not happen, the bug fixed was for a single session.
The cause of that bug was the encoder switching before proper initialization.

We tested the server with a script that start 10 connections and kills every minute. Looks like we missed something or it's caused
by some special setting on your site.

*Can you test with a fixed encoder ( viewer option) instead of auto.
*Does your viewer has the same color depth
Anything particular that can help repeating it.
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 5526
Joined: 2004-04-23 10:21

Return to Beginner questions

Who is online

Users browsing this forum: No registered users and 4 guests