Possible solution for folder access problem in Vista

Here you will find help for frequently asked questions as well as for your specific question.

Possible solution for folder access problem in Vista

Postby retro » 2008-06-05 13:09

I posted a while ago in this thread about a problem I had accessing folders in File Transfer on a Vista machine.

The problem was that certain folders, for example My Documents, came up blank, with the message:

Error: media is not present in the remote drive

Several suggestions were offered, including upgrading the server, installing the service on startup for all users... none of these solved the problem.

I had given up on this, until it happened to me again the other day on another Vista machine. I browsed the folders manually using the remote access, and found that every folder I couldn't access via File Transfer was hidden and had what looked like a shortcut icon. However, they behaved like folders, and there was no shortcut if you checked the properties. Also, if you tried to access them, they would usually give you an Access Denied message. Curious! Setting permissions, taking ownership and turning off the UAC all failed to have any effect on this.

After doing some research, I found the following:


This explains that these are junctions - shortcuts that act like folders. They are there, just like a shortcut, to redirect you to the folder you require - basically so people who aren't used to the new way can still get around as before.

If you take a look at the link, it will show you all the junctions and what they point to. For example, what was: \Documents and Settings\$USER$\My Documents in XP is now \Users\$USER$\Documents, but the junction is there for the oldschool method.

Because of that, if you go to \Users\User-PC via File Transfer, you will see several folders, including:

My Documents

You should be able to access Documents, but My Documents will throw up the media not present error. However, they are the same thing!

Hopefully this will shed some light on the confusion for some people.

However, it is a very confusing thing for the less experienced user. Would there perhaps be a way to change UltraVNC so that one of the following happens?

  1. When you click on a junction, File Manager realizes it is a junction, and goes to the correct location
  2. The junctions aren't displayed in the tree
  3. The error message could mention junctions, perhaps with an link to an explanation (similar to the Jimmah page) on the website?

...or something better that I haven't thought of!

Hope this info is of some use to someone!
Posts: 9
Joined: 2008-04-24 19:47

Return to General help

Who is online

Users browsing this forum: No registered users and 7 guests