Failed to connect

Here you will find help for frequently asked questions as well as for your specific question.

Failed to connect

Postby JSABUK » 2016-06-15 17:53

when trying to connect remotely to a pc I get a "CONNECTED TO SERVER " message when I would expect the prompt for password

ive tried testing locally using win viewer on target pc and appears to work ok

any suggestions this is on a Win7pro pc using uVNC1.1.9

cheers FRUSTRATED
JSABUK
 
Posts: 1
Joined: 2016-06-15 17:47

Re: Failed to connect

Postby Rudi De Vos » 2016-06-15 20:43

This isn't a lot of info ...

both server and viewer are version 1.1.9
It works running in loopback mode ( server+viewer on a single pc)
but fail if you run the viewer from another pc.
*Can you test from a 3the pc
*temp disable firewall on both and recheck, if that works add a firewall rule for the exe
*activate winvnc (server) logging, possible it showt some error that indicate what happen ...
*check if not "loopback only" is set
*can you ping the server from the viewer pc
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5283
Joined: 2004-04-23 10:21

Re: Failed to connect

Postby SteveH » 2016-12-16 11:45

Hi,

I'm hitting the same error too.

I'm using UltraVNC Viewer 1.2.1.2 on Windows 7. On this system I have VMWARE pro 12.1.1 and a virtual box running
Ubuntu 16.0.4.

I have enabled VNC connections on my Ubuntu box using the default port 5900 as is.

I can successfully ping from the host to the virtual and vice versa.
I can connect using putty (SSH) from the host to the virtual box. This confirms at least my IP address is correct.

I can't TELNET to this box. Just get connection failed.

I've tried with the firewall disabled on the host but got the same error.

VNC status is just "Failed to connect to server !"

Regards,

Steve
SteveH
 
Posts: 2
Joined: 2016-12-16 11:13

Re: Failed to connect

Postby Rudi De Vos » 2016-12-16 20:46

Hard to tell, so just some ideas

can you telnet to the vnc port
telnet vncserver vncport

on ubuntu you can list the port used by vnc
sudo netstat -peant
or
sudo netstat -peant | grep ":5900"
or
sudo socklist

*isn't vmware already using port 5900 for his own vnc session
*there exist a vnc viewer for ubuntu, try if that work if you don't have one you also can use telnet localhost vncport
*try if you can connect from an external pc
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5283
Joined: 2004-04-23 10:21

Re: Failed to connect

Postby SteveH » 2016-12-21 13:54

Success!

On Virtual box created file "telnet" in /etc/xinted.d

service telnet
{
disable = no
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.telnetd
log_on_failure += USERID HOST
log_on_success += PID HOST EXIT
log_type = FILE /var/log/xinetd.log
}


Restarted telnet on ubuntu.
$sudo /etc/init.d/xinetd restart

Disabled firewall on ubuntu
$sudo ufw disabled

Could then access virtual box from Windows 7 host using telnet.

Enabled remore access on ubuntu in Desktop Application. Missed that one!

VNC now failed with an authentication error.

Overcame that using :
$gsettings set org.gnome.Vino require-encryption false

Cheers,

Steve
SteveH
 
Posts: 2
Joined: 2016-12-16 11:13


Return to General help

Who is online

Users browsing this forum: No registered users and 6 guests

cron