VNC SC not connecting to repeater using non-standard ports

Here you will find help for frequently asked questions as well as for your specific question.

VNC SC not connecting to repeater using non-standard ports

Postby kneel » 2017-05-22 04:42

Hi,

I have a vncrepeater running on a public IP, listening on ports 15901 & 15500.

If I run my viewer and connect to 15901, then run VNC Server on another machine and "Add new listener" with correct IP & port, it works perfectly.
However, when I create a VNC SC executable, I can't get a connection!

My Helpdesk.txt file contains (not everything, and IP hidden, but...)
Code: Select all
[DIRECT]

[HOST]
Internet support
-connect aaa.bbb.cc.ddd::15500 -id 2005 -noregistry


and the log file says (sorry couldn't cut and past, so no "UltraVnc [timestamp] >" for each line, and only what appears apropos):

Code: Select all
routeConnections(): new server connecting, accepting...
acceptConnection(): connection accepted ok from ip: [correct remote ip here]
nonBlockingRead(): start
nonBlockingRead(): returning 12 bytes
checkIdCode(): RFB 003.016
is not IdCode String
parseHostAndPort() start: id = RFB 003.016

parseHostAndPort() end: host = RFB 003.016
, port = 5900
acceptConnection(): conenction to port 5900 is not allowed, closing connection


Yes, the new lines and extra, blank lines are correct, not a translation typo. Looks almost like there is an extraneous <CR> in the config file, but there isn't!

Can anyone advise what I may be doing wrong?

Thanks in advance.
kneel
 
Posts: 1
Joined: 2017-05-22 04:06

Return to General help

Who is online

Users browsing this forum: Bing [Bot], Majestic-12 [Bot] and 3 guests