Cant connect to server

Here you will find help for frequently asked questions as well as for your specific question.

Cant connect to server

Postby inputname » 2018-03-26 19:24

Hi folks,

I setup UltraVNC on my home computer so that I can access files while on the go at school etc.. I can connect via my internal IP, but outside the network is a different story, I can't connect and I can't seem to figure what it is.

I figured it was my modem/router perhaps? I have a Sagecomm F@st 2864 that I suspect, from what I've heard that the modem itself needs port forwarding? Is there such a thing with the modem/router I have?

Check list:
Allowed through windows firewall
Don't have antivirus firewall (disabled it though through services)
Port forwarded port 30005 to my home computer (something inconspicuous)
Checked that the port is open through (freeportscanner and canyouseeme.org)
dyn DDNS setup, have my own hostname pointed to my public facing IP.
Pinged/tracert my hostname, works.

I'm out of ideas, anyone got a clue?
inputname
 
Posts: 3
Joined: 2018-03-26 19:22

Re: Cant connect to server

Postby Rudi De Vos » 2018-03-26 20:03

Try

uvnc_settings.exe

1° make sure firewal is temp disabled or upnp ports are open
2° run uvnc_settings.exe (accept UAC)
3° select a manual port
check upnp ( sometimes fix upnp is needed)
find ext ip
forward port

If winvnc is running you can connect to ext ip: port from outsite your local network

Don't forget to activate the firewall and close the port when required.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5793
Joined: 2004-04-23 10:21

Re: Cant connect to server

Postby inputname » 2018-03-27 03:13

I stopped the firewall service via services, find ext ip. forward port are grey'd out and fix upnp does nothing. Check upnp outputs this: > UPnP service:Stopped
> FireWall TCP 2869 error checking
> FireWall UDP 1900 error checking
inputname
 
Posts: 3
Joined: 2018-03-26 19:22

Re: Cant connect to server

Postby mhertz » 2018-03-27 11:17

No, there's no port-forwarding with the modem, only the router in your modem/router through it's web-interface. In denmark that modem/router + it's newer version gave many people problems with portforwarding, but a user emailed sagem for new/better firmware and they stated it wasen't them but the provider that needed to support that, so i'm not sure if only an issue here in denmark and yousee ISP.

Anyway, you know what you're doing it sounds from your post, so sorry cannot help. As you have checked at canyouseeme.org and the port is open, then that means that there is already something actively listening for it, so you must have set ultravnc to use that port. Maybe just in case play around with other port name, e.g. standard 5900 just to test, as maybe something else is using it. Also, just use IP and no dyndns at first to rule out(although you had pinged, but nonetheless). Also, as final resort, try to set IP of your PC running ultravnc as DMZ in your router config. Strangely though, as the port is open from outside(canyouseeme.org etc), then this isn't a portforwarding issue it seems.

(I believe I once had an issue where the firewall rule auto-set by ulttravnc during install didn't work because it's set to private only, whereas this was public on mine in one test at VM, so I needed to change the firewall rule to private,public, but as Rudi stated, just disable firewall to test, though you also had done that if I remember correct)

Good luck and sorry cannot help.
mhertz
20
20
 
Posts: 34
Joined: 2018-02-27 20:19

Re: Cant connect to server

Postby inputname » 2018-03-27 23:25

mhertz wrote:No, there's no port-forwarding with the modem, only the router in your modem/router through it's web-interface. In denmark that modem/router + it's newer version gave many people problems with portforwarding, but a user emailed sagem for new/better firmware and they stated it wasen't them but the provider that needed to support that, so i'm not sure if only an issue here in denmark and yousee ISP.

Anyway, you know what you're doing it sounds from your post, so sorry cannot help. As you have checked at canyouseeme.org and the port is open, then that means that there is already something actively listening for it, so you must have set ultravnc to use that port. Maybe just in case play around with other port name, e.g. standard 5900 just to test, as maybe something else is using it. Also, just use IP and no dyndns at first to rule out(although you had pinged, but nonetheless). Also, as final resort, try to set IP of your PC running ultravnc as DMZ in your router config. Strangely though, as the port is open from outside(canyouseeme.org etc), then this isn't a portforwarding issue it seems.

(I believe I once had an issue where the firewall rule auto-set by ulttravnc during install didn't work because it's set to private only, whereas this was public on mine in one test at VM, so I needed to change the firewall rule to private,public, but as Rudi stated, just disable firewall to test, though you also had done that if I remember correct)

Good luck and sorry cannot help.


You wouldn't happen to know the firmware version that was giving issues? I'm really thinking it's the sagecomm I have, because no connection can be made whatsoever so that is my first guess, the modem/router.

I noticed the rule set for only private as well, changed it to all three (private, public, domain) for good measure. Disabling the firewall/anti virus was one of the first things I tried to no avail.
inputname
 
Posts: 3
Joined: 2018-03-26 19:22

Re: Cant connect to server

Postby mhertz » 2018-03-28 10:52

Sorry, it started around a year ago where people complained about it, and there where issued a couple of updates, which worked for some, but the thread still has complaints.

Anyway, this isn't a portforwading-issue, or a router-issue, since the router correctly forewards the port as per your checks. If you have disabled the firewall and other AV-suites, as you stated and it still doesn't work, then i'm affraid I have no idea what's going on.

Also, i'm sorry, the model of your router isn't the same as the thread I was talking about, as that thread where about 3890 and 3686, not 2864, i'm sorry for confusing the model-names. If still interested, then here's the thread though google translate:
https://translate.google.com/translate? ... t=&act=url

If I was you, and the port still is listed as open through port-checks, then try another port, like 5900 and also e.g. try with another VNC client just as a test, like tightvnc or download/test a simple/portable ftp or http server. Also, go through the webinterface of your router and check that there isn't a firewall in there somewhere, that needs disabled or changed.

(In short, if the port tests open, then the router is doing it's job fine, and the issue is elsewhere...)

Edit: After rechecking that thread linked above, then when people got port-forewarding to work, through an update that came automatically after restarting modem, then they have the exact opposite problem as you i.e. when they port-foreward, then they can use there external IP, but no longer there internal IP, if wanting to use the internal, then they need to disable port-forewarding. This is for when using wifi, as wired connections worked I believe. Those sagem seem to be really strange, but as stated, you have no port-forwarding issue, as else the port-checks you did would fail - when not failing it means both the port is forewarded and a service/app is actively listening on said port number.
mhertz
20
20
 
Posts: 34
Joined: 2018-02-27 20:19


Return to General help

Who is online

Users browsing this forum: No registered users and 8 guests

cron