SingleClick issue with recent Windows 10 PCs

Here you will find help for frequently asked questions as well as for your specific question.

SingleClick issue with recent Windows 10 PCs

Postby lesdes » 2018-11-27 05:16

We have been using SingleClick very sucessfully to provide clients with remote support.

Since a couple of weeks ago we have started to experience an issue - presumably caused by a Windows Update being rolled out.

1. It works the first time after download.

2. Subsequent times it connects and I can see the remote screen. My actions (mouse movements, clicks) register at the remote end but the remote screen does not get transmitted to me. I continue to see the original display. Sometimes I can actually see changes for a few seconds and then it stops. The refresh button does nothing.

3. When I disconnect, it does not disconnect at the far end. winvnc.com continues to run - It needs to be killed off with task manager and then I get the disconnect pop-up.

The only solution we have is for the user to download the tool from our server before every connection and it will then work fine only the very first time.

If we do not kill off the old winvnc.com then the fresh download fails to run with some registry error message.

Has anyone else seen this behavior?
lesdes
8
8
 
Posts: 10
Joined: 2004-06-14 09:50

Re: SingleClick issue with recent Windows 10 PCs

Postby lesdes » 2019-01-03 14:14

After a lot of grief we stumbled on the solution.

The exe needs to be set to run in Compatibility mode emulating W7.

It used to run fine in W10 but now, after recent updates, it no longer does so. We have seen the failure slowly creeping through our population of clients using W10.

As the Compatibility mode setting is done in the registry it has to be done on each PC after the file is installed.

I'm very surprised no one else has reported this problem.
lesdes
8
8
 
Posts: 10
Joined: 2004-06-14 09:50

Re: SingleClick issue with recent Windows 10 PCs

Postby Rudi De Vos » 2019-01-04 21:01

Modified latest version to run without compat setting
Use "win10 Same as pevious, but exe request UAC on start " to test

Please let us know if it works
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5840
Joined: 2004-04-23 10:21

Re: SingleClick issue with recent Windows 10 PCs

Postby lesdes » 2019-01-06 12:21

Many thanks. We find this utility a superb support tool and are heavily dependent on it.

We will test it and report back.
lesdes
8
8
 
Posts: 10
Joined: 2004-06-14 09:50

Re: SingleClick issue with recent Windows 10 PCs

Postby lesdes » 2019-01-31 09:26

Sorry for the delay in testing.

We have now built a version using your instructions and done some basic testing but have a serious issue with the need for UAC.

Many of our clients run PCs that are secured and would require support personnel to enter admin password each time.

Will it not work without UAC?
lesdes
8
8
 
Posts: 10
Joined: 2004-06-14 09:50

Re: SingleClick issue with recent Windows 10 PCs

Postby Rudi De Vos » 2019-02-03 19:30

We use the highestAvailable setting
https://docs.microsoft.com/en-us/previo ... (v=msdn.10)

Application launch behavior for a member of the local Administrators group
Ask consent ->UAC

Application launch behavior for a standard user account
Application launches as a standard user

The idea was that when the remote use is admin you should be able to control admin apps, this require UAC
When he is a normal user, sc start as normal user.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5840
Joined: 2004-04-23 10:21

Re: SingleClick issue with recent Windows 10 PCs

Postby lesdes » 2019-02-04 05:30

Got it! Many thanks again.
lesdes
8
8
 
Posts: 10
Joined: 2004-06-14 09:50


Return to General help

Who is online

Users browsing this forum: No registered users and 12 guests