Various Issues - service stops, black screen, MS logon group

Here you will find help for frequently asked questions as well as for your specific question.

Various Issues - service stops, black screen, MS logon group

Postby dan-j » 2019-04-16 16:08

Having various issues intermittently on Win Server 2012.

Every handful of days uVNC server stops allowing us to use MS Logon Groups. We'll connect to the server and it prompts only for the VNC password, not MS credentials. We can manually re-enable it and it works for a time, then reoccurs.

Now it's getting worse.

Today I could remote to it and had a black screen only. I RDPed to the same server and after that the black screen went away.
Then, the service stopped altogether. I add these details in case it could be related, but these may be unrelated.

I restarted the service and all is working now and likely will for a few days or weeks. We've tried reinstalling uVNC server and still have the same issue with it dropping MS Logon Groups from the settings.
dan-j
 
Posts: 1
Joined: 2019-04-16 15:52

Re: Various Issues - service stops, black screen, MS logon g

Postby Rudi De Vos » 2019-04-16 18:58

All settings are in the ultravnc.ini.
What's possible is that you don't have access to write to this file, this happen when the desktop user is a domain admin.
VNC try to impersonate the desktop user but, depending on the settings this fail for some domain users..

Looks like you save it to memory, and as soon as winvc restart himself in another session, the settings are gone.
Workaround
-change settings as local admin
-create the ultravnc.ini on your own pc and copy them to server 2012 files are portable

RDP and black screen
When vnc isn NOT running as service, but manual started in a RDP session, it clone that session.
Or when you have set rdp option on and choose to clone a rdp session
The RDP session stay active when you logoff, but close the video part. VNC is cloning that video card -> black screen until you logon again.
Default VNC clone the console, not an RDP session

MSlogon mode 1 or 2
one use a group in ultravnc.ini
[admin_auth]
group1=group1
group2=group2
group3=
locdom1=1
locdom2=2
locdom3=0
mode 2 use a permission on a registry key
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5898
Joined: 2004-04-23 10:21


Return to General help

Who is online

Users browsing this forum: No registered users and 4 guests

cron