V2 RC1 - Server to Viewer(NAT) not working - wrong ports

V2 RC1 - Server to Viewer(NAT) not working - wrong ports

Postby Utopas » 2012-09-02 07:05

- newly installed server on a W2K8R2 and set groupname and password, rest default.
- newly installed viewer on a W7x64 and set groupname and password, rest default.
- server has public ip and no outgoing ports blocked
- client is behind nat firewall, rule added wan udp 5500 forward to internal viewer ip
- started server, confirmed firewall rule popup
- started client, can see server in list

- click Setup P2P - icon is flashing and on server appears "Initializing connection...", but I never get a connection

checked Firewall and I see blocked i.e. Source (myServer public IP):5570 to Target (myFirewall public IP):26038
I can change that, but at next connection it takes different ports.
I read in manual I should just forward udp port 5500 to nat viewer client, but seems not to use that.
Could also not find any setting to set anywhere for port in ini file etc. ?

any tipps ? thanks
Utopas
 
Posts: 2
Joined: 2012-09-02 06:42

Re: V2 RC1 - Server to Viewer(NAT) not working - wrong ports

Postby Rudi De Vos » 2012-09-03 11:08

This is v2, it use udp with auto nat traversal,
no portforwarding is needed.
(v1 used a repeater, tcp + portforwarding)

Both server and viewer connect to the "access server".
5570 (local) --->26038(router)
"access server" record 26038 and tell it to the other site, then it use this port to make a direct connection.

The port is set by the natrouter, it can differ each time.

The firewall need to have a rule for the exe, not for a single port.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5353
Joined: 2004-04-23 10:21

Re: V2 RC1 - Server to Viewer(NAT) not working - wrong ports

Postby Utopas » 2012-09-03 12:48

I am running a separate firewall box(freebsd pfsense) so not possible to allow program names...

a) is it possible to predefine outgoing port for the viewer to the access server
or
b) viewer automatically automatically registers upnp at router

thank you

p.s. is it possible somewhere to download actual source code for vs2010/2012 to continue programming this nice app for community ?
Utopas
 
Posts: 2
Joined: 2012-09-02 06:42

Re: V2 RC1 - Server to Viewer(NAT) not working - wrong ports

Postby Rudi De Vos » 2012-09-03 19:17

The network protocol we use is udt
http://udt.sourceforge.net/udt3/doc/t-firewall.htm
The trick is that both server and viewer connect to the access server and use the external port to connect
to each other. Server and viewer are making outgoing connections...

Upnp wil not work as it map incoming ports to a specific host/port, we only have outgoing ports.

Is your firewall before or after the nat router ? Normal it should only see the internal ports 5570.5571,5572,....and not the external ports.


sorry, source is not availbe.
It's more then 10.000 lines without proper docs..
Perhaps you can convince me if you worked on other software before
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5353
Joined: 2004-04-23 10:21


Return to PcHelpWare

Who is online

Users browsing this forum: No registered users and 4 guests