JavaViewer Connection Standard Error

Should you have problems with the JavaViewer, here's the place to look for help or report issues.

JavaViewer Connection Standard Error

Postby troywedi » 2009-10-23 01:27

Hi guys my error is;
Network Error: Could not connect to server: servername:5900

Here is my home network forwarding;

Net -> 5180 -> Modem -> Router -> 5800 -> PC
Net -> 5190 -> Modem -> Router -> 5900 -> PC

VNC viewer works awesome on 5190 but when I use 5180 for java viewer it does not conenct completely. I have read quite a few threads on this over the last week but still cannnot crack it. Hoping a fresh pair of eyes can help!

I enter the server details and I get the java load, see the options bar and waiting for connection then after 30 seconds get the;
Network Error: Could not connect to server: Servername:5900

In incomming connections I chose ports options and left default numbers but it reverts to Display with a 0 value, I assume this is a standard. See screenshot for server properties.

Image
troywedi
 
Posts: 4
Joined: 2009-10-23 00:53

Re: JavaViewer Connection Standard Error

Postby troywedi » 2009-10-23 02:38

Forgot to mention the ports have both tcp and udp forwarded.
troywedi
 
Posts: 4
Joined: 2009-10-23 00:53

Re: JavaViewer Connection Standard Error

Postby YY » 2009-10-23 10:38

It is because the Java viewer connection will use both Main Port (5900) and Http Port (5800)

In you case, when you try to connect with a browser:
1. input "http://xx.xx.xx.xx:5180
  No problem, as 5180 will be forward to the uvnc server at 5800.
2. The server will return the java viewer that using the main port, based on its setting, that will be 5900.
3. The java viewer try to establish the real communication via port 5900.
  Problem! The router doesn't has a setting of handling 5900 signal.


To solve this problem, you have two options:
1. At the router, forward the 5900 to the server pc too,
  I think you will not prefer this, as you are obvious not using the stand VNC port for internet connection.
     or
2. Configure the UVNC server using 5190 as main port, and then you need to change the port forwarding setting as:
  5190 (tcp) --> server_pc:5190


Also, UltraVNC uses TCP only, you may cancel the forwarding of UDP.
Last edited by YY on 2009-10-23 11:48, edited 1 time in total.
YY
200
200
 
Posts: 996
Joined: 2006-11-13 15:11

Re: JavaViewer Connection Standard Error

Postby redge » 2009-10-23 16:31

troywedi

In incomming connections I chose ports options and left default numbers but it reverts to Display with a 0 value,


you need to update to uvnc 1.0.6.5 or higher for override this known bug of locked port/display settings.

anyway,
your config NAT translation is OK just need update your winvnc.
Net -> 5180 -> Modem -> Router -> 5800 -> PC
Net -> 5190 -> Modem -> Router -> 5900 -> PC


only valid for default range table (5900 - 5999 and 5800 - 5899)
display 0 = port 5900

for vnc
display 0 = 5900
display 1 = 5901
display 99 = 5999

for http javaviewer
display 0 = 5800
display 1 = 5801
display 99 = 5899
Last edited by redge on 2009-10-23 16:32, edited 1 time in total.
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: JavaViewer Connection Standard Error

Postby troywedi » 2009-10-31 03:13

thanks YY, the way you explained that pretty much spelt it out for me and I understand the issue now. Thanks!

And thanks also Redge for the info! I am using 1.0.6.5 but when I was changing the ports I was still leaving them as the defaults ie. 5900 5800! Haha, feel a bit silly now, changed them to match my routed ports and will test now.

Thanks for the responses guys.
troywedi
 
Posts: 4
Joined: 2009-10-23 00:53

Re: JavaViewer Connection Standard Error

Postby troywedi » 2009-10-31 03:30

all good, java connection working great. Thanks guys!
troywedi
 
Posts: 4
Joined: 2009-10-23 00:53

Re: JavaViewer Connection Standard Error

Postby YY » 2009-10-31 09:08

troywedi wrote:I am using 1.0.6.5 but when I was changing the ports I was still leaving them as the defaults ie. 5900 5800!

When the RunAs Window popup, make sure to UNCHECK the box of "Protect My Computer .....", otherwise the new setting will not be saved.

Reference Can't set password summarized (the mentioned info is applicable to the save of other setting too.)
YY
200
200
 
Posts: 996
Joined: 2006-11-13 15:11


Return to JavaViewer

Who is online

Users browsing this forum: No registered users and 2 guests