VNC Viewer Options

Any feature you'd like to see in Ultr@VNC? Just propose it here.

VNC Viewer Options

Postby ddbivens » 2016-12-18 05:53

I have my VNCViewer / Options / Auto by 100% saved as the default. No other viewer options are active. When I connect to a remote computer, the window opens on my monitor showing the full remote screen and the VNC window is as tall (or wide) as will fit on my monitor, adjusted for the remote monitor resolution. My resolution is 1680x1050 on both of my monitors. The Zoom factor varies, sometimes the zoom is like 116% and sometimes it is as low as 42% (for a portrait display on the other end). The quality of the lettering is good. This works great! Once connected, I can click on Connection Options / Scale to Window / OK. Nothing should change. This should show the same quality of lettering, but it does not. Especially if the zoom factor is below 100%. The lower the Zoom number the lower the quality of the lettering. If I turn off "Scale to Window" the quality of the lettering gets good again. I can change the VNC window size then use the VNCViewer / Options / Auto by ### and change the number to any number, large or small, the quality of the lettering is good. I can move the edge of the window and it snaps to the correct perspective. I am hoping that "Scale to Window" can be changed to use the same algorithm as the Auto by % even if it has to 'jump' a little from one size to another to keep 'good quality' lettering.
ddbivens
8
8
 
Posts: 23
Joined: 2015-12-26 14:53

Re: VNC Viewer Options

Postby ddbivens » 2016-12-29 12:08

I have ran into an odd issue. This happened once before and somehow I got it fixed, but I don't remember how I fixed it... During all my testing with the VNC Viewer options, position, saving, size and everything, now when I open a VNCViewer session for a PC using command line (I actually use Remote Control Manager which launches VNCViewer via command line), the window opens on my 2nd monitor and not my primary monitor. I have clicked about all the options I can think of. If I use the 'Save' option, it does save it on my primary monitor for the next launch, but if I remove the 'save' option, the next launch, it jumps back to my secondary monitor. When I get to work today, I am going to disconnect my 2nd monitor, launch a few VNC sessions (with nowhere to go but my primary monitor). I hope that will fix the issue. Where do I look for the setting that tells VNCViewer what monitor/position to launch as the default?
Thanks
ddbivens
8
8
 
Posts: 23
Joined: 2015-12-26 14:53

Re: VNC Viewer Options

Postby ddbivens » 2016-12-31 15:48

I found the solution to the problem of my VNC Window opening on my second monitor. I unplugged the VGA cable from the back of my PC that lead to my second monitor. I launched VNCViewer, and it still opened to my second monitor (the icon showed on the task bar, but the VNCViewer window never showed on the monitor). I closed the window using Close on the taskbar icon. I deleted the Options.vnc file from my UltraVNC program folder. The next time I launched VNCViewer, it opened to my primary monitor. The odd thing is that I had renamed the options.vnc file the other day when I was trying to fix this (my renamed file was still in the folder) and the VNCViewer window still opened on my second monitor (the 2nd monitor was still connected on that day) and the Options.vnc file was recreated. So it seems like the 'window position' information is also stored somewhere other than the Options.vnc file. If anyone can shed some light on this subject, I would appreciate it. Thanks,
ddbivens
8
8
 
Posts: 23
Joined: 2015-12-26 14:53


Return to Feature requests

Who is online

Users browsing this forum: No registered users and 1 guest

cron