Sudden "VNC authentication failed!"

Sudden "VNC authentication failed!"

Postby -K- » 2010-05-14 09:16

Hi,

Suddenly, a few days ago, my 1.0.8.2 viewer started giving me "VNC authentication failed!" on each and every one of the connections I try (and yes, of course I am certain to give the right password).
We have a mix of RealVNC and UltraVNC servers and viewers on our network, but until now I could connect to all of them.
Servers that require the user to accept the incoming connections do get the dialog when I try to connect, but upon accepting I get the "VNC authentication failed!".
FWIW, others can still connect to me.
We use the basic authentication method, and don't know of any other setting that would matter.
I uninstalled several times and tried 1.0.6.5 too, but every time same outcome.

Any ideas or debug suggestions?

Thanks,
K.
-K-
8
8
 
Posts: 8
Joined: 2010-05-14 08:42

Re: Sudden "VNC authentication failed!"

Postby B » 2010-05-14 14:24

Can others connect to those same targets? Is it just your PC? Have you checked the keyboard? I know that sounds stupid, and maybe it is, but you never know...
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05

Re: Sudden "VNC authentication failed!"

Postby -K- » 2010-05-17 06:35

Yes, I also installed RealVNC now so at least I can connect to non-Ultra servers.

Thanks for taking up interest,
K.
Last edited by -K- on 2010-05-17 06:36, edited 1 time in total.
-K-
8
8
 
Posts: 8
Joined: 2010-05-14 08:42

Re: Sudden "VNC authentication failed!"

Postby wavesailor » 2010-05-18 08:56

-K- wrote:Suddenly, a few days ago, my 1.0.8.2 viewer started giving me "VNC authentication failed!" on each and every one of the connections I try (and yes, of course I am certain to give the right password).
K.


Hi,

I'm have suddenly experiencing the same issue? Anyone know why this is happening? I'm guess a windows update maybe. Running Vista 32. Any help would be appreciated?

-jj
wavesailor
 
Posts: 2
Joined: 2008-05-26 17:52

Re: Sudden "VNC authentication failed!"

Postby -K- » 2010-05-24 10:14

Anyone from the programmers here? Any debug suggestions?

Thanks,
K.
-K-
8
8
 
Posts: 8
Joined: 2010-05-14 08:42

Re: Sudden "VNC authentication failed!"

Postby burzek » 2010-05-25 10:24

Hmm check for any windows updates, that could be related...

Just a hunch...
burzek
8
8
 
Posts: 14
Joined: 2006-06-01 15:51

Re: Sudden "VNC authentication failed!"

Postby -K- » 2010-05-25 11:38

Thanks for the tip, but I really don't have the gut to uninstall programs and updates blindly until I get it working again. Reinstalling didn't work either, so it might have nothing to do with it anyway and thus would be a waste of company resources. And none of the others are experiencing the same.

I'd really like someone from development tell me what could return this faulty message, DLLs to check, run in debug mode, or whatever.

Regards,
K.
-K-
8
8
 
Posts: 8
Joined: 2010-05-14 08:42

Re: Sudden "VNC authentication failed!"

Postby -K- » 2010-07-28 07:09

For some time now, the issue just went away, with no apparent reason, just as it appeared. Weird...

Will get back if it ever resurges (even if noone from development seem to be interested).

Regards,
K.
-K-
8
8
 
Posts: 8
Joined: 2010-05-14 08:42

Re: Sudden "VNC authentication failed!"

Postby redge » 2011-01-05 10:34

vnc authentication failed only single computer or many computers ?
vnc server: realvnc or ultravnc
vnc viewer: ultravnc 1.0.8.2 ?

correct ?
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: Sudden "VNC authentication failed!"

Postby -K- » 2011-02-10 07:28

That was only on my computer, with Ultravnc viewer 1.0.8.2 and server 1.0.6.5 package, and installed Realvnc viewer+server after getting the error.

Regards,
K.
Last edited by -K- on 2011-02-10 07:30, edited 1 time in total.
-K-
8
8
 
Posts: 8
Joined: 2010-05-14 08:42

Re: Sudden "VNC authentication failed!"

Postby redge » 2011-02-10 20:46

1.0.6.5 is too old
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: Sudden "VNC authentication failed!"

Postby -K- » 2011-02-11 08:03

Are you even reading this thread?
-K-
8
8
 
Posts: 8
Joined: 2010-05-14 08:42

Re: Sudden "VNC authentication failed!"

Postby redge » 2011-02-11 11:36

-K- wrote:That was only on my computer, with Ultravnc viewer 1.0.8.2 and server 1.0.6.5 package
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: Sudden "VNC authentication failed!"

Postby -K- » 2011-02-11 13:49

That was the version number in the About that came with the 1.0.8.2 package (bug?).
Anyway, age obviously doesn't matter, as it worked before and after having the issue, and for thousands of users.
Additionally, I recently installed 1.0.9.5, so can't double check anything now.

Regards,
K.
-K-
8
8
 
Posts: 8
Joined: 2010-05-14 08:42

Re: Sudden "VNC authentication failed!"

Postby B » 2011-02-11 16:59

I'm having some weirdness now myself, but not with authentication (I can suddenly only connect in view-only mode, no matter the settings).

Anyway, it sounds as if you were not able to connect to machines, using simple VNC authentication, that others WERE able to connect to?

One thing that comes to mind is the various DSM plugins -- if UltraVNC is trying to use one it might get in the way of regular VNC authentication.

Another thought is that you could simply try extracting the vncviewer.exes from various UltraVNC distributions, and running them in individual directories. VNC Viewer is pretty much a standalone application.

If it still didn't work, I would look at the registry -- it's always seemed to me that the various VNCs make a mess of your registry, and persist in looking to it for settings even when you tell it not to...
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05


Return to 1.0.8.X (stable)

Who is online

Users browsing this forum: No registered users and 1 guest

cron