[solved] connection problem

[solved] connection problem

Postby anubisxl » 2011-01-13 10:12

Hi there,

I'm trying to connect to my home pc (windows 7 64bit) from my office (with proxy, win xp).
I basically followed the tutorial of Cameron W. with small changes found here: http://forums.whirlpool.net.au/archive/513251

I set up freesshd (instead of openSSH) and UVNC 1.0.8.2 64bit and opened port 443 on my router at home and enabled loopback connections in VNC.
I can connect to my home PC via ssh using putty without any problems.
I then built up a tunnel sourceport: 5999 to localhost:5900

but can not connect to my vnc server:


Connection failed - End of Stream

Possible causes:

-Another user is already listening on this ID
-Bad Connection


I really doubt that it's a connection issue as both home and office have highspeed DSL connections without latency problems


There are some posts on this topic but they aren't of any help...

Any thoughts?
Last edited by anubisxl on 2011-01-17 07:54, edited 1 time in total.
anubisxl
 
Posts: 6
Joined: 2011-01-13 08:52

Re: connection problem

Postby redge » 2011-01-13 12:15

try first to update to actual release 1.0.9.5, then you can trouble shoot more if error still exist
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: connection problem

Postby anubisxl » 2011-01-14 08:04

Updated last night to 1.0.9.5 but still same error message :-(

Any other ideas?

What does actually ID in "listening on this ID" mean??
anubisxl
 
Posts: 6
Joined: 2011-01-13 08:52

Re: connection problem

Postby redge » 2011-01-14 20:47

enable loopback connection on winvnc, required for your usage
disable Loopbackonly

if you use repeater
you have another connection using the name number ID
close vncvieer and
check task manager if you have a vncviewer crunched and terminate vncviewer

is your private repeater
or
do you use public free repeater for personal usage ?

how do you connect ? by command line interface or graphic User Interface ?
Last edited by redge on 2011-01-14 20:53, edited 1 time in total.
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: connection problem

Postby anubisxl » 2011-01-14 23:09

Loppback connection is allowed and loopback only disabled.
There's definitely no other vncviewer instance running, it happens also when I start vncviewer for the very first time after windows startup. Checked it though and there wasn't another instance running.
I'm not using a repeater only ssh tunnelling
I opened port 5900 at my router at home which isn't actually necessary when connecting via ssh. Will close the port and retest on monday but I doubt that this is the problem....
anubisxl
 
Posts: 6
Joined: 2011-01-13 08:52

Re: connection problem

Postby Rudi De Vos » 2011-01-14 23:35

For putty (SSL/SSH)you find several tutorial on the net.
But it should be the same manner with all openssh like software.

Are you sure the firewall allow access to this port (5900)
Some firewalls allow a few bits to be send before they close the port
-> stream broken.

Instead of the viewer you can also use telnet to test
telnet 5900
This should answer with rfbxxxxx
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5323
Joined: 2004-04-23 10:21

Re: connection problem

Postby anubisxl » 2011-01-15 07:55

In the win 7 firewall, if you allow a program as an exception it means allow it to open and listen on any port it likes, so I think we can rule out a firewall fault.

Telnet answers:
RFB 003.008
anubisxl
 
Posts: 6
Joined: 2011-01-13 08:52

Re: connection problem

Postby anubisxl » 2011-01-15 08:19

I just found something:

there are basically two (different) setups people recommend:

Setup1:
Tunnel in Putty destination ip: localhost
server in VNCViewer: localhost:5999 (when you redirected 5999 to 5900)
proxy in VNCViewer: no entry

Setup1:
Tunnel in Putty destination ip: ip of remote pc where server is running
server in VNCViewer: no entry
proxy in VNCViewer: localhost

is so far only used setup1

the VNCViewer config shouldn't really make any difference, but specifying a port might... will check that

I don't see why I should choose the remote ip as destination but will give it a try as well

I'll spread the news on monday

thanks for your help so far
Last edited by anubisxl on 2011-01-15 08:20, edited 1 time in total.
anubisxl
 
Posts: 6
Joined: 2011-01-13 08:52

Re: connection problem

Postby anubisxl » 2011-01-17 07:52

Well kind of embarassing, freesshd has a little button saying "allow port forwarding" tick this and it works.

Thanks for your help though
anubisxl
 
Posts: 6
Joined: 2011-01-13 08:52

Re: [solved] connection problem

Postby Rudi De Vos » 2011-01-17 12:06

If you have time.... a little howto would be handy for other users.

Then we would add it to the faq section to avoid that all your search and test effort get lost in the mass of forum messages.


Rudi
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5323
Joined: 2004-04-23 10:21

Re: [solved] connection problem

Postby Jules Fettu » 2012-12-28 16:02

I've searched the forum extensively but have not found what the error

"Possible causes:
-Another user is already listening on this ID
-Bad Connection”

Specifically means.

Any ideas?
Jules Fettu
8
8
 
Posts: 12
Joined: 2012-03-14 14:25


Return to 1.0.8.X (stable)

Who is online

Users browsing this forum: No registered users and 1 guest

cron