Unable to Build VC2010

Developers may discuss here.

Unable to Build VC2010

Postby Prelude101 » 2018-11-30 21:41

Hi,

I downloaded the latest source code from https://sourceforge.net/p/ultravnc/code but I am unable to build the solution that was include VC2010

I got the include error.

fatal error C1083: Cannot open include file: 'ctype.h': No such file or directory

If I put the path manually where the file is located, then I will links errors...

Am I missing a property sheet for the solutions or something like that for the include paths.


Thanks in advance.
Prelude101
 
Posts: 4
Joined: 2008-11-25 21:25

Re: Unable to Build VC2010

Postby Rudi De Vos » 2018-12-01 22:06

The setup build are done using VS 2010 Using the prject file winvncVS2010.sln

We use vcpkg (package manager) for unzip/zip/zlibstat and libjpeg, the standard latest libs doesn't work proper with VS 21010
If you want i can upload the vcpkg incude/lib folders as a zip, you never make changes thoose libs.

The VS2015 has the vnc src + lib src , this compiler also build the libs

ctype.h looks more like a problem with the include/lib path set in the compiler, this is a standard c file.

Yesterday installed VS2010 on a hyperv guest OS (old win8 to do some testing)
*after OS installed VS2010 + SP1 update
*copy vcpkg folder with include/lib and added path the the compiler
*downloaded tarbal and selected sln VS210
*5 minutes and exe was build and ready to run in debug.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: Unable to Build VC2010

Postby Prelude101 » 2018-12-03 14:38

Hi Rudi,

If you can upload the zip of vcpgk include/lib or provide a link where I can download it. I would really appreciate it.
As of now, even if I setup the include path on the compiler manually. I still have link problems that I have find to path to set.

Thanks
Prelude101
 
Posts: 4
Joined: 2008-11-25 21:25

Re: Unable to Build VC2010

Postby Rudi De Vos » 2018-12-03 19:00

Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: Unable to Build VC2010

Postby Prelude101 » 2018-12-04 22:36

Hi Rudi,

Thanks a lot for the package. I am able to build now.

Thanks again for the help!!!
Prelude101
 
Posts: 4
Joined: 2008-11-25 21:25

Re: Unable to Build VC2010

Postby tzott » 2018-12-05 03:00

Has anyone successfully built the newest ultravnc_src_1223 using MS Visual Studio 2017 yet?

I assume you start by using all the many *_VC2017.vcxproj files. Correct?

I've been at it a while with no success and a variety of issues I see also listed in this post.
However, since I'm using 1223 and VS2017 I didn't want to assume the advice here would help me.

ANY suggestions would be appreciated.
tzott
 
Posts: 5
Joined: 2018-12-05 02:52

Re: Unable to Build VC2010

Postby Rudi De Vos » 2018-12-05 18:39

just dubble click on winvncVS2017.sln
Possible you get some signing errors.
We sign the exe and dll's using the post-build task, you simple can disable them ( project properties)

You also need nasm to build the libs. (https://www.nasm.us/) else you get an error that the assembler code can't be compiled.
For the viewer the directx SDK is needed (https://www.microsoft.com/en-us/downloa ... px?id=6812) no direct header found error when not installed.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: Unable to Build VC2010

Postby tzott » 2018-12-05 20:09

A few questions and clarifications:

1. I should be opening the .sln file and not the .vcxproj files?
2. Once inside VS2017 do I need to re-target the project?
3. When I attempt to download the NASM I just get a page of code listings. What is it I need to download and install? https://www.nasm.us/pub/nasm/releasebuilds/?C=M;O=D
4. I am trying to create the Viewer so I downloaded and installed Direct X SDK (June 2010). It seems to install (Windows 10) but ends with error code: S1023. Is this a problem

Thank you in advance for your time.
tzott
 
Posts: 5
Joined: 2018-12-05 02:52

Re: Unable to Build VC2010

Postby tzott » 2018-12-05 20:29

Quick follow-up, I have installed NASM 2.14 64-bit for Win. Hopefully that is correct.
tzott
 
Posts: 5
Joined: 2018-12-05 02:52

Re: Unable to Build VC2010

Postby Rudi De Vos » 2018-12-05 20:35

1. after opening the .sln set winvnc or vncviewer as startup project, it build using the dependecy all other.

2. you can re-target, it depend on the versions you have installed use v141 and not V141_xp if you only want to be to run on version later then XP. Just make sure you set the same target for all subprojects

3. /pub/nasm/releasebuilds/2.14/win64 or /pub/nasm/releasebuilds/2.14/win32 both work
download zip and extract
The compiler need to be able to find the nasm.exe, add it to the exe path

properties->VC++ Directories->Executable Directory add path to nasm
C:\myfolder\nasm;$(ExecutablePath)

4.
https://support.microsoft.com/en-us/hel ... -june-2010
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: Unable to Build VC2010

Postby Rudi De Vos » 2018-12-05 20:38

Then you possible need to add C:\Program Files\nasm or C:\Program Files %28x86%29\nasm to the exe path

You can direct post now, only first messages require manual aproval.
That's why it takes sometimes long before they show, but only spamm filter that realy works
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: Unable to Build VC2010

Postby tzott » 2018-12-05 21:18

It seems that if I do not re-target the project I get a bunch of include errors for common includes like <ctype.h>
After re-targeting I get a bunch of syntax errors from winnt.h
tzott
 
Posts: 5
Joined: 2018-12-05 02:52

Re: Unable to Build VC2010

Postby tzott » 2018-12-05 23:40

FINALLY!!! A successful build!!!
I feel I should be a responsible open source developer and include tips and everything I did to get it working.

- Installed the following using the 2017 Visual Studio Installer, Individual Components:
- Windows 8.1 SDK
- All the VC++ 2017 toolsets I could find in there

- Uninstalled all previous Visual C++ Redistributables from the installed programs list and installed Direct X SDK (June 2010) as described earlier in this thread
https://www.microsoft.com/en-us/downloa ... px?id=6812

- Installed NASM 2.14 as described earlier in this thread
https://www.nasm.us/pub/nasm/releasebuilds/?C=M;O=D

- You do not need to add the NASM directory to the compiler executable settings; you can just add it to the Windows executable path environment variable.

- Do NOT re-target the project. It just creates problems. That’s why you should install the 8.1 SDK and all the toolsets.

- Had to remove the following include:
#include "afxres.h" (could not find that file anywhere)
and add the following code:
#include <windows.h>
#ifndef IDC_STATIC
#define IDC_STATIC
#endif
to ever single .rc file.
Very annoying, but I've read this is a result of a problem with VC2017 messing up .RC files.
Any other theories on that?

- Use only the 2017 .sln files

I think that’s everything. Thank you for the help and I hope this helps others.
tzott
 
Posts: 5
Joined: 2018-12-05 02:52

Re: Unable to Build VC2010

Postby Rudi De Vos » 2018-12-06 08:01

You can also download the virual image for vmware/hyperv/virtualbox then you don't need to install the compiler component.
It's a free limited time version of WIndows10 + Visual studio preinstalled
https://developer.microsoft.com/en-us/w ... l-machines
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21


Return to Developer discussions (mainly user-mode)

Who is online

Users browsing this forum: No registered users and 1 guest

cron