Limit 32bit version to SSE

Developers may discuss here.

Limit 32bit version to SSE

Postby Maniaxx » 2015-11-26 22:02

Hallo,
i have crashes on specific runtime paths (0xC000001D) due to invalid instructions not supported on AMD K7 (AthlonXP processors) with winvnc.exe. The latest version doesn't even start anymore. The 1.2.0.6 does work partially, ok with mirror driver, crashes on RZLE after some time. Can you limit the 32bit version compiler optimizations to /arch:SSE?
Maniaxx
 
Posts: 7
Joined: 2015-11-26 21:50

Re: Limit 32bit version to SSE

Postby Rudi De Vos » 2015-11-26 23:16

OS ?

There are w2k/xp /vista builds, all use other compiler options.
download the uvnc_1209_bin zip
It's possible that a w2k works, because it build with on older compiler.

w2K install on ALL
XP -> min OS XP
..
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5370
Joined: 2004-04-23 10:21

Re: Limit 32bit version to SSE

Postby Maniaxx » 2015-11-27 13:28

I have Win7-32bit.
I tried Win7/Vista/XP/W2k builds. The only one running is W2k. That's probably ok but what about the secondary tools like 'setpasswd.exe' and encryption/hook plugins? The general 1.2.0.9 exe installer doesn't work properly either (crashes in 'setpasswd.exe'). Seems to copy all files though but they don't run.
Maniaxx
 
Posts: 7
Joined: 2015-11-26 21:50

Re: Limit 32bit version to SSE

Postby Rudi De Vos » 2015-11-27 15:19

If the installer detected w2K as OS he would have installed the w2K compatibel exe.
The win7 is build with the latest MS compiler; VS 2015, this is required to support new kernel options.
There are no sse option in the compiler, but jpeg is assembler and use havy sse mmx and otehr stuff.

If you still have some w2k pc or virtual machine you can install vnc and use this exe.
Else i can create a seperate zip with all w2k exe/dll's, manual install.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5370
Joined: 2004-04-23 10:21

Re: Limit 32bit version to SSE

Postby Maniaxx » 2015-11-27 16:02

Rudi De Vos wrote:If the installer detected w2K as OS he would have installed the w2K compatibel exe.
[...]
If you still have some w2k pc or virtual machine you can install vnc and use this exe.
Else i can create a seperate zip with all w2k exe/dll's, manual install.

Thanks. I've installed the setup.exe with Win7 built-in 'compatibility settings' set to 'Windows 2000' and setpasswd.exe doesn't crash anymore. Looking good so far. Will test in-depth later. I had crashes with SecureVNCPlugin as well but could have been host exe (winvnc.exe). Need to test that as well.

Rudi De Vos wrote:The win7 is build with the latest MS compiler; VS 2015, this is required to support new kernel options.
There are no sse option in the compiler, but jpeg is assembler and use havy sse mmx and otehr stuff.

SSE+MMX should be still ok but anything beyond (SSE2+) would be unsupported. MSVC2015 should support the '/arch=SSE' option. Generally, this would be a very reasonable setting for 32bit versions to extend compatibility (if it works) in my opinion.
Maniaxx
 
Posts: 7
Joined: 2015-11-26 21:50

Re: Limit 32bit version to SSE

Postby Rudi De Vos » 2015-11-27 16:47

/arch is not set
So, sse2 is used... default value when nothing is specified
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5370
Joined: 2004-04-23 10:21


Return to Developer discussions (mainly user-mode)

Who is online

Users browsing this forum: No registered users and 1 guest