Web/Java client missing username with MS authentication

Web/Java client missing username with MS authentication

Postby wingfan » 2011-01-25 17:02

I have installed 1.0.9.5 on WinXP(x86) and Win7(x64) and when using MSI or MSII authentication, there is no username field, just the password field. So, it is impossible to use the Web/Java client to connect if you use MS authentication. I'd use 1.0.8.2, but that has the CAD issue that I can't get to work on Win7.

Has anyone else noticed this issue?

P.S. - this also seems to be the issue with 1.0.9.6 beta.
Last edited by wingfan on 2011-01-25 17:54, edited 3 times in total.
wingfan
 
Posts: 1
Joined: 2011-01-25 16:52

Re: Web/Java client missing username with MS authentication

Postby redge » 2011-01-25 22:36

the fix exist, just need developer apply the fix and compile the exe for 1.0.9.5.1 :-)

if (rfb.serverMinor >= 4)

solution from wingfan for the javaviewer ms logon unavailable with 1.0.9.5
topic #27372
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: Web/Java client missing username with MS authentication

Postby powtrix » 2011-02-19 21:36

Hi,

where is the fix? here the post does not exist.

I have this same issue..

I am using UltraVNC 1.0.9.5 w/ MSLogon on Windows 7 Pro (work..)
powtrix
 
Posts: 6
Joined: 2011-02-19 21:31
Location: Brazil

Re: Web/Java client missing username with MS authentication

Postby Rudi De Vos » 2011-02-19 22:34

This was no fix, it placed the javaviewer in user/passwd mode.
(hardcoded)
The the javaviewer only works in mslogon mode.

The javaviewer need to be changed for rfb 3.8 ( Someone is working on it)... but it take some time.

Timeframe set to end of this month.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5620
Joined: 2004-04-23 10:21


Return to 1.0.9.5 (stable)

Who is online

Users browsing this forum: No registered users and 2 guests

cron