64, 32, 64, and authentication

64, 32, 64, and authentication

Postby dukeofurl » 2011-02-28 06:49

I have a Win7x64_SP1 Desktop, and a Win7x32_SP1 netbook. I installed the respective CPU appropriate versions of 1.0.9.5 on each of them. Both have static IPs behind the router.

When I try to connect from my desktop to my netbook via the IP address, it connects just fine, and then asks me the password, which is fine, but no matter what I type, it tells me Authentication Rejected. Just for the heck of it, I experimented and set the password on the netbook to "123" in the settings app, so that it would be simple, and then I tried using that, but it still rejected me. I also tried checking the "Password Required" box, (which BTW acts like it means "no password required") and it doesn't ask me for a password on connection, but then it still rejects my Authentication, which is odd in itself, because that shows that it's not working at all.


Then alternately, when I go the other way, and try to connect from my netbook to the desktop machine, it asks for a username and password, but the funny thing is that I can't remember ever setting any kind of username, and can't find any place for a username in the settings app, so therefore I don't know what it is expecting.


Help!
dukeofurl
 
Posts: 3
Joined: 2011-02-28 06:32

Re: 64, 32, 64, and authentication

Postby dukeofurl » 2011-03-01 00:57

I had really hoped that somebody would reply, since the whole thing is basically un-usable as it is otherwise.
dukeofurl
 
Posts: 3
Joined: 2011-02-28 06:32

Re: 64, 32, 64, and authentication

Postby Rudi De Vos » 2011-03-01 09:01

All settings and passwords are saved in the file ultravnc.ini (same folder as winvnc.exe)
The user who start winvnc need write permission.

Fast test:

Copy winvnc.exe to some temp folder
exe winvnc.exe
This should auto popup the properties box
Enter password ( use a different for full and readonly)
Now try to connect with the viewer.

When this works copy the ultravnc.ini auto created in this folder to the
original install folder of ultravnc.

Is winvnc running as service ?
Is winvnc running as application ?
Are you using domain accounts ?
Is the account that start winvnc guest/admin ?
Are you using uac ?
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5413
Joined: 2004-04-23 10:21

Re: 64, 32, 64, and authentication

Postby dukeofurl » 2011-03-02 04:32

hmm. When I run winvnc.exe it says Another instance of WinVNC is already running.

When I try to run the Viewer shortcut on the dektop, it connects to the IP that I tell it, and then askes me the password, and no matter what I put, whether it's the right password or not, it rejects me. This from both machines.

From only one of the connections, it is asking me for a username, though I do not remember ever seeing a username, so I don't know what it wants.


winvnc is running as a service, on both the 32-bit machine and the 64-bit machine.

I am not using domain accounts. I'm not on a network.

The account... since it's running as a service, well I don't know. Don't services run automatically as admin?

How do I use UAC with this? Whenever I run the settings app, it asks me for permission, I don't know if that's relevant.
dukeofurl
 
Posts: 3
Joined: 2011-02-28 06:32

Re: 64, 32, 64, and authentication

Postby Rudi De Vos » 2011-03-02 08:37

already running: winvnc is already running as service.

username: In that case you have selected mslogon auth.
The logon is based on the user names and groups you defined for access.

If you are running as service, the ultravnc.ini is written with desktop user permissions.

-Use uvnc_settings.exe, this a simple ultravnc.ini editor. After making changes, you need to restart winvnc.
-Verify if the service use the winvnc.exe of the ultravnc folder, sometimes if you had installed several vnc versions the service could use another folder.

To try
*stop service ( winvnc options traybar)
*close winvnc
*remove ultravnc.ini
*start winvnc as application
*make setting changes
*start service ( winvnc options traybar)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5413
Joined: 2004-04-23 10:21


Return to 1.0.9.5 (stable)

Who is online

Users browsing this forum: No registered users and 2 guests