[solved] weird display issue - windows 7 64 bits

[solved] weird display issue - windows 7 64 bits

Postby slecaille » 2011-03-01 14:11

Hello,

I face a problem on two computers.
When uvnc is runned as a service I can connect but I have display issue :

Image

When I manually run uvnc (logged as Administrator on local machine) there is no problem.

Did I miss something ?

Best regards,
Simon.
Moderated by redge at 2011-03-02 12:30:
added solved to title, solution, remove bookmark from krdc
Last edited by slecaille on 2011-03-02 12:30, edited 1 time in total.
slecaille
 
Posts: 4
Joined: 2011-03-01 13:58

Re: weird display issue - windows 7 64 bits

Postby redge » 2011-03-01 17:05

what the version of uvnc are you using, look like is NOT 1.0.9.5 even you posted your message to 1.0.9.5 thread.
just replace your old version with current version 1.0.9.5
your issue was known on older release and then fixed.

your vncviewer is krdc on linux
your winvnc version ? running on windows 7 64bit
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: weird display issue - windows 7 64 bits

Postby slecaille » 2011-03-02 08:36

I know where I posted and here comes the reason :

Image

Look like is NOT 1.0.9.5 but when I check I read 1.0.9.5

Best regards,
Simon.
slecaille
 
Posts: 4
Joined: 2011-03-01 13:58

Re: weird display issue - windows 7 64 bits

Postby Rudi De Vos » 2011-03-02 08:49

You have the winvnc 1095 server and some linux viewer.

The effect you see is a bit shift, last pixel of each line is displayed on the next. The viewer is using an incorrect pitch for the requested color depth and resolution.

The logged on screen can have a different color depth or size then the initial screen.

Looks like a viewer issue. Can you test it with a other linux viewer or
the win32 ultravnc viewer.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5370
Joined: 2004-04-23 10:21

Re: weird display issue - windows 7 64 bits

Postby slecaille » 2011-03-02 09:24

Hmm, you've got it.

If I connect with Krdc, the display is twisted then if I connect with VNCviewer (on Windows system) or TightVNCviewer : same issue.

I deleted the bookmark in krdc, tried again and... it works.

May be krdc kept pitch and things. Shame on me and thank you for the light.
Last edited by slecaille on 2011-03-02 09:57, edited 1 time in total.
slecaille
 
Posts: 4
Joined: 2011-03-01 13:58

Re: weird display issue - windows 7 64 bits

Postby redge » 2011-03-02 12:29

i'm sorry for my mistake, so your solved your issue just removing the bookmark from krdc
thank you.

added solved to title
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: [solved] weird display issue - windows 7 64 bits

Postby slecaille » 2011-03-02 13:49

Not only, remove the bookmark isn't enough.

I didn't connect by RDP, only VNC (with windows VNC viewer) after service started : display twisted.

I tried two connections with a VNC Client :
- first connection : display twisted.
- second connection : display fine
slecaille
 
Posts: 4
Joined: 2011-03-01 13:58

Re: [solved] weird display issue - windows 7 64 bits

Postby redge » 2011-03-02 14:53

krdc version ?
could you update or is already the current version ?
linux version ?
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva


Return to 1.0.9.5 (stable)

Who is online

Users browsing this forum: No registered users and 1 guest