The server running as application / Authentication failure

The server running as application / Authentication failure

Postby altjx » 2011-03-04 18:43

Is anyone actually running a working version of this for windows 7? I'm at work right now and recently we just got a new machine in with Windows 7 that we're going to start moving towards. VNC, the free version at least, isn't compatible with Windows 7.

Downloaded Ultra VNC Viewer only on my machine, downloaded it on the remote machine. It's runinng as a service. I went ahead into the Edit settings application. I went to the security tab and set a 10 character password.

The minute I try to use the viewer to get into the machine, it gives me an error saying "Server closed connection - the server running as application"... It's sort of pissing me off. I think I've tried just about everything I can think of, and still getting the same thing.
altjx
8
8
 
Posts: 9
Joined: 2010-07-27 19:52

Re: The server running as application / Authentication failu

Postby redge » 2011-03-06 01:28

replace your winvnc and vncviewer

Rudi De Vos wrote:Could you first try with the 10951 server. (will be released as 10956)
Latest version
http://www.uvnc.eu/download/winvnc_dnstest.zip

This is a stable version, still beta because the java viewer require an update and not yet finished.
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: The server running as application / Authentication failu

Postby altjx » 2011-03-07 15:00

redge wrote:replace your winvnc and vncviewer

Rudi De Vos wrote:Could you first try with the 10951 server. (will be released as 10956)
Latest version
http://www.uvnc.eu/download/winvnc_dnstest.zip

This is a stable version, still beta because the java viewer require an update and not yet finished.


Can you please show me how you navigated to that download link? Also, is this going to run every time the system starts up? And I'm assuming the problems should be gone in this version?
Last edited by altjx on 2011-03-07 15:16, edited 1 time in total.
altjx
8
8
 
Posts: 9
Joined: 2010-07-27 19:52

Re: The server running as application / Authentication failu

Postby B » 2011-03-07 17:24

redge forwarded you a direct link from the developer, Rudi. Rudi placed it on a server he controls.

It will run on startup if you configure it that way (e.g., replace it in the service directory). If you can, just wait until the next official release.
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05

Re: The server running as application / Authentication failu

Postby Galaxiom » 2011-03-08 00:11

1.0.9 viewer connecting to a 1.0.9 server causes this problem when using the MSRC4 Plugin.

Downgrade the viewer to 1.0.8

Unfortunately this also drops the file transfer, chat and disable remote console options.

The 10951 server does not fix the problem.

I would really like it fixed as I don't want to change the encryption plugin.
Galaxiom
8
8
 
Posts: 11
Joined: 2009-10-25 23:50
Location: NSW Australia

Re: The server running as application / Authentication failu

Postby sbostedor » 2011-03-15 19:21

Is there fix for this yet? I'm getting a lot of reports of this from users.
Steve Bostedor
http://www.vncscan.com
Super Simple UltraVNC Management
sbostedor
100
100
 
Posts: 273
Joined: 2005-02-02 19:30
Location: Jackson, MI, USA

Re: The server running as application / Authentication failu

Postby Rudi De Vos » 2011-03-15 20:02

All test were done with the new plugins.
I also tested SC with the old MSRC4 Plugin and viewer 10951.

What version of plugin doesn't work.
Server/viewer version

What encoder is used, does all encoders have the same problem
Special Zrle and plugins is a hell to get it working.
Last edited by Rudi De Vos on 2011-03-15 20:06, edited 1 time in total.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5283
Joined: 2004-04-23 10:21

Re: The server running as application / Authentication failu

Postby Rudi De Vos » 2011-03-15 21:04

MSRC4 Plugin seems to work fine with server/viewer 10951.
if you use a rc4.key.
fail without a key.
If you don't use a key, the plugin should request a password, but the plugin
answer "nothing needed".

I guess in the old viewer version, "nothing needed" defaulted to ask password. The new plugins has the "requestpassword" answer.

The new plugin engine conflict with this old plugin.

Because SC use a key, my test work correct.

Wrong answer, I had a key on the viewer site....

Testing again

Seems zrle is causing trouble, other encoders works...
Found...
added switch based on the plugin name.
Fixed, but only if the plugin is called "MSRC4Plugin.dsm".
Last edited by Rudi De Vos on 2011-03-15 21:34, edited 3 times in total.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5283
Joined: 2004-04-23 10:21

Re: The server running as application / Authentication failu

Postby Rudi De Vos » 2011-03-15 22:15

Fix old plugin added. ( viewer change)

http://www.uvnc.eu/download/winvnc10951S.zip
Last edited by Rudi De Vos on 2011-03-15 22:16, edited 2 times in total.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5283
Joined: 2004-04-23 10:21

Re: The server running as application / Authentication failu

Postby Galaxiom » 2011-03-15 22:48

Thanks Rudi. All good now.
Galaxiom
8
8
 
Posts: 11
Joined: 2009-10-25 23:50
Location: NSW Australia

Re: The server running as application / Authentication failu

Postby pgb00 » 2011-03-16 09:55

Hello

I installed the upgrade 10951S and i have the same pb when i use ARC4Plugin.dsm (i don't connect a server 10951S with this message "Server run as application"). With the same file and SecureVNCPlugin.dsm, i have no problem.

After many tests, it's works with plugin ARC4Plugin.dsm and encoder Tight. I must uncase "Auto Select best settings" and choose "Tight"

The upgrade 10951S fix only MSRC4 plugin ? The option "Tight" is it a good option ?

Thanks for your help.
pgb00
8
8
 
Posts: 11
Joined: 2011-03-01 15:38

Re: The server running as application / Authentication failu

Postby Rudi De Vos » 2011-03-16 10:07

added switch based on the plugin name.
Fixed, but only if the plugin is called "MSRC4Plugin.dsm".


ARC4Plugin.dsm: fix doesn't work
unless you rename it to MSRC4Plugin.dsm
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5283
Joined: 2004-04-23 10:21

Re: The server running as application / Authentication failu

Postby looker44 » 2011-03-29 15:28

Running on W2003x64
Installed 1.0.9.5 recieved same error
Uninstalled 1.0.9.5 reboot
installed 1.0.8.2
reboot
received same error
I am running 1.0.8.2 for client on xp32bit
looker44
8
8
 
Posts: 23
Joined: 2008-06-06 19:19


Return to 1.0.9.5 (stable)

Who is online

Users browsing this forum: No registered users and 1 guest

cron