[Fixed] UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

[Fixed] UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby Teazle » 2011-04-03 19:31

Hi there!

Been using this neat little program for quite some time and decided I'd try the new pre-release update (only went from 1.0.9.5 to 1.0.9.6) but I am having problem getting encryption to work.

Since I have physical access to my server, I decided that to be on the safe side I would do a complete reinstall of Server (as Service) on Server-computer and complete reinstall of Viewer on Viewer-computer.

Setup:

Server - WinXP x64 SP2 w/ UltraVNC x64 v1.0.9.6 w/ SecureVNC 2.3.0.0
Viewer - WinXP x32 SP3 w/ UltraVNC x32 v1.0.9.6 w/ SecureVNC 2.3.0.0


Server
-------

Enable DSMPlugin SecureVNCPlugin64.dsm
Configure as AES with 256-bit Key, RSA-2048
Generate Client Authentication Key
save *.pkey and *.pubkey

Viewer
--------

Copy *.pkey from Server to UltraVNC folder
Use DSMPlugin SecureVNCPlugin.dsm

Connect.

Result:

"You have specified an encryption plugin, however this connection is unencrypted! Do you want to continue?" Yes/No

Yes: Connection established, but Status Window reports: "Connected (SecureVNCPlugin-v2.3.0.0)
(no encryption)

No: You refused the insecure connection.


Connecting without DSMPlugin:

SecureVNCPlugin authentication failed (no plugin interface available)

This last one can also occur upon pressing Yes in previous scenario.


Could anyone help me sort out what I've done wrong? I admit I might not be an expert on encryption, but following the rather simple guide for SecureVNCPlugin, this should have worked?

Best Regards

Teazle

edit: I noticed that the UltraVNC Server for x64 is labeled "VNC Server for win32" - wrong label, or could this be the source of my problem?
Last edited by Teazle on 2011-04-05 14:26, edited 2 times in total.
Teazle
8
8
 
Posts: 19
Joined: 2011-02-26 20:11

Re: UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby Eagle » 2011-04-03 20:10

I'm seeing something very similar.

Server and Client XPSP3 UltraVNC Pre 1.0.9.6 dated March 11, 2011.

Installed latest UltraVNC 1.0.9.6 dated April 1, 2011 and from that point I'm not able to connect to either machine. Even if both computers were installed with the April 1st release the error messages are same.

I'm getting the same error messages as you are seeing. I'm thinking something in the April 1st build did not get compiled correctly, or upgrading from a prior version did not get done correctly. I tried using the full install dated April 1, 2011 on both computers without any luck.
Eagle
 
Posts: 7
Joined: 2007-01-27 03:28

Re: UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby redge » 2011-04-03 21:50

i don't know if this could help

2 version of securevncplugin.dsm 2.3.0.0 exist
i see only one way for identify the difference only by size of file.

* single thread (404'992 bytes) adzm
* multi-thread (412'104 bytes) Rudi De Vos

or opposite

not related to multi connexion, both accept multi-viewers and are thread safe

i hope i'm not confusing.
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby Rudi De Vos » 2011-04-03 23:10

The check
"You have specified an encryption plugin, however this connection is unencrypted"
was disabled for SecureVNCPlugin.

I enabled this back as i found no reason why it should be disabled...

Possible the check need to be disabled for this plugin to allow the auto detection to work.

I will test this tomorrow again.

This was a viewer change, done after the prerelease :(
Last edited by Rudi De Vos on 2011-04-03 23:13, edited 2 times in total.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby Eagle » 2011-04-03 23:17

Looked at the file size for SecureVNC Pluggin. In the pre 1.0.9.6 (March 18th) the file size is 412,104 and in the 1.0.9.6 (April 1st) the file size is 412,920. But, when I did the install if the pre 1.0.9.6 was installed it did not over right the 1.0.9.6 (April 1) with the larger file.

It was possible to connect from the pre 1.0.9.6 (March 18th) to the 1.0.9.6 (April 1st) after doing a clean install with the April 1 release. But, I've not found a way to connect from the 1.0.9.6 (April 1st) release to the March release.

Hope any of this helps to make sense.
Last edited by Eagle on 2011-04-04 03:54, edited 1 time in total.
Eagle
 
Posts: 7
Joined: 2007-01-27 03:28

Re: UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby Eagle » 2011-04-04 03:51

Rudi De Vos

You could be right. I installed 1.0.9.6 (April 1st) in a clean install and then renamed the (March 18th) vncviewer.exe to vncviewerpre.exe so they could be in the same directory.

The March 18, 1.0.9.6 vncviewerpre.exe would connect to the 1.0.9.6 (April 1st) install, but the April 1, 1.0.9.6 vncviewer.exe still has the errors.

Thanks
Last edited by Eagle on 2011-04-04 03:55, edited 1 time in total.
Eagle
 
Posts: 7
Joined: 2007-01-27 03:28

Re: UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby twagner » 2011-04-04 13:47

i`ve the same effect than eagle,
the vncviewer 20110318 md5:548d383fa0dc8a293392c44b4677ff0f works good with the SecureVNCPlugin.dsm and the winvnc.exe server 20110401 in service- and application mode, too
the vncviewer 20110401 md5:6fb719d29f61bdb8895cd52bb9a048a0 don`t work with the the SecureVNCPlugin.dsm and the winvnc.exe server 20110401 in service- and application mode, too. It will only work without the SecureVNCPlugin.dsm.

twagner
Die Welt geht Remote . . . . / the World goes remote . . . .
www.vnc-world.com
Writer of the first book about UltraVNC!!!
twagner
40
40
 
Posts: 74
Joined: 2008-09-09 20:43
Location: Germany

Re: UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby Kirck » 2011-04-04 15:08

Same error
Kirck
20
20
 
Posts: 52
Joined: 2005-06-16 08:41

Re: UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby Rudi De Vos » 2011-04-04 16:24

Corrected, and all file re-uploaded.
Error was in vncviewer, you only need to replace the viewer
( can be extracted from the bin zip downloads)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby Teazle » 2011-04-04 17:49

Thank you for the fix, however I had a slight problem with it:

I could not establish an encrypted connection, SecureVNC was active but no encryption. This was solved via creating new keys and then... actually... crashing VNC Server. I'm quite sure a reboot would have done the deed aswell.

Many Thanks

Teazle
Last edited by Teazle on 2011-04-04 18:11, edited 2 times in total.
Teazle
8
8
 
Posts: 19
Joined: 2011-02-26 20:11

Re: UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby rsutton » 2011-04-04 17:56

I have been experiencing the same issues described above. Today's fix (reupload) fixed the problem for me.

Thanks, Rudi...

Dick
rsutton
8
8
 
Posts: 31
Joined: 2008-02-15 16:51

Re: UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby Kirck » 2011-04-05 12:49

fixed, thanks
Kirck
20
20
 
Posts: 52
Joined: 2005-06-16 08:41

Re: [Fixed] UltraVNC 1.0.9.6 + SecureVNC 2.3.0.0 Broken?

Postby RWilkes » 2014-05-13 17:43

Having the same issue w/ Viewer ver 1.1.96 (32 bit) and SecureVNC 2.3.0.0. Don't really want to downgrade 5 releases...
What's the "permanent" fix?
RWilkes
 
Posts: 2
Joined: 2006-08-16 17:16
Location: Miami, FL USA


Return to 1.0.9.6 (stable)

Who is online

Users browsing this forum: No registered users and 1 guest

cron