Unable to CTRL-ALT-DEL

Unable to CTRL-ALT-DEL

Postby WHairstonLOI » 2011-04-04 21:34

I have several machines that I recently upgraded from 1.0.8.2 to 1.0.9.5, then to 1.0.9.6. All worked well with CTRL-ALT-DEL support on v1.0.8.2.

My Windows SBS 2008 x64 machine and my Windows 7 x64 machine will no longer accept CTRL-ALT-DEL commands from any VNC viewer/client (physical keyboard still works) when running v1.0.9.5 or v1.0.9.6.

My Windows SBS 2003 x86 and Windows XP x86 boxes still work fine when sent a CTRL-ALT-DEL sequence with v1.0.9.5 and v1.0.9.6.

I've tried the GPO setting for SAS specified in the FAQ, but no luck.

Any suggestions?
WHairstonLOI
 
Posts: 5
Joined: 2011-04-04 21:27

Re: Unable to CTRL-ALT-DEL

Postby B » 2011-04-04 21:38

Is UAC on or off?

Is WinVNC running as a service?

Is the old CAD.EXE still present in the service directory?
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05

Re: Unable to CTRL-ALT-DEL

Postby Rudi De Vos » 2011-04-04 22:28

Was the update done via the upgrade exe or extracted from the zip ?

If you used the zip.

Try to manual start winvnc.exe ( while service isn't running".
Do get some warning popup " internet downloaded file"...
In that case, the file is market as unsecure (ntfs security)
You need to copy the file to a usb stick (FAT) and back to remove this
bit.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5295
Joined: 2004-04-23 10:21

Re: Unable to CTRL-ALT-DEL

Postby ken » 2011-04-05 14:54

I have this same problem, but I thought it was SmartCode. I see now it was UltraVNC.
ken
8
8
 
Posts: 11
Joined: 2009-04-06 21:29

Re: Unable to CTRL-ALT-DEL

Postby Rudi De Vos » 2011-04-05 16:28

Info on the method used in 1096.

http://msdn.microsoft.com/en-us/library ... 61(v=vs.85).aspx
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5295
Joined: 2004-04-23 10:21

Re: Unable to CTRL-ALT-DEL

Postby ken » 2011-04-05 22:13

Arg, stupid UAC! I need it OFF for lots of stuff, now I find out I need it ON for this.
ken
8
8
 
Posts: 11
Joined: 2009-04-06 21:29

Re: Unable to CTRL-ALT-DEL

Postby Rudi De Vos » 2011-04-06 07:10

If winvnc run as service, uac don't need to be ON.
see previous msdn link.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5295
Joined: 2004-04-23 10:21

Re: Unable to CTRL-ALT-DEL

Postby WHairstonLOI » 2011-04-06 18:50

It took me a couple of days to revisit the site where the SBS 2008 x64 box is located (since I can't connect via VNC now - LOL)...

1. All upgrades to v1.0.9.5/v1.0.9.6 of UltraVNC were done by downloading/running the upgrade.exe over an existing/working v1.0.8.2 installation.
2. UAC is ON.
3. UltraVNC Server IS running as a service.
4. The old CAD.EXE file is still present, although I have tried renaming it to CADOLD.EXE and restarting the service (no change in behavior). Currently exists as CAD.EXE.

It appears the new approach is for v1.0.9.5+ to use the Microsoft SAS.DLL library - I have searched the entire C: drive of my SBS 2008 x64 machine, but this file does not exist. (The MSDN documentation referenced above says it does not ship with this version of Windows.) Is this file actually distributed/installed with the UltraVNC upgrade? Is this something I need to manually copy/register seperately?
WHairstonLOI
 
Posts: 5
Joined: 2011-04-04 21:27

Re: Unable to CTRL-ALT-DEL

Postby Rudi De Vos » 2011-04-06 19:02

I think we found it...you have a 2008 R1 server.
Sas.dll only exist native on 2008 R2.

http://www.uvnc.eu/download/sas64.zip

This is the Vista64 dll, this should also work on 2008 R1

This need to be in the same folder as winvnc.exe

I don't have a R1 for testing.

re-uploaded UltraVNC_1.0.9.6_x64_update.exe
to auto add sas.dll
Last edited by Rudi De Vos on 2011-04-06 19:12, edited 2 times in total.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5295
Joined: 2004-04-23 10:21

Re: Unable to CTRL-ALT-DEL

Postby WHairstonLOI » 2011-04-06 19:36

Thanks Rudi, I'll download and give this a try when I return to that site later this week. (Yes, SBS 2008 is based on Vista/Server 2008 R1 code, whereas the newer SBS 2011 is based on Win7/Server 2008 R2 code.) I'm assuming I'll also have to regsvr this DLL file.

Just a thought: you might want to correct and update ALL of the v1.0.9.6 installers (both x86 and x64, full setup and update packages), as the MSDN documentation states that the SAS.DLL file is only natively available on Win 7/Server 2008 R2. This would mean that the file needs to be added to any Vista/Server 2008 R1 machine, x86 or x64 versions.

Unfortunately, I'm still having the same issue with my Windows 7 x64 workstation - any more ideas?
WHairstonLOI
 
Posts: 5
Joined: 2011-04-04 21:27

Re: Unable to CTRL-ALT-DEL

Postby Rudi De Vos » 2011-04-06 20:25

Full setup was OK
only update 108-109 was incorrect for X64
Last edited by Rudi De Vos on 2011-04-06 20:27, edited 1 time in total.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5295
Joined: 2004-04-23 10:21

Re: Unable to CTRL-ALT-DEL

Postby Rudi De Vos » 2011-04-06 20:35

win7 x64
did you already checked
How to configure your OS to accept ctrl+alt+del
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5295
Joined: 2004-04-23 10:21

Re: Unable to CTRL-ALT-DEL

Postby WHairstonLOI » 2011-04-06 20:42

Thanks - that solved the problem on the Win 7 x64 computer.

I had to use the "workgroup" option on my Windows 7 x64 PC, although it is on a domain. The domain controller is a SBS 2003 server, which didn't have that group policy option.
WHairstonLOI
 
Posts: 5
Joined: 2011-04-04 21:27

Re: Unable to CTRL-ALT-DEL

Postby ken » 2011-04-06 21:08

All my machines are Win7 x64, and I deployed UltraVNC with SmartCode. I can't manage them now. Smartcode does deploy vnc as a service.
:(
How do I go about fixing this?
ken
8
8
 
Posts: 11
Joined: 2009-04-06 21:29

Re: Unable to CTRL-ALT-DEL

Postby Rudi De Vos » 2011-04-06 21:43

The policies can be managed remote and when you have a domain policy you only need to set it once.

How to configure your OS to accept ctrl+alt+del

mmc gpedit.msc /a /computer=ABC
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5295
Joined: 2004-04-23 10:21

Re: Unable to CTRL-ALT-DEL

Postby ken » 2011-04-07 14:06

Thanks, that did it. 8)
ken
8
8
 
Posts: 11
Joined: 2009-04-06 21:29

Re: Unable to CTRL-ALT-DEL

Postby WHairstonLOI » 2011-04-07 18:50

I just noticed that even though CTRL-ALT-DEL is recognized, the screen doesn't refresh. I usually have to use the toolbar "refresh" button to "see" the logon prompt - any solution for this?
WHairstonLOI
 
Posts: 5
Joined: 2011-04-04 21:27

Re: Unable to CTRL-ALT-DEL

Postby Rudi De Vos » 2011-04-07 19:30

Check polling options, is fullscreen [v]
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5295
Joined: 2004-04-23 10:21

Re: Unable to CTRL-ALT-DEL

Postby B » 2011-04-07 20:45

That's weird; thanks Rudi. I haven't touched my setup in months, but I was having terrible redisplay problems today -- I had to keep refreshing. Checking full screen under polling options helped. (And I'm back on 1.0.8.0.)
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05

Re: Unable to CTRL-ALT-DEL

Postby GTA_doum » 2011-04-22 06:47

Hi,
Have same problem on 2008 Server 32 bits ! What could I do to make it work ?
I did the upgrade from 1082 to 1096...
Thanks,
Dominic Russell
GTA_doum
8
8
 
Posts: 19
Joined: 2009-02-11 02:48

Re: Unable to CTRL-ALT-DEL

Postby GTA_doum » 2011-05-06 21:48

Installed 1.0.9.6.1 update, but still not working...
Thanks,
Dominic Russell
GTA_doum
8
8
 
Posts: 19
Joined: 2009-02-11 02:48


Re: Unable to CTRL-ALT-DEL

Postby GTA_doum » 2011-05-10 11:30

Hello,

Uncompressed with a paid version of WinRAR, copied to my computer, and to the server via Remote Dektop.

Still, Ctrl-Alt-Del not working !
Thanks,
Dominic Russell
GTA_doum
8
8
 
Posts: 19
Joined: 2009-02-11 02:48

Re: Unable to CTRL-ALT-DEL

Postby GTA_doum » 2011-05-11 03:56

Thanks,
Dominic Russell
GTA_doum
8
8
 
Posts: 19
Joined: 2009-02-11 02:48

Re: Unable to CTRL-ALT-DEL

Postby B » 2011-05-11 14:18

But that's the same solution Rudi gave you a week ago?
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05

Re: Unable to CTRL-ALT-DEL

Postby GTA_doum » 2011-05-12 02:20

I reread this post to better understand...

I couldn't understand the first time I came to this post, 'cause I did not know what a UAC was, and where to set it !!
Also there is a lot of other information, for which I did not need to fix my problem... Hence, the post I mention, which helped me find UAC setting and get my attention only to it. Also, the post I found mention about the group policy editor that could be called by another file name...

I wanted to post it here in case someone, like me, wanted a quick fix easy to follow for his 32 bits server...
Thanks,
Dominic Russell
GTA_doum
8
8
 
Posts: 19
Joined: 2009-02-11 02:48

Re: Unable to CTRL-ALT-DEL

Postby donniedarko » 2012-07-24 19:43

On a Win 7 machine, you must have UAC on. Keep it on the default setting. Next, have the PC logged in and unlocked. Remote into it with Ultravnc. Hit the button to send ctl alt delete command. You will see 2 popup messages, one I think is the UAC prompt, the other asks if you want to let ultravnc make changes to the registry. Say yes to all the popups. Now hit the ctl alt delete button again and you'll see the Win 7 PC at the lock/switch user/logoff etc. screen. You can now send ctl alt delete commands to it whether it is locked/logged off or unlocked.
donniedarko
 
Posts: 1
Joined: 2012-07-24 19:37

Re: Unable to CTRL-ALT-DEL

Postby eric0326981 » 2014-06-30 15:42

this will fix the issue permenantly at least it did for me

click the start button
type gpedit.msc in the search bar
on the left pane at the top computer configuration
scroll to administrative templates then at the bottom of that
windows components then scroll down to windows logon options
then double click on the bottom one on the right hand panel
disable or enable software secure attention sequence
then on the top left click on the enable button then on the scroll down bar under options click services then click apply at the bottom and close out

do this on the computer you are trying to connect too
eric0326981
 
Posts: 1
Joined: 2014-06-30 15:35


Return to 1.0.9.6 (stable)

Who is online

Users browsing this forum: No registered users and 1 guest

cron