View Only with 1.0.9.6 Install on WindowsXP

View Only with 1.0.9.6 Install on WindowsXP

Postby DDD » 2011-04-06 10:12

I have got a Problem with the new version.
I do the same install on XP 32bit SP3 with 1095 and 1096 and
can only see the Screen with the 96 Version, but can't make inputs.
The two passwords are different.
uvnc ist running in service Mode.

here is my ini file:

[Permissions]
[admin]
UseRegistry=0
MSLogonRequired=0
NewMSLogon=0
DebugMode=0
Avilog=0
path=C:\Programme\UltraVNC
DebugLevel=0
DisableTrayIcon=0
LoopbackOnly=0
UseDSMPlugin=0
AllowLoopback=0
AuthRequired=1
ConnectPriority=0
DSMPlugin=
AuthHosts=
DSMPluginConfig=
AllowShutdown=1
AllowProperties=1
AllowEditClients=1
FileTransferEnabled=1
FTUserImpersonation=1
BlankMonitorEnabled=1
BlankInputsOnly=0
DefaultScale=1
CaptureAlphaBlending=1
BlackAlphaBlending=0
primary=1
secondary=0
SocketConnect=1
HTTPConnect=0
XDMCPConnect=0
AutoPortSelect=1
PortNumber=5900
HTTPPortNumber=5800
IdleTimeout=0
RemoveWallpaper=1
RemoveAero=0
QuerySetting=2
QueryTimeout=10
QueryAccept=0
QueryIfNoLogon=1
InputsEnabled=1
LockSetting=1
LocalInputsDisabled=0
EnableJapInput=0
kickrdp=0
clearconsole=0
[admin_auth]
group1=
group2=
group3=
locdom1=0
locdom2=0
locdom3=0
[ultravnc]
passwd=XXX
passwd2=XXX2
[poll]
TurboMode=1
PollUnderCursor=0
PollForeground=0
PollFullScreen=1
OnlyPollConsole=0
OnlyPollOnEvent=0
MaxCpu=40
EnableDriver=0
EnableHook=1
EnableVirtual=0
SingleWindow=0
SingleWindowName=


Any Idea?
Last edited by DDD on 2011-04-06 10:13, edited 1 time in total.
DDD
8
8
 
Posts: 9
Joined: 2011-04-06 09:59
Location: DE

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby Rudi De Vos » 2011-04-06 11:04

Looks ok, but can't import the settings now, for testing.

What you could do.

1) Copy winvnc.exe to a user,tmp folder
2) Start winvnc.exe in this folder
This create a new ultravnc.ini as soon as you enter the 2 passwords.
passwd is limited to 8 chars, make sure full and viewonly differ in the
first 8.
3) Try to connect ( winvnc is now running as application).

When this works, copy the ultravnc.ini over the one in program files.
Last edited by Rudi De Vos on 2011-04-06 11:05, edited 1 time in total.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5679
Joined: 2004-04-23 10:21

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby marks3162 » 2011-04-07 03:16

Same here....WinXP...viewer only...no inputs.
marks3162
 
Posts: 4
Joined: 2011-04-07 03:14

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby DDD » 2011-04-07 05:40

My 2 Passwords are completely different.

I will try your recommendation later.
DDD
8
8
 
Posts: 9
Joined: 2011-04-06 09:59
Location: DE

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby Rudi De Vos » 2011-04-07 07:35

OS server ?
Server running as service/application ?

UAC block input from non service applications as soon as you have
one elevated window open.

If you started winvnc manual ( not as service) and you open a window
that requested uac elevation, then as long as this window is open the uac
protection block winvnc input.
Last edited by Rudi De Vos on 2011-04-07 07:39, edited 1 time in total.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5679
Joined: 2004-04-23 10:21

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby DDD » 2011-04-07 07:37

OS Server = WindowsXP SP3 Professional
OS Client = WindowsXP SP3 Professional & Windows Vista Enterprise

Server running as Service
DDD
8
8
 
Posts: 9
Joined: 2011-04-06 09:59
Location: DE

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby Rudi De Vos » 2011-04-07 07:41

1)
full and viewonly passwd differ

2)
Server options: disabled input on/off
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5679
Joined: 2004-04-23 10:21

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby DDD » 2011-04-07 08:34

1) Copy winvnc.exe to a user,tmp folder
2) Start winvnc.exe in this folder
This create a new ultravnc.ini as soon as you enter the 2 passwords.
passwd is limited to 8 chars, make sure full and viewonly differ in the
first 8.
3) Try to connect ( winvnc is now running as application).
When this works, copy the ultravnc.ini over the one in program files.

i tried this, i can connect to the VNC in application mode with write Permissions (i can move the Mouse on the Client), but the Screen stay black on the Client.
the second time i connect to the server, the Client Application doesn't react any more and show only password accepted :roll:

Another strange thing is, when i shut down the viewer, the Server doesn't recognise it and the vnc icon is still yellow in the Taskbar.

UAC i don't have here on WindowsXP
Last edited by DDD on 2011-04-07 08:35, edited 1 time in total.
DDD
8
8
 
Posts: 9
Joined: 2011-04-06 09:59
Location: DE

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby Rudi De Vos » 2011-04-07 09:41

XP: then uac stuff can be excluded

The only thing i can think of is that some firewall like application is messing with the communication, it almost look like data can only flow in one direction.
video: server>viewer or input: viewer->server

You could activate vnclog ( server), you never know if some errors
popup in this file.

If you invert the server/viewer ( run winvnc.exe on the pc now running vncviewer.exe), do you still get the same results.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5679
Joined: 2004-04-23 10:21

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby DDD » 2011-04-07 10:22

Why should a firewall block only uvnc 1096 and not 1095?
DDD
8
8
 
Posts: 9
Joined: 2011-04-06 09:59
Location: DE

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby Rudi De Vos » 2011-04-07 10:41

Indeed, if it works with 1095 and not with 1096...
Unless Firewall is exe based and not port based.

If your firewall ( windows) allow winvncv1095 to pass the firewall
it isn't certain that after you change the exe, crc change, it still have access.

To be sure, just add tcp port 5900, then it is exe independed.

So it was working with 1095 ?
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5679
Joined: 2004-04-23 10:21

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby DDD » 2011-04-07 10:47

it works fine with 1095, only 1096 have this problem.
DDD
8
8
 
Posts: 9
Joined: 2011-04-06 09:59
Location: DE

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby Rudi De Vos » 2011-04-07 12:32

No idea anymore, let see if some other people have xp trouble.
1096 was tested on xp, but you never know...
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5679
Joined: 2004-04-23 10:21

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby DDD » 2011-04-07 12:38

marks3162: What antivirus software do you use? I use KAV 6.0.
DDD
8
8
 
Posts: 9
Joined: 2011-04-06 09:59
Location: DE

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby Eagle » 2011-04-07 12:51

Not able to recreate the problem going 1.0.9.6 to 1.0.9.6.

Started the VNC server in manual mode. Two computers both using XP SP3. Passwords set different for full mode and view only mode.

Connecting in full mode there is no limits on the screen. I'm able to move the mouse and launch other application.
Eagle
 
Posts: 7
Joined: 2007-01-27 03:28

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby DDD » 2011-04-07 13:12

My viewer was an 1082, with the new viewer a am able to move the mouse.
This was the Problem.
But why it doesn't work with 1082 viewer?

Edit: 1095 Viewer also without Problems.
Seems like the older ones aren't compatible with the 1096 Server.
Last edited by DDD on 2011-04-07 13:20, edited 1 time in total.
DDD
8
8
 
Posts: 9
Joined: 2011-04-06 09:59
Location: DE

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby Rudi De Vos » 2011-04-07 13:23

1082= rfb3.3
1095/6= rfb3.8

The 1096 viewer can do rfb3.3 and rfb3.8.
The 1096 server is rfb3.8.

Damm seems i always ask the wrong questions... why didn't i asked for
the viewer version :)

Good you found the cause...i started wondering if we missed something
in 1096.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5679
Joined: 2004-04-23 10:21

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby DDD » 2011-04-07 13:29

thanks folks :)
DDD
8
8
 
Posts: 9
Joined: 2011-04-06 09:59
Location: DE

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby onesolo » 2011-08-04 18:24

Help!!!

I also have this problem for some time...

my client machine is Win 7 x64, and I have this problem on two "server" machines, one Win7 x32 and other is a Winxp x32 machine!!!!
On my machine and on the Win7 I have 1.0.9.6.1 version and on the xp machine I have 1.0.9.6
Both passwords are different...
Oh and if I specify a longer password I cannot input it on the password box when asking to enter the machine... only part of it...
onesolo
 
Posts: 2
Joined: 2009-02-10 12:06

Re: View Only with 1.0.9.6 Install on WindowsXP

Postby B » 2011-08-04 20:03

You might want to double check Admin Properties, Keyboard and Mouse, Disable Viewers inputs [sic].

Recently that had somehow magically changed on me; I have no idea why, and I had to uncheck the box to allow proper remote control again.
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05


Return to 1.0.9.6 (stable)

Who is online

Users browsing this forum: Bing [Bot] and 1 guest