VNCviewer Bug -- No Warning when connecting to a Non-encrypt

VNCviewer Bug -- No Warning when connecting to a Non-encrypt

Postby YY » 2011-04-09 02:45

When the viewer specifies using a dsmplugin, if connecting to a server not using encryption, the viewer should pop up a warning window of "Accept insecure connection". However, this feature is broken on 1.0.9.5 and 1.0.9.6, the connection is established without this warning. Even worse, when checking the viewer's Connection Info, it reported the configured dsmplugin was being used.

Both normal and reverse connection have this problem.


Have verified with 1.0.8.2 viewer, no such bug.
YY
200
200
 
Posts: 996
Joined: 2006-11-13 15:11

Re: VNCviewer Bug -- No Warning when connecting to a Non-enc

Postby redge » 2011-04-09 23:05

bug confirmed

uvnc 1.0.9.6 release vncviewer date 4.4.2011 and winvnc 1.4.2011
vnc viewer status HOSTNAME
Status: Connected (SecureVNCPlugin-v2.3.0.0)
In progress (no encryption)

viewer use encryption plugin but not server

options.vnc

UseDSMPlugin=1
DSMPlugin=SecureVNCPlugin.dsm
AutoAcceptIncoming=0
AutoAcceptNoDSM=0
RequireEncryption=0
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: VNCviewer Bug -- No Warning when connecting to a Non-enc

Postby redge » 2011-04-17 02:34

vncviewer 10961 (15 April)
winvnc 10961 (16 April)

short test
winvnc NO plugin
vncviewer with securevncplugin.dsm


vncviewer
ok direct connection, message and prompt pwd + conexion OK
ok via repeater ID message and connection OK

not tested from comand line, tested only from vncviewer GUI
(no encryption)
Last edited by redge on 2011-04-18 18:51, edited 1 time in total.
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: VNCviewer Bug -- No Warning when connecting to a Non-enc

Postby YY » 2011-04-21 16:08

Still a minor defect.

The viewer's Connection Info still showing a plugin is used, in fact not.
Image
YY
200
200
 
Posts: 996
Joined: 2006-11-13 15:11

Re: VNCviewer Bug -- No Warning when connecting to a Non-enc

Postby Rudi De Vos » 2011-04-21 17:20

Technical, plugin is used even without encryption.

Message
Status: Connected (SecureVNCPlugin-v2.3.0.0)
In progress (no encryption)

Older plugins get unloaded,
SecureVNCPlugin-v2.3.0.0 stay loaded, even when not used.

This change in behaviour caused the initial error.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21


Return to 1.0.9.6 (stable)

Who is online

Users browsing this forum: No registered users and 2 guests

cron