Viewer fails to update display

Viewer fails to update display

Postby ksch11 » 2011-05-10 14:02

Hello.

We are using the current versions of UltraVNCViewer, the UVNC-Repeater and UVNC-Server-SC.
(Viewer x64 1.0.9.6, UltraVnc Linux Repeater version 0.14, Ultr@VNC Win32 Server SC 20.3 (Build Aug 26 2009))

We often experience a problem during remote control session und often can reproduce it with the following scenario: The server is started on a Windows XP Machine by a custom program, the viewer on a Windows 7 computer. When opening an instance of Internet Explorer on the remote machine through the viewer, the viewer will not show any screen updates no more, although it still submits the mouse and the keyboard events to the remote machine. Requesting to refresh the screen doesn't have any effect. Sometimes, after some minutes everything starts working normally again. Also, when the Internet Explorer window is closed the screen immediately gets refreshed.
I tried several settings in the server configuration but none seemed to help.
At least, the problem is not bound to Internet Explorer but arises with the windows of some other programs, too.

Can somebody give me a hint how to solve this problem, please?
ksch11
 
Posts: 3
Joined: 2011-05-10 13:30

Re: Viewer fails to update display

Postby B » 2011-05-10 15:33

Try turning on "capture alpha blending" in UltraVNC on the server side.
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05

Re: Viewer fails to update display

Postby ksch11 » 2011-05-11 09:15

Since we're using the SC version of winvnc there is no admin option to turn on alpha blending.
But with the hint from another discussion "Alpha blending + Video Hook Driver, not working together" (https://forum.ultravnc.net/viewtopic.php?f=3&t=26900 we deactivated "System Hook Dll" form the "Properties" menu - and it seems to work.
I now just removed the dlls SCHook.dll and vnchooks.dll from the deployment - which seems to have no influence on operation (?). We will see how it works on the other machines...
Thank you for your help.
ksch11
 
Posts: 3
Joined: 2011-05-10 13:30

Re: Viewer fails to update display

Postby B » 2011-05-11 14:21

It's been a while since I did an SC, but I think you can still manipulate its Ultravnc.ini file -- the relevant settings are:

CaptureAlphaBlending=1 (enabled)
CaptureAlphaBlending=0 (disabled)
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05

Re: Viewer fails to update display

Postby ksch11 » 2011-05-12 10:28

To me it seems as if ultravnc.ini is read by the "normal" server ,but is ignored by SC.
Anyway - SC works well enough without the dlls ;-)...
ksch11
 
Posts: 3
Joined: 2011-05-10 13:30


Return to 1.0.9.6 (stable)

Who is online

Users browsing this forum: No registered users and 1 guest