What causes solid-colour viewer windows?

What causes solid-colour viewer windows?

Postby rcooke » 2011-09-19 14:24

What causes solid-colour client areas in the viewer?

I have seen this off and on during testing various features. The screen shot below is from a test of ChunkVNC Fork 3.1m.

This was through a repeater, and admittedly my outside network speed was likely slow. Does the encryption add a huge amount of over head?

And what about "speed 0"?

Image
Regards,
Richard Cooke
User avatar
rcooke
40
40
 
Posts: 96
Joined: 2011-02-19 13:06
Location: Toronto, Canada

Re: What causes solid-colour viewer windows?

Postby B » 2011-09-19 15:15

If this is at the welcome/login screen, please see my comment in your other thread.

If not, I don't know. :)
B
Super-Mod
Super-Mod
 
Posts: 2347
Joined: 2009-09-09 14:05

Re: What causes solid-colour viewer windows?

Postby rcooke » 2011-09-19 15:52

Sorry, I forgot some details I posted elsewhere.

Both machines are XP Pro going through the Perl repeater.

The plugin is enabled to get password access control, dont really care for encryption.

The server was logged in. I could move the mouse around and click on things.

No screen saver enabled.
Regards,
Richard Cooke
User avatar
rcooke
40
40
 
Posts: 96
Joined: 2011-02-19 13:06
Location: Toronto, Canada

Re: What causes solid-colour viewer windows?

Postby supercoe » 2011-09-19 18:13

AFAIK it's simply the initial color of the Viewer window while it waits for the Server to send a screen update.
Previous versions of the Viewer had a black color if I remember correctly.
http://www.chunkvnc.com - ChunkVNC - Free PC Remote control with the Open Source UltraVNC wrapper InstantSupport!
User avatar
supercoe
Super-Mod
Super-Mod
 
Posts: 1735
Joined: 2009-07-20 21:27
Location: Walker, MN

Re: What causes solid-colour viewer windows?

Postby rcooke » 2011-09-19 19:35

Thanks supercoe!

I suspected as much.

I think this "problem" is related to this post:
viewtopic.php?f=64&t=28648

In that both of use are getting to the state of having a blank (solid colour) viewer screen that never gets data from the server.

Well, likely not "never" in my case, just slow enough I gave up before it came in.
Regards,
Richard Cooke
User avatar
rcooke
40
40
 
Posts: 96
Joined: 2011-02-19 13:06
Location: Toronto, Canada

Re: What causes solid-colour viewer windows?

Postby supercoe » 2011-09-19 19:42

I don't know if this will help at all but I've had really good luck suggesting these ultravnc.ini settings to people lately:

PollForeground=1
PollFullScreen=0
PollUnderCursor=1
EnableHook=1

Remember to restart the Server after modifying the ultravnc.ini file.
http://www.chunkvnc.com - ChunkVNC - Free PC Remote control with the Open Source UltraVNC wrapper InstantSupport!
User avatar
supercoe
Super-Mod
Super-Mod
 
Posts: 1735
Joined: 2009-07-20 21:27
Location: Walker, MN


Return to 1.0.9.6 (stable)

Who is online

Users browsing this forum: No registered users and 3 guests