Server Not Listening/Won't Accept Socket

Server Not Listening/Won't Accept Socket

Postby ChrisCollins » 2014-02-26 23:18

Hello everyone. Thank all of you for reading my question.

I use UVNC on many of my machines, but I ran into a unique problem today.

Clean install (not upgrade) of latest released UVNC build on site. OS Win7/64. Installed as usual. UAC & Firewall are both off.

The server service says 'not listening'. Every time I open Admin Properties, Accept Socket Connects is unchecked, but all my other info is still there. I recheck the box to Accept, click apply, click ok... The server is still not listening. I go back into options and it is unchecked again.

The install was ran as admin, logged on user is admin.

I would very much appreciate any help you could offer me that may correct this problem.

Thanks,

Chris
ChrisCollins
 
Posts: 2
Joined: 2014-02-26 23:12

Re: Server Not Listening/Won't Accept Socket

Postby Rudi De Vos » 2014-02-27 11:19

Sol1 (port in use)
Are you using a fixed port ?
If yes, check if the port isn't used by another app, only one app can listen on a port.

Sol2 (ultravnc.ini error)
goto program file\uvnc... and delete the ultravnc.ini
copy winvnc.exe to some /tmp folder
run manual winvnc.exe, set passwd an other settings -> this create a ultravnc.ini in the same folder as winvnc.exe
copy ultravnc.ini from /tmp to program files/ uvnc...
The reason to copy the winvnc.exe to some tmp folder is to avoid file permission issue in program files ( this is a secure folder)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5471
Joined: 2004-04-23 10:21

Re: Server Not Listening/Won't Accept Socket

Postby ChrisCollins » 2014-02-28 05:54

Thank you Rudi. I will give Sol2 a shot in the morning when I get to the office. It's not the fixed port, but your second solution looks like that may be my problem.
ChrisCollins
 
Posts: 2
Joined: 2014-02-26 23:12


Return to 1.0.9.6 (stable)

Who is online

Users browsing this forum: No registered users and 1 guest