UltraVNC and x11vnc

UltraVNC and x11vnc

Postby balubeto » 2014-03-22 11:25

Hi

In Windows 7 SP1 64-bit, I use UltraVNC viewer 1.1.9.6 64-bit with the SecureVNCPlugin64.dsm plugin.

Now, I have a computer with Lubuntu 13.10 32 bit that it has installed the x11vnc server.

How can I configure the VNC server so that I can remotely control this Linux machine completely, including its Display Manager LightDM?

Thanks

Bye
balubeto
balubeto
40
40
 
Posts: 78
Joined: 2004-11-05 15:35

Re: UltraVNC and x11vnc

Postby Bonji » 2014-03-22 20:35

UltraVNC only runs on Windows. The viewer can connect to non-UltraVNC servers, however it goes back to a very basic feature-set that any other flavor of VNC supports.
-Ben
Bonji
100
100
 
Posts: 325
Joined: 2008-05-13 14:54

Re: UltraVNC and x11vnc

Postby balubeto » 2014-03-25 17:57

Bonji wrote:UltraVNC only runs on Windows. The viewer can connect to non-UltraVNC servers, however it goes back to a very basic feature-set that any other flavor of VNC supports.

Hi

From Linux, I wrote from the terminal:

sudo x11vnc -storepasswd /etc/x11vnc.pass


and then I created in the /etc/init directory the x11vnc.conf file and I wrote:

start on login-session-start
script
/usr/bin/x11vnc -xkb -auth /var/run/lightdm/root/:0 -noxrecord -noxfixes -noxdamage -rfbauth /etc/x11vnc.pass -forever -bg -rfbport 5900 -o /var/log/x11vnc.log
end script


but when I restarted the computer, I tried to connect with UltraVNC without the SecureVNCPlugin64.dsm plugin but the x11vnc server does not respond and it does not even create the log file. Where am I wrong?

Thanks

Bye
balubeto
balubeto
40
40
 
Posts: 78
Joined: 2004-11-05 15:35

Re: UltraVNC and x11vnc

Postby balubeto » 2014-03-25 19:14

Running this command from the terminal with the sudo command because there is the -o option, I get:

25/03/2014 18:30:24 passing arg to libvncserver: -rfbauth
25/03/2014 18:30:24 passing arg to libvncserver: /etc/x11vnc.pass
25/03/2014 18:30:24 passing arg to libvncserver: -rfbport
25/03/2014 18:30:24 passing arg to libvncserver: 5900
25/03/2014 18:30:24 x11vnc version: 0.9.13 lastmod: 2011-08-10 pid: 2733
No protocol specified
25/03/2014 18:30:24 XOpenDisplay(":0") failed.
25/03/2014 18:30:24 Trying again with XAUTHLOCALHOSTNAME=localhost ...
No protocol specified

25/03/2014 18:30:24 ***************************************
25/03/2014 18:30:24 *** XOpenDisplay failed (:0)

*** x11vnc was unable to open the X DISPLAY: ":0", it cannot continue.
*** There may be "Xlib:" error messages above with details about the failure.

Some tips and guidelines:

** An X server (the one you wish to view) must be running before x11vnc is
started: x11vnc does not start the X server. (however, see the -create
option if that is what you really want).

** You must use -display <disp>, -OR- set and export your $DISPLAY
environment variable to refer to the display of the desired X server.
- Usually the display is simply ":0" (in fact x11vnc uses this if you forget
to specify it), but in some multi-user situations it could be ":1", ":2",
or even ":137". Ask your administrator or a guru if you are having
difficulty determining what your X DISPLAY is.

** Next, you need to have sufficient permissions (Xauthority)
to connect to the X DISPLAY. Here are some Tips:

- Often, you just need to run x11vnc as the user logged into the X session.
So make sure to be that user when you type x11vnc.
- Being root is usually not enough because the incorrect MIT-MAGIC-COOKIE
file may be accessed. The cookie file contains the secret key that
allows x11vnc to connect to the desired X DISPLAY.
- You can explicitly indicate which MIT-MAGIC-COOKIE file should be used
by the -auth option, e.g.:
x11vnc -auth /home/someuser/.Xauthority -display :0
x11vnc -auth /tmp/.gdmzndVlR -display :0
you must have read permission for the auth file.
See also '-auth guess' and '-findauth' discussed below.

** If NO ONE is logged into an X session yet, but there is a greeter login
program like "gdm", "kdm", "xdm", or "dtlogin" running, you will need
to find and use the raw display manager MIT-MAGIC-COOKIE file.
Some examples for various display managers:

gdm: -auth /var/gdm/:0.Xauth
-auth /var/lib/gdm/:0.Xauth
kdm: -auth /var/lib/kdm/A:0-crWk72
-auth /var/run/xauth/A:0-crWk72
xdm: -auth /var/lib/xdm/authdir/authfiles/A:0-XQvaJk
dtlogin: -auth /var/dt/A:0-UgaaXa

Sometimes the command "ps wwwwaux | grep auth" can reveal the file location.

Starting with x11vnc 0.9.9 you can have it try to guess by using:

-auth guess

(see also the x11vnc -findauth option.)

Only root will have read permission for the file, and so x11vnc must be run
as root (or copy it). The random characters in the filenames will of course
change and the directory the cookie file resides in is system dependent.

See also: http://www.karlrunge.com/x11vnc/faq.html


So, how do I fix this?

Thanks

Bye
balubeto
balubeto
40
40
 
Posts: 78
Joined: 2004-11-05 15:35

Re: UltraVNC and x11vnc

Postby balubeto » 2014-03-26 11:40

Leaving the /etc/init/x11vnc.conf file and restarting the computer, I notice that the /var/run/lightdm/root/:0 file is created, but when I run the command sudo netstat -anp | grep 5900 or sudo netstat -nlp | grep vnc or sudo ps -ef | grep [x]11vnc , nothing is displayed.

So, I run from the terminal the command sudo /usr/bin/x11vnc -xkb -auth /var/run/lightdm/root/:0 -noxrecord -noxfixes -noxdamage -rfbauth /etc/x11vnc.pass -forever -rfbport 5900 -bg -o /var/log/x11vnc.log, the file /var/run/lightdm/root/:0 is created but the other commands always give the same result.

So, I rebooted the computer and gave the command sudo /usr/bin/x11vnc -auth /var/run/lightdm/root/:0 -display :0 but the same log file is displayed.

How come?

Thanks

Bye
balubeto
balubeto
40
40
 
Posts: 78
Joined: 2004-11-05 15:35

Re: UltraVNC and x11vnc

Postby Bonji » 2014-03-26 14:26

Your problem appears to be with the VNC server which is running x11vnc which is not supported by these forums. Try the support channels for x11vnc.
-Ben
Bonji
100
100
 
Posts: 325
Joined: 2008-05-13 14:54


Return to 1.0.9.6 (stable)

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest