Beta 1002

Re: Beta 1002

Postby Rudi De Vos » 2011-12-31 13:53

UPdate
http://www.uvnc.eu/download/setup_server.zip
http://www.uvnc.eu/download/setup_viewer.zip


*multiple groups ( del/add)
*better viewer icons
*added server info

Remove old ini file when updating, other syntax used.
Server and viewer are pairs, if you use this update, you need to update server and viewer.
(During Beta test protocol can change, this require server and viewer updates to keep both in sync)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby blackscorp » 2011-12-31 22:38

There appears to be a problem running settings.exe on win 7 x64 msvcr100.dll is missing, think it has been mentioned before, VS2010 needs to be installed?

Also how do we integrate this with the repeater function, as I would like it it work over proxies both directions...like the v1..

Thanks,
blackscorp
 
Posts: 2
Joined: 2011-12-31 22:35

Re: Beta 1002

Postby Rudi De Vos » 2012-01-01 14:01

setting.exe updated, should run without VS libs.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby Rudi De Vos » 2012-01-01 16:04

This verion use udp and not tcp, you can't use any http(s) proxies.

The software actual setup an encrypted tunnel between server and viewer (even when server and viewer are behind a nat router) , data never get transferred overa 3the server, but direct beween server and viewer.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby Rudi De Vos » 2012-01-03 00:38

Update:

settings.exe now also create a sfx (SC), if you save settings it ask to create one.
"Final got rid of the selfextracting warning that something was possible not good installed do to compatibility issue's)

Text can be edited via settings.exe ( custom button).
Bmp and Trayicon be replacing the files in the sfx subfolder.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby ProTekTech » 2012-01-04 18:56

Thanks so much for the software.
I have an issue with a program causing loss of control when server running in app mode.
Basically, when this program gains focus, I have no control over pc, but when focus is moved back to a different application, I gain control back.
This program is a port of a dos program and may run in some kind of protected instance?
I don't know if this is a bug or an example of UAC or something similar.
Thanks,
Aaron
ProTekTech
 
Posts: 1
Joined: 2012-01-04 18:41

Re: Beta 1002

Postby Rudi De Vos » 2012-01-04 22:52

If it is an UAC issue, running as application, the server need to have the same
elevated access. Running "runas admin" should give the server the same access
and your app to avoid being blocked by UAC.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby Mike » 2012-01-08 15:27

Hi Rudi,

first i have to thank you for your work an this great software.

Before a couple of weeks i tried the old PcHelpware and now i saw that there is a new version.
It looks realy good but it's not exactly that i'am looking for.


This is what i need:

- Enable users to show or see their desktops in LAN or via Internet.

- A quick and easy way to get connected.
For example:
One user starts the server the second User starts the viewer. The server-user tells the viewer-user a random number
generated by the server program. The viewer-user type the given number to the viewer program and the connection starts.

- Running my own access server listening to a port that is open on any firewall.


Do you think this is possible?

Best regards
Mike
Mike
 
Posts: 3
Joined: 2012-01-08 15:20

Re: Beta 1002

Postby Rudi De Vos » 2012-01-08 17:10

Mike, i think it's not possible to make a simpler connection.

1) You create a server sfx version via the create sfx button, this preset group and accesscode.
2) Send predefined server to server user.
3) User start server
4) User start viewer. The viewer show the "accesscode" of the PC as soon he is online.
5) The server user need to tell the password to the viewer user.
6) Viewer user open required module ( chat/desktop access..)

You can also preset the password, desktop access always need to be confirmed by the "server user". It isn't needed for the chat module,
but that isn't a high risk. If the password is set via the sfx creator, it is already set for the viewer. (All IN ONE creator version)

The current version works on lan and internet and bypass nat routers, it even bypass some corporate firewalls.

Once we go to release, a own "access server" is possible. I never tested it when he is behind a firewall, the nat punching require several
ports and outgoing ports are random ( we need to use the outgoing port of the nat router and he translate the fixed ports to some external random value)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby Mike » 2012-01-08 18:30

Hi Rudi,

i like to test this in detail but there is one problem.
The first try failed because our corporate firewall blocks the used port. So i presume that most of other firewalls will do the same.
Is it possible for your access server to listen to port 80 (for example) because this port should be open on any firewall?

Best regards
Mike
Mike
 
Posts: 3
Joined: 2012-01-08 15:20

Re: Beta 1002

Postby Rudi De Vos » 2012-01-08 22:18

Does you firewall also block outgoing ports ? Usual the only lock incoming ports.
Both viewer and server are making an outgoing connection, no incoming port is needed.
The local windows firewall block outgoing ports, but on first start it ask if the exe is allowed to call out.

PCHelpWareV2 use UDP, not TCP. Even if it use port 80 ( web access) the standard 80 port is tcp.
The reason we use UDP is that you only have outgoing ports and you don't need to allow or portforward anything on the routers.
Using tcp, you only can make direct connections ( one site outgoing, on site incoming)

Greetings
Rudi
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby mrreload » 2012-01-09 18:42

Bug
I cannot successfully run the Viewer 2 times in a row. It fails to connect to the group. It works on the first launch when it asks to setup the Group Name and password but not after closing it. I have to delete the .ini files to start over.
mrreload
8
8
 
Posts: 23
Joined: 2006-03-16 08:02

Re: Beta 1002

Postby Rudi De Vos » 2012-01-09 19:43

Please use the latest updates first ( links on this page were not the latest version, updated)

http://www.uvnc.eu/download/setup_server.zip
http://www.uvnc.eu/download/setup_viewer.zip

If it stay "offline" you can press the reload button ( next to the settings), this reinitiaze the "access server connection".
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby mrreload » 2012-01-09 22:39

Initially this newer version worked but now I am having he same issue. Hitting the refresh button has no effect. The viewer just does not connect.

How would I go about doing a fresh install? I tried uninstalling and reinstalling but it appears the settings do not get erased.

Should I be using RC1 AllinOne instead?
mrreload
8
8
 
Posts: 23
Joined: 2006-03-16 08:02

Re: Beta 1002

Postby Rudi De Vos » 2012-01-09 23:22

After a little testing i found a problem with setting a custom "save password".
It doesn't ask the password on startup, and read the ini file with empty password -> access servers are empty
Test without settings a "save password", it's broken...

erase ini
C:\Users\rudi\AppData\Roaming\uvnc\pchw\settings ( replace rudi by your own logon)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby Rudi De Vos » 2012-01-09 23:40

Bug corrected and setup_viewer.zip reuploaded.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby mrreload » 2012-01-09 23:46

Thanks Rudi,
Found another item, Installing server in XP results in server setting unable to launch. It does prompt for and install DOTNET 4. Then reboots and continues the install. But still unable to launch. Also it does not allow for Custom groupname during install, just goes to default.
On a Windows 7 x64 box it installs and works.
mrreload
8
8
 
Posts: 23
Joined: 2006-03-16 08:02

Re: Beta 1002

Postby Rudi De Vos » 2012-01-10 08:42

Damm MS msi installers.... i even don't use dotnet 4, but i guess MS installer does.

Development was done on win7,need to test it on XP.
Does both applications fail to start
"Server Settings PCHelpWareV2"
"PCHelpWareV2 Server"
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby blackscorp » 2012-01-10 11:37

Rudi De Vos wrote:This verion use udp and not tcp, you can't use any http(s) proxies.

The software actual setup an encrypted tunnel between server and viewer (even when server and viewer are behind a nat router) , data never get transferred overa 3the server, but direct beween server and viewer.


Sorry just to clarify, does that mean this will not work over proxies?

Thanks
blackscorp
 
Posts: 2
Joined: 2011-12-31 22:35

Re: Beta 1002

Postby Rudi De Vos » 2012-01-10 12:31

This doesn't work over a http proxy. You can't transmit udp over a tcp proxy.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby mrreload » 2012-01-11 15:43

Rudi De Vos wrote:Damm MS msi installers.... i even don't use dotnet 4, but i guess MS installer does.

Development was done on win7,need to test it on XP.
Does both applications fail to start
"Server Settings PCHelpWareV2"
"PCHelpWareV2 Server"


The server will manually start when clicked, but the Settings will not.

MSI installers are good for some things, but in this case not so much. Damn MSI installers.
mrreload
8
8
 
Posts: 23
Joined: 2006-03-16 08:02

Re: Beta 1002

Postby mrreload » 2012-01-11 18:33

[s]Still having the issue with the viewer apparently not reading the .ini file after the first launch. I am using a custom groupname and password.[/s]

Scratch that, found that my system didn't get the new version originally. Redownloading resolved. It now asks for password everytime. :D
mrreload
8
8
 
Posts: 23
Joined: 2006-03-16 08:02

Re: Beta 1002

Postby Mike » 2012-01-11 18:41

Hi Rudi,

i guess most of the corporate firewall follow the principle — everything which is not allowed is forbidden.
So it's not possible connecting the access server from within the lan. I checked the settings of the firewall and the only open udp port is 53 for dns queries.
Is it possible to use this port or is there another way to get through the Firewall?

Best regards
Mike
Mike
 
Posts: 3
Joined: 2012-01-08 15:20

Re: Beta 1002

Postby Rudi De Vos » 2012-01-12 10:56

Mike, if your company block all ports you can't use any server outsite your company. You are limited to
web based solution that only use 443 ( ssl).

Possible you have a dmz, run the viewer component on a dmz server and connect to it via rdp or vnc.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby sharonch » 2012-01-12 12:39

Wow, it looks like everyone knows how to use ini to make the viewer knows the password and control the server. I am thinking about writing some script to auto control the viewer. Is it possible to have the viewer read the password information from ini file? and how? so instead of manually type those password in the viewer, it reads some command to run?
sharonch
8
8
 
Posts: 10
Joined: 2011-12-15 08:25

Re: Beta 1002

Postby Rudi De Vos » 2012-01-12 20:55

mrreload,

Found, in XP you need to do special things in the source to use some gui stuff, if not it just doesn't create a window...LOL.
The DOTNETT4 stuff isn't needed, i tested in on XP version without DOTNET4 installed and that seems to work, only installer
3.1 seems to be required, but that exist by default in XP.

All re-uploaded
*DOTNET4 dependency removed
*XP fixed
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby Rudi De Vos » 2012-01-12 21:11

sharonch,

The viewer already read the server passwd from the ini file
And you enter the passwd onces via the gui
Image
Image

The ini file content is aes256 encrypted you can only import an ini in a viewer
if you use the same master password (AES password)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: Beta 1002

Postby mrreload » 2012-01-12 22:57

Rudi De Vos wrote:mrreload,

Found, in XP you need to do special things in the source to use some gui stuff, if not it just doesn't create a window...LOL.
The DOTNETT4 stuff isn't needed, i tested in on XP version without DOTNET4 installed and that seems to work, only installer
3.1 seems to be required, but that exist by default in XP.

All re-uploaded
*DOTNET4 dependency removed
*XP fixed


Rudi,
The server setup is working in XP now but I just tried it on another test box and the DOTNET4 requirement is still there. This test box is Win 7 64bit.

File dates are 1/12/12 2:50PM.
mrreload
8
8
 
Posts: 23
Joined: 2006-03-16 08:02

Re: Beta 1002

Postby dgwinnup » 2012-01-13 19:28

Rudi,

I am having trouble with the digital signature of my created SC from withing PCHelpware V2.

Is there a way that this created EXE will be signed so that users using Internet Explorer can download and run the EXE?

In the past versions, I had hosted the EXE on an FTP or HTTP location and emailed a link to my user who needed support. Now, they can't run the created exe unless I direct them to hit save and then "unblock" inside of the properties of the file.

Any help would be appreciated!

Thanks,

Derek
dgwinnup
 
Posts: 2
Joined: 2012-01-13 19:23

Re: Beta 1002

Postby Rudi De Vos » 2012-01-13 21:29

The Sc is created offline, this can not be signed with our key
Possible we can setup some future online tool for it.

Singing require private key and password...
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

PreviousNext

Return to pchelpwareV2 BETA

Who is online

Users browsing this forum: No registered users and 1 guest