bug: connection still open after client is closed

bug: connection still open after client is closed

Postby burzek » 2015-03-11 09:46

Hi,

Latest uvnc 1.2.0.5 , has problem on the server side, showing that client is still connected even after client disconnects.

This is happening randomly. It needs to be investigated in detail.

Please check for this bug.

Thanks.
burzek
8
8
 
Posts: 14
Joined: 2006-06-01 15:51

Re: bug: connection still open after client is closed

Postby Arno-BS » 2015-03-11 14:26

Hi,

same happens to me at least once a day.
In this case often (not always) a new connection displays only a grey or black screen, so remote PC cannot be used via VNC.

In these cases I connect to the remote PC via Remotedesktop and see two VNC Icons in the taskbar.
Then I kill uvnc service and restart it again. Then client connection runs fine (until next occurence of the mentioned scenario).

Regards
Arno
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Arno-BS » 2015-03-16 12:03

Hi again,

in above case sometimes it is possible to connect to the server via UltraVNC again, not only with a black screen but with full access to the server.
In this case when I have a look at the taskbar icon and "list all clients", there are two entries with identical IP-address. I think one of them then is my "actual" connection, the other is the old one which "hangs" and which should have been removed when disconnecting "old" client.

Regards
Arno
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Rudi De Vos » 2015-03-16 18:51

It's hard to repeat... we need to be able to repeat it in debug mode.

Looks like the server crash or deadlock.
A crash show some dialog box, but it is not visable, app was stared by service.
The server deadlocked, some internal loop
Both have the same effect winvnc.exe exist and looks frozen.

It's hard to tell if the server crashed on connect or on disconnect.
Can you activate vnclog.log, perhaps there is some info in it that indicate crash time.

How is the connection made:
viewer connect to server ?
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5751
Joined: 2004-04-23 10:21

Re: bug: connection still open after client is closed

Postby Arno-BS » 2015-03-20 11:04

Yes, connection is initiated from viewer (Win 7 Pro x64) to server (Win 8.1 Pro x64).

And indeed it seems to be difficult to reproduce this error.
So far - since I activated logfile - the error didn't occur.

I will see and attach logfile if it will happen again.

Regards
Arno
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Arno-BS » 2015-03-26 15:20

So today (03/26) it happened again.
All connections have been done from client to server.

1. Last working connection: don't know the time, must have been before 14:55.
2. Connection started at about 14:56 led to a grey screen on client, so not able to use the server.
I waited some time, but screen stayed gray, then I closed the client.
3. Connection started at about 15:09 or 15:10 was o.k.
Then I had a look on server's taskbar icon and did a "List all Clients" which diplayed two "Currently Connected Clients" with identical IP-address.
4. Next connection later didn't work, got a complete black screen on client.

Then I connected to server via RDP, killed vncserver tasks and restarted vncserver service.
Next connection then was o.k.

http://www.protel-computer.de/WinVNC.zip
Hope you will find something in the logfile.

Regards
Arno
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Arno-BS » 2015-04-16 10:39

I'd like to ask if the log file already is under investigation.
I often have this problem and would appreciate this bug to be fixed.

@burzek, who started this post: do you still run into this bug or did you get it fixed by yourself?

Regards
Arno
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Skyfighter » 2015-04-17 19:33

Unfortunately I see the same Problem on regular basis: viewer (Win 8.1 Pro x64) to server (Win 8.1 Pro x64).

For now I don't have any log-files, but it might be provokable by interrupting the network (switch off wifi / disable network adapte / pull the network cable)...I am not sure about that.
Skyfighter
40
40
 
Posts: 95
Joined: 2014-12-31 22:10

Re: bug: connection still open after client is closed

Postby Rudi De Vos » 2015-04-20 08:13

Seems to be a loop, but hard to repeat in debug mode.

I gonna setup a 24h win8 pc with the server running in debug and try to connect from time to time.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5751
Joined: 2004-04-23 10:21

Re: bug: connection still open after client is closed

Postby Arno-BS » 2015-05-05 14:23

Any ideas so far?

I regularly run into this issue and it is a little bit annoying.

When I'm able to create a new connection in this case and I see two identical IP addresses in "list all clients", the function
"Kill all clients" kills correctly the actual connection but not the old idle one.

Restarting Winvnc service helps, so perhaps (as mentioned in another thread) a new option "restart VNC service when disconnecting" would also be helpful until this bug is fixed.

Regards
Arno
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Rudi De Vos » 2015-05-06 20:24

Looks like it happen only when
win8>=
w8hook used

latest message before the loop is "set W8 hooks"

If someone who can easy repeat it could disable the w8hook and test if it still happen, then i could already exclude
95% of the source.

*to disbale the w8hook, rename the w8hook.dll to w8hook2.dll
*if w8hook doesn't exist, the vnchook is used.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5751
Joined: 2004-04-23 10:21

Re: bug: connection still open after client is closed

Postby burzek » 2015-05-07 08:32

Hi,

I tried to solve this problem by a workaround , restarting uvnc service.

However, running W7 64-bit pro , I happen to see that even the service has a problem with W7.
Added a cmd file to task schedule to restart service every hour.
It just does not restart or something happens and I can not longer connect to it.
Please test it also by yourselves, let see if anyone will have the same problem.
I believe the major problems are related with the service.

1- Mouse is jerky, I do mouse movements, when I stop I still see mouse is moving around. I could minimize it with compression:9 and quality:1 in viewer options and low accuracy in server.
2- Even I close from vncviewer normally, when I get to home I see that server thinks there is still connection.
3- Yesterday, it drive me mad, I connect with viewer and the screen comes full first and after a second refresh I get disconnected. It fought it like 10 times than I setted to full colors for it to take time to send me the first full screen. During it I pressed for several times to ctrl-alt-del button in the toolbar. Finally I connected without being closed and restart the pc , it when back to normal.

All these problems happening after 1.2.0.x release, I advise unless there is a security risk going back to old versions way of running.

Best Regards,
Burak Ural
burzek
8
8
 
Posts: 14
Joined: 2006-06-01 15:51

Re: bug: connection still open after client is closed

Postby Arno-BS » 2015-05-07 10:44

I renamed w8hook64.dll (I'm on a Windows8.1 64 Bit System) to w8hook64_disabled.dll
Then schook64.dll is used.
(There is also a vnchook.dll in the directory ...)

During the next days now I will see if things are going better now and then I will post again.

Thanks and regards
Arno
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Rudi De Vos » 2015-05-24 23:05

any feedback
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5751
Joined: 2004-04-23 10:21

Re: bug: connection still open after client is closed

Postby Skyfighter » 2015-05-26 16:02

A Few days ago I found your test-version here: http://forum.ultravnc.info/viewtopic.php?f=70&t=31318#p98633

I am not sure why, but I haven't seen the "ghost connection" any more. Perhaps you already fixed it?
Skyfighter
40
40
 
Posts: 95
Joined: 2014-12-31 22:10

Re: bug: connection still open after client is closed

Postby Rudi De Vos » 2015-05-26 21:08

Perhaps i better release a 1.2.0.6 with all little changes and bug fixes to avoid that some issue's have multiple results.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5751
Joined: 2004-04-23 10:21

Re: bug: connection still open after client is closed

Postby Skyfighter » 2015-05-27 15:42

Yes, a new version would be great! :)
Skyfighter
40
40
 
Posts: 95
Joined: 2014-12-31 22:10

Re: bug: connection still open after client is closed

Postby Arno-BS » 2015-06-02 11:47

Tested again with 1.2.0.6 and w8hook64.dll active.
Again connection still open after client is closed...

Will now test without w8hook64.dll

Arno
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Rudi De Vos » 2015-06-02 22:16

I still can't repeat it... w8hook makes a big difference in speed, disabling it doesn't solve the issue.

BUt i need to be able to repeat it... the logging was helpfull but doesn't exact pinpoint to something.
What is changed in the settings, are you using any non default viewer/server settings.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5751
Joined: 2004-04-23 10:21

Re: bug: connection still open after client is closed

Postby Rudi De Vos » 2015-06-04 20:16

test

http://www.uvnc.eu/download/1206/winvnc_w8test.zip

I added some check to the w8hook to verify if it was proper started.
both winvnc and w8hook need to be replaced to test
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5751
Joined: 2004-04-23 10:21

Re: bug: connection still open after client is closed

Postby Skyfighter » 2015-06-16 08:40

I've used v1.2.0.6 and your test-version: the bug with stuck connections is still there.

With the test version it seems much less fatal:
1) stuck connections get created at connection time (observed a few times): viewer window gets created but stays grey (not showing the remote display content) and "refresh screen"-button doesn't change anything; closing viewer leads to stuck connection at server-side but then:
2) when a connection gets stuck I still can connect with a new session (close viewer and reopen viewer) without any problems (at least in version v1.2.0.5 there were multiple retries needed to connect and sometimes no usable connection was possible anymore until uvnc server & processes are restarted/killed)

Some other things about the test version:
- connections get up much faster than with previous versions (not sure, but it feels like that); especially the delay between creation viewer screen window and seeing the remote screen got faster
- the tiny dot cursor-problem seems to be gone (I regularly could reproduce a tiny dot cursor using u2 encoding - using hextile encoding always solved the cursor problem for me)
- automatic reconnections of the viewer (interrupted network, server-pc reboot, send viewer-pc to sleep and wake it up while being connected) became much more reliable; up to v1.2.0.5 my viewer regularly timed out or crashed

=> the test version seems to be a good step forward! :)
Skyfighter
40
40
 
Posts: 95
Joined: 2014-12-31 22:10

Re: bug: connection still open after client is closed

Postby Arno-BS » 2015-06-16 11:54

I totally agree with Skyfighter's sentences 1) and 2).

The last point (timeout) I also see a timeout at least with v1.2.0.5 and v1.2.0.6 after some time, even if neither the server nor the client are configured to any kind of sleep/standby/hibernation. Sometimes I connect and "forget" to disconnect the client, then after an amount of time (minutes or hours, I don't know) the client hangs (black screen). Didn't test this so far with latest test version.

Regards
Arno
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Skyfighter » 2015-06-22 20:19

Just saw a stuck connection once more; this time I had Full-Log to file enabled: http://www22.zippyshare.com/v/3zIzgRrU/file.html (zip-compressed WinVNC.log)

Does that log help in any way?
Skyfighter
40
40
 
Posts: 95
Joined: 2014-12-31 22:10

Re: bug: connection still open after client is closed

Postby XyZiron » 2015-08-25 16:05

I get the same issue when I connect to my Windows 7 PC (running 1.2.0.5) from my Mac (OS 10.10.4) using Apple's built in VNC. Whenever I disconnect, I am unable to reconnect because the server still says I am connected. I check on my mac and there are no connections, I can connect to other Macs, other Windows PCs (running 1.2.0.5) that I have yet to disconnect from. When I check on my PC, it says the connection is still there and I need to restart UltraVNC Server (attempting to disconnect clients does nothing).
XyZiron
 
Posts: 1
Joined: 2015-08-25 16:00

Re: bug: connection still open after client is closed

Postby Arno-BS » 2015-09-24 12:22

I got again this issue with beta 1.2.0.8 build Sep. 2

Arno
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Arno-BS » 2015-11-27 11:03

It seems to occur not as often as before, but I again ran into this issue with 1.2.0.9 (u1)

Regards
Arno
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Skyfighter » 2015-12-04 18:39

Unfortunately I still have the problem from time-to-time (rarely, but it happens). Currently using: viewer v1.2.0.9u1 and server v1.2.1.0-test1
Skyfighter
40
40
 
Posts: 95
Joined: 2014-12-31 22:10

Re: bug: connection still open after client is closed

Postby Arno-BS » 2016-02-24 15:19

I also have this with Server and Viewer 1.2.1.0 as of January, 24.
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28


Return to 1.2.0.X

Who is online

Users browsing this forum: No registered users and 3 guests