AuthHosts= Line cutoff in .INI file

AuthHosts= Line cutoff in .INI file

Postby mwend » 2015-08-14 20:56

The UltraVNC.INI AuthHost= is cutoff and ignored after 150 or so characters.

Using 1.2.0.6 with INI file on Windows 7 64 bit.
Clean/fresh install of UltraVNC then copied over our INI file - shown below
Note the line

AuthHosts=-:?172.26.3.9:?172.26.3.57:?172.26.3.10:?172.26.3.13:?172.26.3.16:?172.26.3.19:?172.26.3.27:?172.26.3.11:?172.24.6.21:?172.22.4.6:?172.24.4.19:?172.26.3.54:?172.18.8.13:?172.18.8.14:?172.18.8.15:

Here is the problem
The 5th IP from the end is the last IP address that will connect to the host. Anything workstation past the 172.24.4.19 IP will result in the message "Your connection has been rejected" immediately. Move this IP to be first on the list (restart the uvnc service) and it will work from the workstation as expected. Of course the non connecting IPs with shift. It seem that the authorized IP's after the 150 characters of the line will not work.

Additionally using the "uvnc_settings.exe" (Connections Tab) only shows about the first 150 characters Hitting OK to "save" the settings with then truncate the UltraVNC.ini AuthHosts= lineto about 150 characters.

This worked in prior vnc versions. I would expect this to work here..
Can some one confirm or suggest ideas?
-Mike


UltraVNC.INI
[UltraVNC]
passwd=[snip]
passwd2=[snip]
[Permissions]
[admin]
UseRegistry=0
MSLogonRequired=0
NewMSLogon=0
DebugMode=0
Avilog=0
path=C:\Program Files (x86)\Orl\VNC\UltraVNC
accept_reject_mesg=The Helpdesk needs your permission for remote control assistance. Please select the "Accept" Button.
DebugLevel=8
DisableTrayIcon=0
LoopbackOnly=0
UseDSMPlugin=0
AllowLoopback=0
AuthRequired=1
ConnectPriority=1
DSMPlugin=No Plugin Detected
AuthHosts=-:?172.26.3.9:?172.26.3.57:?172.26.3.10:?172.26.3.13:?172.26.3.16:?172.26.3.19:?172.26.3.27:?172.26.3.11:?172.24.6.21:?172.22.4.6:?172.24.4.19:?172.26.3.54:?172.18.8.13:?172.18.8.14:?172.18.8.15:
DSMPluginConfig=
AllowShutdown=0
AllowProperties=0
AllowEditClients=0
FileTransferEnabled=1
FTUserImpersonation=1
BlankMonitorEnabled=1
BlankInputsOnly=0
DefaultScale=1
primary=1
secondary=1
SocketConnect=1
HTTPConnect=1
AutoPortSelect=1
PortNumber=5900
HTTPPortNumber=5800
IdleTimeout=0
IdleInputTimeout=0
RemoveWallpaper=0
RemoveAero=1
QuerySetting=2
QueryTimeout=30
QueryAccept=0
QueryIfNoLogon=0
InputsEnabled=1
LockSetting=0
LocalInputsDisabled=0
EnableJapInput=0
kickrdp=1
clearconsole=0
service_commandline=
FileTransferTimeout=3
KeepAliveInterval=5
[admin_auth]
group1=
group2=
group3=
locdom1=0
locdom2=0
locdom3=0
[poll]
TurboMode=1
PollUnderCursor=0
PollForeground=0
PollFullScreen=1
OnlyPollConsole=0
OnlyPollOnEvent=0
MaxCpu=50
EnableDriver=0
EnableHook=1
EnableVirtual=0
SingleWindow=0
SingleWindowName=
mwend
 
Posts: 3
Joined: 2015-08-14 18:26

Re: AuthHosts= Line cutoff in .INI file

Postby mwend » 2015-08-21 02:17

Well it looks like I can answer my own question and confirm AUTHHOSTS= line has a max of 150 chars.
I wish it was more ...like 255 chars - but I guess that is a developer choice.

Code is located in
uvnc_settings.cpp line 53 and line 320 both have have a hardcoded "150"
char authhosts[150]=("\n)
mwend
 
Posts: 3
Joined: 2015-08-14 18:26


Return to 1.2.0.X

Who is online

Users browsing this forum: No registered users and 2 guests

cron