1.2.0.6 bug: Disabling local inputs disables some remotekeys

1.2.0.6 bug: Disabling local inputs disables some remotekeys

Postby Csimbi » 2015-10-21 21:56

Have a server running and make sure:
- you have disabled local input in the server settings
- you have an app running that detects keypresses.

Now, connect using viewer from a remote PC and tap 'F12'.
Nothing happens.

Turn off the "disable local input" setting on the server.
Now, connect using viewer from a remote PC and tap 'F12' again.
F12 will work.

Interesting because F12 was pressed on the remote machine in both cases.

Thank you for fixing!

PS. I did not test other keys than F12, but once you find the bug with F12, you'll see which other keys are impacted.
Csimbi
8
8
 
Posts: 16
Joined: 2008-05-03 15:28

Re: 1.2.0.6 bug: Disabling local inputs disables some remote

Postby Rudi De Vos » 2015-10-22 10:30

IS this a bug ?

Disable local input: you want to prevent the "server user" to type anything while you have control
Disable remote input: View-only viewer, you prevent the remote user to use the keyboard
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5713
Joined: 2004-04-23 10:21

Re: 1.2.0.6 bug: Disabling local inputs disables some remote

Postby Csimbi » 2015-10-22 11:22

Of course it is.
Remote keypresses should all go through regardless how local keypresses are handled - no?
Csimbi
8
8
 
Posts: 16
Joined: 2008-05-03 15:28

Re: 1.2.0.6 bug: Disabling local inputs disables some remote

Postby Rudi De Vos » 2015-10-22 14:35

Remote keypresses should all go through regardless how local keypresses are handled? Indeed.

Text was unclear to me... i like it more technical.

So, the bug is that some special keys like F12 are blocked by the local keyboard blocker even when
they are injected with sendinput (via the viewer)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5713
Joined: 2004-04-23 10:21

Re: 1.2.0.6 bug: Disabling local inputs disables some remote

Postby Csimbi » 2015-10-22 18:39

No worries, I was not clear I guess.
It's better to ask twice.

I have a PC here (remote) and a PC there (local).
I am controlling the PC there with VNCViewer.
The local behaviour is not consistent and the culprit seem to be the setting that disables local input.
F12 is an example, there may be more.

That's about right.
But I am not injecting anything. I just press the key on the remote PC (the controller).
Csimbi
8
8
 
Posts: 16
Joined: 2008-05-03 15:28


Return to 1.2.0.X

Who is online

Users browsing this forum: No registered users and 2 guests

cron