1211 Memory Leak

1211 Memory Leak

Postby sqcs » 2017-01-25 19:38

When a UVNC 1.2.1.2 client (Windows 10) connects to a UVNC 1.2.1.2 server (Windows XP), a memory leak is started on the server. Disconnecting the client stops the memory leak. Killing the winvnc process (running as SYSTEM), restarting winvnc as the logged on user, and then reconnecting the client does not produce the memory leak. The memory leak was viewed through Process Explorer.

I have other UVNC setups that do not have this issue. I recently replaced the UVNC server computer from an older Dell Optiplex GX270. The older server did not have this issue, but the new server has had this issue since day 1. Windows XP was used on both the old and the new server, with the same setup on each. I don't have another system available to set up for this purpose. Windows XP was recently reinstalled on the new server. The issue existed before and after the XP reinstall.

The new UVNC server is a Dell Optiplex 740 with AMD Athlon 64 X2 4200+, NVIDIA GeForce 6150 rev. A2 northbridge, NVIDIA nForce 410/430 MCP rev. A3 southbridge, 2GB DDR2, NVIDIA GeForce 7300 LE graphics card, and Windows XP SP3.

The VNC connection is very vanilla. The only settings changed from their defaults were that a static port is assigned and the passwords were set. The server runs Geovision Multiview software, Panda antivirus, and Firefox (rarely used).
sqcs
 
Posts: 2
Joined: 2017-01-25 19:07

Re: 1211 Memory Leak

Postby sqcs » 2017-02-14 18:20

FYI, I bypassed this issue by disabling the uvnc_service (starts winvnc.exe as a service) and creating a scheduled task to start winvnc.exe at logon as the logged on user.
sqcs
 
Posts: 2
Joined: 2017-01-25 19:07


Return to 1.2.1.x

Who is online

Users browsing this forum: No registered users and 3 guests

cron