MS Logon broken after Windows 10 Upgrade

MS Logon broken after Windows 10 Upgrade

Postby Tobei » 2018-03-09 14:45

Hi,

we made following observation, after we made a upgrade from Windows 10 1607 to 1709, the UltraVNC MS Logon user authentication is broken. If we do a fresh installation of Version 1607 or directly 1709 there is no problem. We can reproduce the issue. This only happens after a upgrade.

We are using UltraVNC Version 1.2.1.7 If the computer is a part of a Active Directory the AD Authentication is still working, but authenticating as a local Administrator is broken after the upgrade. The viewer gets the message:
authentication rejected

Extract from our "ultravnc.ini":
Code: Select all
[admin_auth]
group1=vncusers
group2=Administrators
group3=
locdom1=2
locdom2=0
locdom3=0

When we change the server configuration to "New MS Logon" Authentication we get the VNC server back to work, but we want to rollout the server part fully automated ... so we decided back then to use the "old authentication method".

We enabled the debug log function and get following output:
Thu Mar 8 17:04:37 2018
vncserver.cpp : authhosts set to ""
vncproperties.cpp : ***** DBG - Load User Preferences
vncproperties.cpp : clearing user settings
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : FromClear called
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncserver.cpp : trying port number 5900
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
Thu Mar 8 17:04:38 2018
vsocket.cpp : closing socket
vncproperties.cpp : $$$$$$$$$$ ApplyUserPrefs - Plugin Enabled - Call SetDSMPlugin()
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Entry
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Enabled
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin NOT loaded - Try to load it
vncsockconnect.cpp : started socket connection thread
--Falscher Parameter.
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin successfully loaded
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Init plugin call
--Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - SetPluginParams call
vncserver.cpp : DSMPlugin Params OK
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : ToText called
Thu Mar 8 17:04:43 2018
vncservice.cpp : @@@@@@@@@@@@@ GetCurrentUser - Error: Usersize 0
vncproperties.cpp : ***** DBG - Force USER SYSTEM 2
vncservice.cpp : @@@@@@@@@@@@@ GetCurrentUser - Error: Usersize 0
vncservice.cpp : @@@@@@@@@@@@@ GetCurrentUser - Error: Usersize 0
Thu Mar 8 17:04:48 2018
vncservice.cpp : @@@@@@@@@@@@@ GetCurrentUser - Error: Usersize 0
vncproperties.cpp : ***** DBG - Force USER SYSTEM 2
vncservice.cpp : @@@@@@@@@@@@@ GetCurrentUser - Error: Usersize 0
vncservice.cpp : @@@@@@@@@@@@@ GetCurrentUser - Error: Usersize 0


Any idea what we are doing wrong, or is this a real bug? We can gladly provide more informations.


Greeting Tobias
Tobei
 
Posts: 2
Joined: 2018-03-09 14:26

Re: MS Logon broken after Windows 10 Upgrade

Postby Rudi De Vos » 2018-03-13 22:06

i will add it to the todo list... current no time do debug this one.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5713
Joined: 2004-04-23 10:21

Re: MS Logon broken after Windows 10 Upgrade

Postby Tobei » 2018-03-15 20:23

Hi Rudi,

thanks for reading and your feedback. Feel free to ask me later if you want any further information.


Greeting Tobias
Tobei
 
Posts: 2
Joined: 2018-03-09 14:26


Return to 1.2.1.x

Who is online

Users browsing this forum: No registered users and 2 guests

cron