1.2.1.0 pre-release installers online

1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-10 22:33

From 1-1-2016 sopme OS require Sha256 signing
exe and installers dual signed with sha1 and sha2

Repeater/uvnc_launcher added to the installers

Please test

addon x86
http://www.uvnc.eu/download/1210/UltraV ... Addons.exe
setup x86
http://www.uvnc.eu/download/1210/UltraV ... _Setup.exe

setup X64
http://www.uvnc.eu/download/1210/UltraV ... _Setup.exe
addon X64
http://www.uvnc.eu/download/1210/UltraV ... Addons.exe

bin zip ALL
http://www.uvnc.eu/download/1210/Uvnc_1210_bin.zip
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-11 09:06

hi
UVNC_Launch.exe
I configured
but the list SERVER does not loaded :(
maybe I'm doing something wrong?
===============================================
testing:
UltraVNC server 1.2.1.0 + 2.4.0.0 SecureVNCPlugin64.dsm
Windows 10 x64

last (Repeater.exe)

UltraVNC viewer 1.2.1.0 + 2.4.0.0 SecureVNCPlugin64.dsm
Windows 7 x64
(server properly reconnect after connecting through a repeater)
===============================================
continue testing... :surprise:
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-11 11:39

uvnclaunch

/uvnc
/uvnc/uvnclaunch.ini
/uvnc/myserver.vnc
/uvnc/mysubfolder/anotherserver.vnc

The server list, is the list of the .vnc files in /uvnc and subfolders
.vnc files are created via the add option or you can save it from the vncviewer
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-11 13:40

Understood thanks.
The question remains to encrypt?
What encryption can be used?
I have a servers (each with its own private key)
Settings in servers are now installed:
AES(128 to 256 bit key) (256-bit)
RSA-2048
use new key algorithm (yes)
+pass (installed)

how do I set the encryption settings?
make everything work with "UVNC_Launch.exe"
is one condition was necessary that the encryption key and password
Thank you
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-11 15:45

All encryptions are supported.

+Import a .vnc file ( copy it in the uvnc folder)
+Use UVNC_Launch.exe, select ( right click) the .vnc entry and select edit
or
+right click SERVERS and select add

In this properties windows you can set
*password
*select encryption plugin
The password is the vnc password or the passphraze if you use encryption and have it set.
Password/MS user are saved encrypted

Viewer/launcher/dsm plugins/encryption keys need to be in the same folder

Encryption key
You don't need to do anything special. The server pass it's numeric part of the key file (20160111_Server_ClientAuth.pubkey)
20160111 to the viewer. The plugin on the viewer site, search the viewer key that contain the same name.
20160111_Viewer_ClientAuth.pkey
Just make sure vncviewer/plugin and keys are all in the same folder.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-12 06:12

cool
it works!
I was doing wrong.
Password needed to save in UVNC Console
+right click SERVERS and select Edit then insert password and save
and then everything works fine 8)
Thanks! :roll:
continue testing... :surprise:
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Multi viewer connections settings are not fully working

Postby Chaka » 2016-01-12 17:42

Hello guys,

I've tested UltraVNC v1.2.0.9 and now 1.2.1.0. It seems two of four settings under "Multi viewer connections" are not working.
In detail:
1.) "Disconnect all existing connections": should mean a new arriving viewer should kick established viewer connections, but the truth is existing connections still persists. I think thats wrong because it works like point 2 and should be fixed.
2.) "Keep existing connections": I think this works, more than one viewer can view and navigate the computer with the ultravnc server.
3.) "Refuse the new connection": I think I don't fully understand the intension of this option, but when choosen I see no difference in handling to point 2. Therefore I think this option is broken, too.
4.) "Refuse all new connections": This one works fine, the actual viewer can work unharmed until he close the connection. During the session of this viewer all other viewers get no access and while connecting a error message, e.g. "WriteExact: Socket error while writing" or "Server closed connection - The server running as application" and within the status window appears the error message: "Connection closed (1)".
So am I doing something wrong or can someone reproduced my findings?
Chaka
8
8
 
Posts: 21
Joined: 2014-04-11 18:01

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-12 21:32

Your testings are correct.
VNC has 2 viewer options, shared and non shared.
The server options 1)2)3) behave different in combination with the "non shared" viewer option.

4) Is simple, kick all (shared and non shared) viewer connection

Sorry, I know, this isn't clear ... 8 combinations.
share viewer connected and non shared viewer connect with server option 1 2 3 4
non shared viewer connected and shared viewer connect with server option 1 2 3 4
This give 8 different combinations...
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-13 06:03

hi
after installation UltraVNC_1_2_10_X64 _Setup.exe
in uvnc_settings.exe No tab "Services"

in \Uvnc_1210_bin\win7\X64\uvnc_settings.exe
yes tab "Services"
but in tab "Security" the button "Configuration" does not work

in \Uvnc_1210_bin\xp\uvnc_settings.exe
yes tab "Services"
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby Chaka » 2016-01-13 08:41

@Nick_od: When there was a "Services" tab within previous versions of uvnc_settings.exe then I can confirm your findings.

@Rudi De Vos: Thank you for your explanation, still I think I don't fully understand the situation. So let me short recape this topic.
First: Within my viewer options the setting "share the server" was indeed set, probably standard. With that I get the descriped behavior (see above), means 2 options the server will always be shared, besides I set "Refuse all new connections" within the server options.
Second: But when I unset "share the server" within the viewer options then the first 3 points within the server settings works like intended?
So when I'am right then I would say there are max. 6 possible combinations. 2 with share the server set and 4 with share the server unset.

With that in mind I think I can report an error, at least for Version 1.2.0.9: With "share the server" set (viewer) and "Disconnect all existing connections" set (server) the server isn't accessible anymore when 2 or more viewers try zu access simultaneously. Not even the restart of the UltraVNC service fixes this problem but I have to restart the whole computer. I have had this problem with Windows 2008 R2 (server) and Windows 7 (viewer1) and Windows XP (viewer2). And I have had this problem with Windows 2008 R2 (server) and Windows 7 (viewer1) and some nasty bulgarian bots, which were trying to get access without access. At the other hand the same scenario tested between 3 Windows 7 maschines within the LAN works without problems?!?!
However now I've set "Refuse all new connections" at the UltraVNC server and since that the problem is gone.
Chaka
8
8
 
Posts: 21
Joined: 2014-04-11 18:01

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-13 10:13

UVNC Console
It should show that the server ID is connected to Repeater or not should show ?
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-13 21:00

uvnc_settings.exe: looks like i mixed different versions for the installers.
Thanks for the feedback

update: recompiled uvnc_settings.exe and installers re-uploaded
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-13 21:03

uvnc console: It actual show the connectable status:

green: you can connect
green/green: you can connect to the repeater and server is online

Did you set the webgui user/passwd port?
Can you access the webgui from the pc running the uvnc console

btw: uvnc console is a better name then the uvnc launcher.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-14 06:09

Rudi De Vos wrote:uvnc console: It actual show the connectable status:

green: you can connect
green/green: you can connect to the repeater and server is online

Did you set the webgui user/passwd port?
Can you access the webgui from the pc running the uvnc console

btw: uvnc console is a better name then the uvnc launcher.


hi
I configured "webgui user/passwd port"
but it shows a green / red
When you press the refresh one ID blinks (blue / green - green / blue) and then again green / red
you can check?
you normally work?
Thank you.
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-14 07:48

The console repeater connection was tested for several weeks.
see viewtopic.php?f=70&t=31505&hilit=vnc_launch

green-red = repeater online, ID not found

Does the viewer connect when you click on it ?
When you open a browser to the gui, do you see the same ID as you defined in the properties ?
Are you using the latest repeater ( it's included in the bin zip)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-14 08:37

Rudi De Vos wrote:The console repeater connection was tested for several weeks.
see viewtopic.php?f=70&t=31505&hilit=vnc_launch

green-red = repeater online, ID not found

Does the viewer connect when you click on it ?
When you open a browser to the gui, do you see the same ID as you defined in the properties ?
Are you using the latest repeater ( it's included in the bin zip)


repeater last run in (bin zip)
I connect to Web Gui Port repeater hi shows ID:123456 connect but in "uvnc launcher" shows (green / red) when double clicked to connect in "uvnc launcher"
it connects me to the server.

You may need special settings in repeater ?
My Settings (mode1 no) (mode2 yes)
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-14 11:27

We actual use the webpage (html) and check that in the server part of the text there is a string with the ID.

If you manual refresh the status in the console, does he detect it.
There was a report that sometimes the first run fail the access the webpage.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-14 12:22

I think I understood
my program (uvnc launcher) constantly tries to connect to a different port (Webgui repeater port).
for example:
My port in repeater (Web Gui Port:10000)
the program (uvnc launcher) tries to connect to port 22221 (in settings set port 10000)
I deleted a file (uvnclaunch.ini) and again exhibited setting but the program (uvnc launcher) continues to try to connect to port 22221
(in settings set port 10000)
it tries to connect to the port on which I connected vncviewer.exe
what am I doing wrong?
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-14 21:37

You can set the port at 2 levels.
1) global... uvnclaunch.ini
2) .vnc ( right click edit )

If no .vnc repeater is set, the global is used.

Some people have multiple repeaters and this way we can set .vnc based repeater.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-15 09:10

I'm sorry maybe I not so much an expert
but i can not understand why I have configured "uvnc launcher" set port 10000 (webgui repeater) and the program tries to connect to a different port 22221 (This port is connected to vncviewer.exe)
I see it using the program "TCPView"

in file configuration ***.vnc repeater and port is not set
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-15 12:14

Just tested and 10000 is 10000
Are you not messing the incoming and outgoing ports ?

process-------local port-----remote port
repeater 10000
repeater 5901
repeater 5000

uvnc_launch 51020 10000

Use this Launcher wIth debug console...
http://www.uvnc.eu/download/1210/uvnc_l ... onsole.zip
This give something like this..

Code: Select all
++++++++ START SCAN REFRESH ++++++++
repeater localhost port 5901 added to cache
User admin password adminadmi2
http connect to localhost 10000
The server requires authentication. Sending credentials...
The resource was successfully retrieved.
Handling html data
Strings found
caching data
Connections: >Connections: <br><table class="style2" style="width: 800px"><tr><t
d style="width: 40px; height: 23px" class="style3">Slot</td><td style="width: 16
0px; height: 23px" class="style3">Time</td><td style="width: 90px; height: 23px"
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-15 13:59

thanks for the help :P
Code: Select all
++++++++ START SCAN REFRESH ++++++++
repeater my.com port 22221 added to cache
User admin password 123456789
http connect to my.com 10000
The server requires authentication. Sending credentials...
The resource was successfully retrieved.
Handling html data
Strings not found
Handling html data
Strings not found
Handling html data
Strings not found
Handling html data
Strings not found
Handling html data
Strings not found
Handling html data
Strings not found
Handling html data
Strings not found
Handling html data
Strings not found
Handling html data
Strings not found
Handling html data
Strings not found
Repeater ID >123456< Not Found
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
Found in cahe my.com 22221
++++++++ STOP SCAN ++++++++


but ID:123456 connect to repeater and other ID also
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-15 15:14

At least we see that port 10000 used and the launcher connect to the repeater webgui.
He also connect to the repeater port to check if the repeater is online (22221)--> first green
We cache data for repeater my.com on port 22221, but it looks like the html data is empty

You don't see any html code in the debug console ?

I will try to check the source for a possible cause or add some extra debug info to see whats happening.
I's always strange that things works on pc A and fail on pc B...

Possible the html page is plit during download, ( you have many servers waiting and data exceed buffer)
In that case we don't find the (connected/server/viewer) text in a single data block and data is ignored.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-15 20:04

You don't see any html code in the debug console ?

no
all that was
show everything
and this is repeated
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-17 22:11

Use this Launcher wIth debug console...test2
Increased buffer

http://www.uvnc.eu/download/1210/uvnc_l ... nsole2.zip
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-18 10:09

Thank you
everything is working
is the last question this works without encryption?
(when there is a request to update the list)
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby Rudi De Vos » 2016-01-18 10:16

encryption is always between server and viewer.
Encryption is between endpoints.

The launcher and repeater doesn't use encryption.
The webgui is passwd protected, but no enryption
The launcher encrypt passwords, but this is independed of the encryption used between server and viewer.

Folders are rescanned every x minutes or on refresh.

Perhaps i just don't understand your question :)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5788
Joined: 2004-04-23 10:21

Re: 1.2.1.0 pre-release installers online

Postby Nick_od » 2016-01-18 10:23

The launcher and repeater doesn't use encryption.

That was my question 8)

I installed "stunnel" for https encryption but it does not work with "launcher"
Thank you very much for your help
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 pre-release installers online

Postby ddbivens » 2016-01-20 23:53

UltraVNC_1_2_10_X64_Setup prerelease feedback
(I just downloaded the 'release version' and will install it tomorrow.)
1st, this update is Great!!! It seems to have completely resolved the screen redraw issue. I opened VNCViewer looking at 10 systems at the same time and had only the initial draw (slower on a slow network, but that is OK) and a very fast refresh.
On a few systems were I (we in IT) have had slow response from the remote system, the new update seems to have fix that entirely.
I am extremely pleased with the initial test results and am expanding my test installs immediately.
-
I have noticed the following items:
1) When I disconnect from a system, I can't reconnect to that system for about 19-20 seconds. This seems consistent. When I disconnect from one system, I can connect to a different system immediately, so it appears to be on the remote end (winvnc.exe).
2) When the remote PC has multiple screens, it seems that I always have to click the "Show Full Desktop/Switch Monitor" button two times for it to work. Once it works I can click once and it will switch between both/one monitor view.
3) The new "Save position" feature is great. I am not certain it is fully compatible when the "Viewer size/pos Auto" and "Scale server to window" options are both in use. I have one system that won't save the position and displays a 1024x768 single monitor as a wide screen, the icons are stretched. If I turn off Viewer Size Auto" and turn off "Scale server to window" and move the edge of the window, it snaps to the correct shape and saves correctly when close/open is repeated. If I turn off the "Save Position", it opens/closes/opens to the correct size repeatedly.
4) When I use the switch /loadinf="path\ultravncx32.ini, sometimes it does not honor the path line and installs to the default path of C:\Program Files\uvnc bvba\UltraVnc
path=C:\Program Files\UltraVnc
I am running the install remotely, so my batch file checks for the path C:\Program Files\uvnc bvba\UltraVnc\vncview.exe and if found, it runs the uninstall command then installs version 1.0.962 which never fails to install to the folder spelled out in the ini file then runs the install for the current version again. Almost always, it installs to the specified folder correctly the 2nd time.
-
I will check these items in the 'installer' release that I will install tomorrow.
Again, this program is fantastic! The latest update is absolutely excellent! I am only trying to help.
Thank you so much for this program!!!
ddbivens
40
40
 
Posts: 76
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA


Return to 1.2.1.x

Who is online

Users browsing this forum: No registered users and 2 guests