1.2.1.0 release installers online

Re: 1.2.1.0 release installers online

Postby Skyfighter » 2016-01-30 19:01

with v1.2.1.0 I've seen a tray icon bubble-message of winvnc.exe like that two or three times:
Code: Select all
Remote Connection
Could not connect to <unknown public ip address>

Any idea what triggers this message? Does that mean the winvnc.exe tried to establish an outgoing connection? (Previously I never saw such a bubble message of winvnc.exe...)

Looking at the mslogon.log in the uvnc installation folder there are lots of messages like "Invalid attempt from client <other-unknown-public-ip-addresses>". Hopefully these message are harmless (although the vnc ports are open/forwarded from my router to this particular machine) keeping in mind I'm using SecureVNC encryption plugin with passphrase and private/public key files...
Skyfighter
20
20
 
Posts: 57
Joined: 2014-12-31 22:10

Re: 1.2.1.0 release installers online

Postby Rudi De Vos » 2016-01-31 16:17

Invalid attempt from client : encryption and key passphrase does there job
But we can not block them trying to make a connection.

Could not connect to: You get this error when the rfb protocol message exchange fail.
The inital message from the viewer should be "RFB....." but when you use the latest encryption plugin (SecureVNC)
we also encryted this message. A viewer with a wrong encryption key cause "RFB.." to be decrypted as something else
"!è§..." -> unknown protocol -> error via balloon
This messages was added in 2009

VNC blacklist the ip addresses after 3 failed connection. A blacklisted ip can not connect for a certain time and time is inceased
each failed connection.

->add ip to blacklist
-> init protocol, on fail balloon popup
->check password
passwd ok-> remove from blacklist

Try to use another port then 5900, there are a lot of scanners that scan 5900 ports.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5442
Joined: 2004-04-23 10:21

Re: 1.2.1.0 release installers online

Postby Skyfighter » 2016-02-02 01:25

Thanks for the explanation and details, Rudi! I'll try changing the port and look if there are fewer scanners knocking on my door...
Skyfighter
20
20
 
Posts: 57
Joined: 2014-12-31 22:10


Re: 1.2.1.0 release installers online

Postby jjurkus » 2016-02-04 02:09



"The requested URL /download/1210/UltraVnc_1210_X64_XP.msi was not found on this server."

But what is the difference in the msi installers? I was going to check for myself, but the server wouldn't let me :( 8) :wink:
User avatar
jjurkus
 
Posts: 4
Joined: 2016-01-28 20:39

Re: 1.2.1.0 release installers online

Postby Rudi De Vos » 2016-02-04 18:57

corrected
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5442
Joined: 2004-04-23 10:21

Re: 1.2.1.0 release installers online

Postby Nick_od » 2016-02-05 11:43

hi
I installed the setup and testing:

Code: Select all
[admin]
alternate_shell=winlogon.exe
rdpmode=1


UltraVNC server 1.2.1.0 + 2.4.0.0 SecureVNCPlugin64.dsm
Windows 10 x64 (explorer.exe OFF)

last (Repeater.exe)

Test 10 servers UltraVNC
After rebooting all servers connected to Repeater all OK
If i restart repeater.exe (no one the server does not automatically reconnect to the)

something is not working properly.
Nick_od
40
40
 
Posts: 82
Joined: 2013-09-04 06:42

Re: 1.2.1.0 release installers online

Postby Prisma » 2016-02-09 10:23

I'm able to commit that. rdpmode is actually not working properly. I tested 1.2.1.0 version from December. Rudi fixed some problems and that's it. Worked quite well. Worked stable.
Then I installed the release. Disappeared from repeater after some switching between rdp and console session, never came back. I stopped the service and I saw one winvnc.exe (SYSTEM) hanging. I had to terminate the process manually.

Something changed since December regarding rdpmode.
Prisma
100
100
 
Posts: 283
Joined: 2005-10-27 15:50

Re: 1.2.1.0 release installers online

Postby Rudi De Vos » 2016-02-14 19:43

ok, will take a look again
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5442
Joined: 2004-04-23 10:21

Re: 1.2.1.0 release installers online

Postby Chris » 2016-02-16 08:36

i have a strange Problem with this new version. We use UVNC als Helpdesktool with the Repeater, and now all 12 to 24 hours the Server (2008R2) which hosts the Repeater crashed the network, no browsing possible. Killing the REPEATER.EXE makes the networking working again.
Chris
8
8
 
Posts: 16
Joined: 2012-10-31 11:59

Re: 1.2.1.0 release installers online

Postby Rudi De Vos » 2016-02-16 14:11

Does the server network stop to function or does the repeater stop to function ?
Our own test repeater is now running 7/7 24 running on our webserver and didn't crashed (server 2012r2)
webgui 8080, default user/passwd

Can you try with another port as the standard webgui port 80, it could be that to many strange packets trying to connect to
standard browser ports. Any indication in the log files
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5442
Joined: 2004-04-23 10:21

Re: 1.2.1.0 release installers online

Postby markc » 2016-02-16 15:18

Hi all,
I am currently using Windows 10 with a dual monitor setup. Each monitor is connected to a separate graphics card. The first display resolution is set at 1024x768, the other is set at 1920x1080p

In order to get both monitors to show up in all VNC clients, I changed secondary=1 in the UVNC settings file.

This worked fine in Windows 8.1/Server 2012 R2 using 12.2.1.0.

However in Windows 10 the uvnc service just crashes instantly and restarts. The picture of the two monitors show up very briefly on the client but then the crash occurs and I am not longer able to control the desktop.

I have noticed that un-ticking System HookDll resolves the issue but obviously this is going to have an adverse effect on performance.

Has anyone else noticed this problem?
markc
 
Posts: 1
Joined: 2016-02-16 15:00

Re: 1.2.1.0 release installers online

Postby Chris » 2016-02-16 15:37

before 1.2.1.0 it runs for years without any problem. The Repeater is configured on Port 81.
If the error occurs, no outgoing connection works anymore (e.b. sending Mails, Browsing, etc).
Chris
8
8
 
Posts: 16
Joined: 2012-10-31 11:59

Re: 1.2.1.0 release installers online

Postby Rudi De Vos » 2016-02-16 18:46

So, you only changed the repeater.exe on the server and now it start blocking all after a while ?
Are there many servers connecting ( waiting)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5442
Joined: 2004-04-23 10:21

Re: 1.2.1.0 release installers online

Postby Chris » 2016-02-17 08:49

for first: yes. but i have been going back to Repeater 12_2015 and the same occurs, so i think it is not the repeater but the new 1.2.1.0 release.
We dont have many helpdeks connections, we are only 6 man who use this support tool.

Can this be a problem if older versions are used (mixed with the current one) of UltraVNC?
I will watch the issue further, if i found the reason i will post it.
Chris
8
8
 
Posts: 16
Joined: 2012-10-31 11:59

Re: 1.2.1.0 release installers online

Postby Rudi De Vos » 2016-02-17 09:37

Are you using vnclauncher , this tool monitor the repeater and try to make connections from time to time.
Just to exclude this one if not used.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5442
Joined: 2004-04-23 10:21

Re: 1.2.1.0 release installers online

Postby Chris » 2016-02-17 10:06

no Launcher used.
Viewer with Parameters: -proxy ourdomain::5901 ID:ourid -autoacceptincoming -password ourpassword -reconnectcounter 0 -dsmplugin SecureVNCPlugin$64BIT.dsm
Server with Parameters: -sc_exit -id:ourid -connect ourdomain::5500 -run
Chris
8
8
 
Posts: 16
Joined: 2012-10-31 11:59

Re: 1.2.1.0 release installers online

Postby Rudi De Vos » 2016-02-17 10:21

The new repeater send keepalive messages, this was added to the server a year ago and is NOT backward compatible

If the server doesn't understand the messages he reconnect: using a keepalive repeater with a non keepalive server
cause the server to reconnect to the viewer each x seconds.

If something goes wrong in the repeater and he keeps using sockets without releasing them he eats the resources.
Do you see some stuff increase ( taskmgr repeater.exe)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5442
Joined: 2004-04-23 10:21

Re: 1.2.1.0 release installers online

Postby Rudi De Vos » 2016-02-17 21:42

Viewer with Parameters: -proxy ourdomain::5901 ID:ourid -autoacceptincoming -password ourpassword -reconnectcounter 0 -dsmplugin SecureVNCPlugin$64BIT.dsm
Server with Parameters: -sc_exit -id:ourid -connect ourdomain::5500 -run


So you start viewer / server on request.
What happen after timeout is there some auto tool that restart it or does people only start it on both sites when required.

Then it can not be the server connection that changed, a single connection can't cause that kind of resource leaks.
I was thinking you used the autoreconnect functions, causing the server to reconnect 300 times/hours..

Runned repeater on resource leak detector and no increasing resources with the time.

What the hell is going on on your PC...with the repeater.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5442
Joined: 2004-04-23 10:21

Re: 1.2.1.0 release installers online

Postby Chris » 2016-02-18 06:42

after changing Mode II only in Repeater options and eleminating one older Viewer Version from one Employee it seems OK until today (running 2 Days without the Network Crash). The error searching in my scenario ist very difficult but it seems ok for now, thanks for helping.
Chris
8
8
 
Posts: 16
Joined: 2012-10-31 11:59

Re: 1.2.1.0 release installers online

Postby Prisma » 2016-03-04 13:24

Referring to my post from 09/02/2016:

I had to go back to winvnc 1.2.0.9 completely. In our setup we use constant reverse connections with repeater 2015.
All connections from 1.2.0.9 are stable and always shown, all 1.2.1.0 connections disappear from repeater and don't come back.
Reason: winvnc is froozen. After shutting down the service winvnc.exe is still shown up at process list. See:
Image
Prisma
100
100
 
Posts: 283
Joined: 2005-10-27 15:50

Re: 1.2.1.0 release installers online

Postby sjoswig » 2016-04-20 15:13

Could you please list all possible msi parameters for ultravnc msi except the standard ones. For example I want to disable creation of desktop icons.

Second thing: All icons after msi installation except the one for ultravnc viewer are correct. Could you fix this?
sjoswig
 
Posts: 2
Joined: 2016-04-20 15:08

Re: 1.2.1.0 release installers online

Postby sjoswig » 2016-04-21 06:09

Wrong icons after msi installation (%ProgramData%\Microsoft\Windows\Start Menu\Programs\):
Image

MSI parameters:
I think the custom properties beginning with "Checkbox" are relevant for the wish that no desktop symbols will be created.
sjoswig
 
Posts: 2
Joined: 2016-04-20 15:08

Re: 1.2.1.0 release bug when Change

Postby far-ar » 2016-05-09 03:15

This version (1..2.1.0) crashes/aborts/cancels when you change the Connection Options during a established connection.

I change the Format and Encoding between:
- Auto Select
- ZRLE
- Tight
- Ultra
- ZlibHex

and
- 8 Colors
- 64 Colors
- 256 Colors
- Full Colors

And the programm crash.

I could do these changes with the previous versions.
Pay atention that I change with a established connection.
The OS that I used: Windows 2003 Servers, Windows Professional 10, Windows Professional 7, Windows XP.

Hope you can correct in the new version.

Thanks
Fabian
far-ar
 
Posts: 1
Joined: 2016-05-09 02:54

Re: 1.2.1.0 release installers online

Postby Rudi De Vos » 2016-05-09 08:06

Please check if
http://www.uvnc.eu/download/1211/uvnc_1211RC3.zip
Fix it.

To fast test, rename winvnc.exe to winvnc_old.exe and copy the updated winvnc.exe from the zip.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5442
Joined: 2004-04-23 10:21

Previous

Return to 1.2.1.x

Who is online

Users browsing this forum: No registered users and 1 guest