bug: connection still open after client is closed

bug: connection still open after client is closed

Postby Arno-BS » 2016-02-24 15:34

Had this thread already for version 1.2.0.x, but have this issue again in 1.2.1.0:

I connect with viewer (1.2.1.0, Win7 x64) to server (1.2.1.0, Win8.1 x64). When I connect only one viewer (my own) is connected. Then I close the connection and (in most cases) wait for the next connection about several minutes or even hours.

Sometimes the connect only leads to a grey screen, refresh or minimize/maximize then doesn't help.
In these cases the only way to get viewer working is closing the viewer and starting viewer again and do a new connection.
When I then have a look at the host "list all clients" there are two entries with identical IP-address (my own from the viewer).

I then had it several times in this situation (and never in other cases) that then after a while (several hours) that the host's Windows' Explorer.exe does a restart (I see that there are missing taskbar Icons). If I in the above case immediately stop uvnc service, then kill the remaining winvnc task and then start uvnc service again I never had an explorer.exe restart afterwards.

So there are two problems:
- sometimes vnc Server doesn't disconnect correctly when viewer is closed
- in this situation leaving uvnc service running on host it seems to let crash Explorer.exe after a while
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Arno-BS » 2016-03-03 11:31

not any idea?
I just had the same thing again :-(
Arno-BS
8
8
 
Posts: 24
Joined: 2010-01-28 15:28

Re: bug: connection still open after client is closed

Postby Rudi De Vos » 2016-03-03 11:53

If somewere in the code you have a memory error, this can happen on exit.

I only could trigger a crash once, and it was in the jpeg lib.
After updating the lib i wasn't able to repeat the crash, but can't tell if this is related or not.
Some leaks were found and corrected...

All is still testing... sorry this take time as i can't find how i can trigger a crash.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5739
Joined: 2004-04-23 10:21


Return to 1.2.1.x

Who is online

Users browsing this forum: No registered users and 2 guests