Grey Screen

Grey Screen

Postby UsernameIssues » 2016-08-12 22:18

I have seen threads talking about grey screens. I've been getting those even with older versions of uVNC and I'm still seeing the grey screen issue with version 1.2.1.1.

I use a VNC [INI] file (with password hash saved) to make a view only connection to computer A:
Code: Select all
[Connection]
host=10.0.2.5
password=xxxxxxxxxx
port=5900
proxyhost=
proxyport=5900
[options]
disableclipboard=0
viewonly=1
showtoolbar=1
Scaling=1
scale_num=50
scale_den=100


Then other users will attempt to use almost the same VNC file (with viewonly=0) to control computer A. More times than not, the secondary connection gives the user a grey screen where the remote desktop should be. Sometimes, the user has control of the remote computer, but cannot tell what they are doing due to the grey screen.

I glanced at the log files and noticed this (unrelated?) line that repeats all day long - even when there are no connections being made:
Code: Select all
Fri Aug 12 07:55:45 2016
vncmenu.cpp : ############### Usernames change: old="username", new="username"
--The system cannot find the file specified.
Fri Aug 12 07:55:50 2016
vncmenu.cpp : ############### Usernames change: old="username", new="username"
--The system cannot find the file specified.
Fri Aug 12 17:01:00 2016
vncmenu.cpp : ############### Usernames change: old="username", new="username"
--The system cannot find the file specified.
Fri Aug 12 17:01:05 2016
vncmenu.cpp : ############### Usernames change: old="username", new="username"
--The system cannot find the file specified.
Fri Aug 12 17:01:10 2016
vncmenu.cpp : ############### Usernames change: old="username", new="username"
--The system cannot find the file specified.


Can you replicate the issue?
Let me know what additional info (if any) that you need from me.

Thanks
UsernameIssues
8
8
 
Posts: 23
Joined: 2016-08-11 18:55

Re: Grey Screen

Postby VncUser2014 » 2016-08-17 13:27

I can confirm we have the same issue with 1.2.1.1
Grey screens on connection. Does not happen all the time but it happens. Sometime we have to close/open connections three or four times in a row.
VncUser2014
8
8
 
Posts: 28
Joined: 2014-10-29 10:33

Re: Grey Screen

Postby UsernameIssues » 2016-08-18 00:27

Our current work around is to open more connections until one of them works. For us, it often takes more than a dozen new connections to get a working one :-(
UsernameIssues
8
8
 
Posts: 23
Joined: 2016-08-11 18:55

Re: Grey Screen

Postby Rudi De Vos » 2016-08-21 13:36

I try to repeat it without luck.

Server and viewer are both 1.2.11 ?
This look simular to a bug we had in the previous version and was reported fixed in 1211.
But has the cause was some initiating timing issue's...
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby VncUser2014 » 2016-08-22 11:31

Yes I can confirm we have this issue with UltraVNC Server & Viewer 1.2.1.1 (at least the 64-bit version)
VncUser2014
8
8
 
Posts: 28
Joined: 2014-10-29 10:33

Re: Grey Screen

Postby Rudi De Vos » 2016-08-22 21:13

In 98% of the cases al works ok, but it seems that on some systems the screen is often grey.
The problem is that we need to able to repeat it to fix it.

An idea that can help us repeating it.
OS
cpu speed
network speed
color depth server/viewer
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby UsernameIssues » 2016-08-22 21:51

Rudi De Vos wrote:I try to repeat it without luck.

Server and viewer are both 1.2.11 ?
This look simular to a bug we had in the previous version and was reported fixed in 1211.
But has the cause was some initiating timing issue's...


Yes, both server and viewer are 1.2.1.1.

Most of the time we get a grey screen if one VNC session is already connected to the remote computer.

Sometimes we get a black screen if one VNC session is already connected to the remote computer.

Is there some detailed logging that I should turn on?
UsernameIssues
8
8
 
Posts: 23
Joined: 2016-08-11 18:55

Re: Grey Screen

Postby VncUser2014 » 2016-08-24 10:00

Yes this is true, the grey screen seems to happen more often when other viewer sessions are connected to the server already.

In our case:

Server OS: VmWare virtual machine (5.5 U3) with Windows 2012R2 Server as guest OS
Client OS: Windows 7 x64 SP1 or Windows XP x86 SP3
Cpu speed server: Multicore 2,4GHz
Network speed: Gigabit
Format & encoding : Hextile Full Colors
Not sure what you mean with color depth. Where can I find this?
VncUser2014
8
8
 
Posts: 28
Joined: 2014-10-29 10:33

Re: Grey Screen

Postby Rudi De Vos » 2016-08-24 19:16

Possible it's related to the desktop duplication engine, this can only be activated on OS's >= 6.2
On following OS's
Windows 10 10.0*
Windows Server 2016 10.0*
Windows 8.1 6.3*
Windows Server 2012 R2 6.3*
Windows 8 6.2
Windows Server 2012 6.2

This special mode is activated together with the "system hookdll" polling.
"system hookdll" is a server poll option.

If this is the case:
The grey screen bug happen on OS's>=6.2 with the polling option systemhook activated.

For someone who can easy repeat the issue
- check if OS is >=6.2
- check if they still can repeat the grey screen if "system hookdll" is disabled
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby UsernameIssues » 2016-08-25 21:11

This grey screen issue happens on Windows 7 (32bit and 64bit).

It also happens on XP. Please see the video below:

https://www.youtube.com/watch?v=746FVbqiBh8
UsernameIssues
8
8
 
Posts: 23
Joined: 2016-08-11 18:55

Re: Grey Screen

Postby Rudi De Vos » 2016-08-28 19:07

Sorry, still no luck repeating it.

Tried with virtualpc and vmware with a xp guest OS.
Viewer on master os.
Made a script that open 10 sessions: simultanious, every 2 seconds...
The script kill the connections and restart after 1 minutes
After 2 hours running, i still have proper multiple connections.

But something must trigger it on your setup...
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby UsernameIssues » 2016-08-30 01:11

Thanks for looking into the issue.

The setup for the video used two VirtualBox VMs (both running XP) and VirtualBox's Nat Network.

Maybe others that see this issue will be able to suggest a way for you to replicate it.
UsernameIssues
8
8
 
Posts: 23
Joined: 2016-08-11 18:55

Re: Grey Screen

Postby VncUser2014 » 2016-09-05 09:44

Is there some kind of logging we can enable on server side and/or client side that can help you find the root cause of this issue?
VncUser2014
8
8
 
Posts: 28
Joined: 2014-10-29 10:33

Re: Grey Screen

Postby VncUser2014 » 2016-09-06 13:42

We had this issue this morning which was reproducable.
- Windows 7 x64 host with UltraVNC Server 1.2.1.1 x64
- two users with Windows 7 x64 client with UltraVNC Viewer 1.2.1.1 x64

User 1 could connect immediately
User 2 got grey screen when also connecting
User 2 closed down & openened connection multiple times, the screen stayed grey
User 1 closed its session
User 2 openened a session again and could connect immediately

This leads to the feeling that the grey screens happens when other sessions are already open in certain circumstances.
VncUser2014
8
8
 
Posts: 28
Joined: 2014-10-29 10:33

Re: Grey Screen

Postby Rudi De Vos » 2016-09-06 19:18

While the screen is grey, do you see all buttons ontop of the viewer window.

Some buttons are only activated after some negotiation, like the file transfer button.
Does the grey screen show all buttons ? If not this can give me a clue about were it's locked.

ps: what's the build date of the 1.2.1.1 version
server trayicon -> about
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby UsernameIssues » 2016-09-06 23:54

> Does the grey screen show all buttons ?
All of the buttons eventually appear, but the screen is still grey.

https://www.youtube.com/watch?v=iVoM0Z2-X3k

In that video, the grey screen has control, but the user cannot see where he is clicking.

The video also shows the build info on the server. The server and client have the same version/build installed. Both are Windows 7 pro 64 bit for the OS - but like I mentioned before: this happens on XP too.
UsernameIssues
8
8
 
Posts: 23
Joined: 2016-08-11 18:55

Re: Grey Screen

Postby VncUser2014 » 2016-09-07 12:05

At first, not all icons appear, after a while, indeed all icons appear and users can click but don't see the screen... auch.
The version is 1.2.1.1 x64, Build May 12 2016 22:34:37
VncUser2014
8
8
 
Posts: 28
Joined: 2014-10-29 10:33

Re: Grey Screen

Postby Rudi De Vos » 2016-09-07 14:30

The buttons help a lot, special because i added at some place a 5 sec timout to prevent a total application lockup.
On of the visual effects of the lock was that the buttons didn't showed...

At least i know now were i need to look in the src.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby Rudi De Vos » 2016-09-07 19:14

I remember that i could repeat something simular in the past...
The issue was related to the cursorshape update.

A viewer option
()Track remote cursor locally <-------this use the cursor shape routine on the server site.
(*)This would mean that using "Let remote server deal with mouse cursor" can prevent it.

Using (*) possible prevent it.

I'm back tracing all changes made after 4/2014 to see how it was fixed for 98% of the users.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby UsernameIssues » 2016-09-07 20:40

UsernameIssues
8
8
 
Posts: 23
Joined: 2016-08-11 18:55

Re: Grey Screen

Postby Rudi De Vos » 2016-09-07 21:10

Can you activate server logging repeat the grey issue and mail me the WinVNC.log

Thanks
R.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby UsernameIssues » 2016-09-07 21:40

I sent you a PM with the log file.

I stopped the service on the remote computer shortly after the grey screen happened. That should have ended the log collection near the grey screen event.
UsernameIssues
8
8
 
Posts: 23
Joined: 2016-08-11 18:55

Re: Grey Screen

Postby Rudi De Vos » 2016-09-08 21:23

investigating
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby Rudi De Vos » 2016-09-09 13:18

found already an issue.
The viewer need to answer within a few seconds or server timeout.

Introduced april 2016 with the ipv6 patch.
I could repeat the timeout with a static server screen... possible this is
also causing the grey issue. However, i could not repeat the grey screen.

The trigger to repeat it is a static server screen.
If things change on the screen, you don't get the timeout.

R.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby VncUser2014 » 2016-09-09 14:13

You are right, servers with a static screen have this problem all the time. We can reproduce this problem now.
I did the test with my collegue.
My collegue opened a VNC session to a server with a static screen, he had no grey screen.
I opened a VNC session to the same server with the static screen, I always got the grey screen.
My collegue started typing or mouse-moving in the screen, I opened a vnc session to the same server, no grey screen.

So indeed, it has to do with multiple connections to a server having a static screen.
I have a week off work, so I will not be able to test a new build until 19 september. Thanks for digging into this issue.
VncUser2014
8
8
 
Posts: 28
Joined: 2014-10-29 10:33

Re: Grey Screen

Postby UsernameIssues » 2016-09-09 19:34

I guess it depends on what you mean by a static screen.

https://www.youtube.com/watch?v=IyJxt6FI-vk

The video shows two W7 pro 64bit Virtual Machines side by side. The "remote" VM is playing a video full screen.
UsernameIssues
8
8
 
Posts: 23
Joined: 2016-08-11 18:55

Re: Grey Screen

Postby Rudi De Vos » 2016-09-11 21:35

I'm able to repeat it with a static screen...and possible solving this also solve the other.

I already found that it is the viewer that goes in timeout, and then the viewer breaks the connection.
The server reset, but cause is the viewer. I also can repeat it with older viewers, but then the timeout
is after a longer time of inactivity.
Having a cursor ( flashing input) prevent it from happening...in my case
Using a video i can't repeat it, but this doesn't mean that the reason can't be the same.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby Rudi De Vos » 2016-09-11 21:35

I'm able to repeat it with a static screen...and possible solving this also solve the other.

I already found that it is the viewer that goes in timeout, and then the viewer breaks the connection.
The server reset, but cause is the viewer. I also can repeat it with older viewers, but then the timeout
is after a longer time of inactivity.
Having a cursor ( flashing input) prevent it from happening...in my case
Using a video i can't repeat it, but this doesn't mean that the reason can't be the same.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby Rudi De Vos » 2016-09-12 19:09

Seems i can repeat it( grey screens) when i download the online bins. (date around 22/05)
Both 32/64 bit versions

Starting second instance -> grey screen

But not with bins i used to test this usseu, fresh compiled.
This way we can test forever. é"'!ç(§é"&'è!ç(§ç&
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Re: Grey Screen

Postby Rudi De Vos » 2016-09-18 19:26

I think i found it...

Hard to debug issue.
Debug mode -> no grey
Release Mode in compiler -> no grey
Release Mode, run direct -> grey
But when you run the exe you can't debug anything....

Final i was able to get rid of it in my test case... but has it already was hard to repeat i'm not 100% sure
it's solved in all other cases.

Preparing exe 32/64 for XP >= for testing.

Build 1065(src)

http://www.uvnc.eu/download/forum1211/w ... eytest.zip
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5438
Joined: 2004-04-23 10:21

Next

Return to 1.2.1.x

Who is online

Users browsing this forum: No registered users and 2 guests