FileTransfer FT disabled

FileTransfer FT disabled

Postby ianfinlay » 2017-05-17 01:54

I have the following setup:
- Windws 7 Embedded running x64 UltraVNC Server as a service - title bar appended with "service mode"
- Windows 10 Viewer x64 UltraVNC

The server has file transfer enabled in admin properties
The viewer shows no file transfer icon
when I right click the viewer title bar and access file transfer from the popup menu I get the message...

"The connected VNC Server doesn't support UltraVNC File Transfer !" :oops:

I have other sites with the same setup but file transfer works

I am appreciative of any ideas to resolve this

Aside: I have found that I need to have a scheduled task that kills and restarts uvnc_service.exe every hour, if I have not accessed a remote ultravnc server for extended periods I can not always get in, and then its a flight hire car hotel; just to reboot a PC.
Posts: 1
Joined: 2017-05-17 01:42

Re: FileTransfer FT disabled

Postby CoreyCoop » 2017-05-24 05:21

I have sort of the same problem, in that I can set the Properties to allow file transfer, but it won't allow me to enter transfer mode.
Windows 7 to Windows 7
both 64bit
both on the same network, so quite fast, no bandwidth issues.
Server running in Service Mode
Posts: 1
Joined: 2017-05-24 05:17

Re: FileTransfer FT disabled

Postby Cackle61 » 2018-01-17 22:23

Sorry I don't have an answer for this. I have the same problem. WinVNC Server is installed on a WinXPSP3 machine, 2.16GHz, 1GB.

file transfer was previously working on a much older version (1.0.8 if I remember correctly). I upgraded to late last week and lost the file transfer function (no toolbar button and the above error message when selecting from the dropdown menu).

I have tried the following to no avail:
* uninstalled and reinstalled this version of uVNC via both RD & Teamviewer connections;
* downgraded to an earlier version (;
* searched and deleted VNC related files that might be interfering;
* searched and deleted registry entries/keys relating to VNC (it should be noted that there were some that couldn't be deleted)

Has anyone found a solution to this yet?

Thanks in advance...
Posts: 2
Joined: 2018-01-17 00:00

Re: FileTransfer FT disabled

Postby Rudi De Vos » 2018-01-18 10:50

On startup, ultravnc check the protocol.
If the protocol differ vnc is started in "compatibility mode" and ultravnc specific parts are disabled ( like FT)

I guess you are running an old server and a new viewer or a new server and a old viewer, using 2 different rfb protocols
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6107
Joined: 2004-04-23 10:21

Re: FileTransfer FT disabled

Postby Cackle61 » 2018-01-23 04:42

Problem solved. Although I had upgraded the client to, the shortcut was still pointing to an older version. Once I redirected it to the new version and deleted the old, it was all good.
Posts: 2
Joined: 2018-01-17 00:00

Return to 1.2.1.x

Who is online

Users browsing this forum: No registered users and 1 guest