1.2.1.6 online

1.2.1.6 online

Postby Rudi De Vos » 2017-09-13 20:42

Code fixes after 1215 cummulated and all added in this release.

*On connection you sometimes got disconnected, or ubvnc specific buttons were missing.
This was very difficult to repeat. The only thing i found was that the clipboard started to send data during connection.
This data could mix with initial data and made the connection fail. After this change i could not repeat it. But not 100%
sure it's solved, i just can't repeat it anymore with this build.

*Visual studio 2017 activate sse2 by default, added a special oldCPU build without sse/sse2

*The viewer didn't reconnect proper, crashed ( using plugins and repeater ...)
Fixed.

Download via homepage
https://www.uvnc.com/downloads/ultravnc.html
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: 1.2.1.6 online

Postby szymon.nowak » 2017-09-14 06:56

I have tested the xp32 bit on Win 32&64 - 7, 8.1, 10, it seems that everything is ok
szymon.nowak
20
20
 
Posts: 40
Joined: 2011-12-09 22:21

Re: 1.2.1.6 online

Postby irgendeinname » 2017-09-14 07:43

szymon.nowak wrote:I have tested the xp32 bit on Win 32&64 - 7, 8.1, 10, it seems that everything is ok

Sorry, but it seems no ok!
Tested on Win 32&64 - 7 and 10.

  • winvnc.exe isn't updated to Version 1.2.1.6
  • vncviewer.exe always installed
    Setup.inf
    Code: Select all
    [Setup]
    Lang=de
    Dir=C:\Program Files\UltraVNC
    Group=UltraVNC
    NoIcons=0
    SetupType=server
    Components=ultravnc_server
    Tasks=installservice
irgendeinname
 
Posts: 2
Joined: 2017-09-14 07:35

Re: 1.2.1.6 online

Postby Rudi De Vos » 2017-09-14 18:41

Indeed, the 32bit version was installing the viewer but exe file are 1216.

if winvnc.exe is running ( app/service) the exe is replaced on reboot to avoid to get disconnected.
Perhaps you need to reboot to update the exe !

Use the upgrade option if you want to replace online, upgrade stop service/replace files/start service
and replace only existing files..

correct inf created with
\SAVEINF

Code: Select all
[Setup]
Lang=en
Dir=C:\Program Files (x86)\uvnc bvba\UltraVNC
Group=UltraVNC
NoIcons=0
SetupType=custom
Components=ultravnc_server
Tasks=startservice


Reuploaded the 32bit installer
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: 1.2.1.6 online

Postby Rudi De Vos » 2017-09-14 18:45

A little trick to all to create your inf

Run setup.exe \SAVEINF="myfile.txt" and manual make all changes
run setup.exe \LOADINF=myfile.txt" to use it
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: 1.2.1.6 online

Postby ddbivens » 2017-09-14 23:32

I downloaded the new 1.2.1.6 installers this morning. (I re-downloaded again today when I saw your note above that you had re-uploaded the 32bit installer.) I have installed to Windows 7, 32bit/64bit. I was able to install the 32bit application on Windows 7 32bit without an issue. Each time I try to install the 32bit installer on a Windows XP PC, (silent install), the install hangs. I rebooted the XP PC to clear the hung install. I logged into the XP and ran the installer manually. During the install I get two error messages which are what caused the silent install to hang. The first error message is: "Setup / Unable to execute file: / C:\Program Files\UltraVNC\setpassword.exe / CreateProcess failed; code 193. / %1 is not a valid Win32 application". The second error message is: Unable to execute file: / C:\Program Files\UltraVNC\setcad.exe / CreateProcess failed; code 193. / %1 is not a: valid Win32 application". (In the previous quotes the '/' means a new line.) Is it possible these programs were compiled with a compiler no longer compatible with XP? I hope you can help. We still have about 80 XP PCs in use. Thanks for listening.
ddbivens
20
20
 
Posts: 49
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA

Re: 1.2.1.6 online

Postby irgendeinname » 2017-09-15 10:58

Rudi De Vos wrote:Indeed, the 32bit version was installing the viewer but exe file are 1216.
[...]
Reuploaded the 32bit installer

Thanks a lot.

Rudi De Vos wrote:if winvnc.exe is running ( app/service) the exe is replaced on reboot to avoid to get disconnected.
Perhaps you need to reboot to update the exe !

Yes, reboot was needed.

Rudi De Vos wrote:correct inf created with
\SAVEINF

My INF was created with a previous version.
I created a new one and now it works.
irgendeinname
 
Posts: 2
Joined: 2017-09-14 07:35

Re: 1.2.1.6 online

Postby SkyBeam » 2017-09-15 18:30

Many thanks for the release.

Will there be any MSI installers available?
I hope this type of installers are not silently dropped suddenly.

I will test it as soon as I get MSI packages.
Thanks again!


EDIT: Also I am obviously too stupid to understand the packaging. There seems to be no new release of the Addos package. However the ZIP distribution of version 1.2.1.6 contain a folder called "encryptionPlugins" which seem to inclode a newer (or re-built) version of "SecureVNCPlugin*.dsm". But this version is neither included in the old nor in the linked 1.2.1.0 version of the addons (I downloaded and diffed them, they seem not to have been updated).
So are we supposed to do patchwork like
- Use EXE installer instead of MSI (which does not work with some auto-deployment systems)
- Install old 1.2.1.0 addons
- Install (or not?) the updated encryption addon from the ZIP?

It's really confusing (at least to me).
SkyBeam
 
Posts: 5
Joined: 2012-12-31 11:01

Re: 1.2.1.6 online

Postby Rudi De Vos » 2017-09-15 21:20

msi installers are online

Checking the older downloads...
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: 1.2.1.6 online

Postby Rudi De Vos » 2017-09-15 21:30

CreateProcess failed; code 193

Found what happened, Compiler was upgraded during build...
Rebuilding all builds to be sure
Do it asap

Automated 95%, so will be done fast
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: 1.2.1.6 online

Postby SkyBeam » 2017-09-15 22:01

Rudi De Vos wrote:msi installers are online


Many thanks for this. Either I was blind or you just uploaded them now. Anyway, they are there now. Unfortunately when I download them I get a 0 Byte file from the download servers.

EDIT: Just read your next post later... I will wait until all builds are re-uploaded. Does it also affect the ZIP and EXE installer builds? Shall I re-download all of them?
From Change and Configuration management perspective this is very bad as you don't know who already downloaded the binaries. So it would perhaps be better even to bump the revision again.

Also the description is very cryptic like
"x86
XP >=
"

I know UltraVNC is mainly used by "technical" people but a little bit of description would be easy to add. Some suggestions:

ultravnc 1216 msi w32 Old Cpu:
UltraVNC 1.2.1.6 distribution for x86 CPUs without SSE/SSE2 support. Use this only on very old hardware on Windows XP and older.

ultravnc 1216 msi w32:
UltraVNC 1.2.1.6 distribution for 32-bit operating systems.
Supports Windows XP or later. Requires SSE/SSE2 CPU support.

ultravnc 1216 msi x64:
UltraVNC 1.2.1.6 distribution for 64-bit operating systems.
Supports Windows 8 x64 or later.

ultravnc 1216 msi x64 XP:
UltraVNC 1.2.1.6 distribution for 64-bit Windows XP installations (Windows XP x64) only.


As far as I know also the MSI does not include the addons. In addition it's also unclear here whether installing addons 1.2.1.0 on top of the MSI is sufficient or in addition to this the Encryption Plugins from the ZIP will have to be added (at least they look like newer build).

Meanwhile I have installed UltraVNC 1.2.1.6 on a test machine running Windows 10 Home. No larger issues discovered yet. Except fast user switching issues. When switching between users often the Viewer sends keyboard/mouse events and I see the mouse moving on remote machine but the screen does not refresh until I reconnect the viewer. This however was already an issue in earlier versions and it's not new in 1.2.1.6. Currently running a full patchwork installation:
- UltraVNC 1.2.1.6 base installation
- Addons 1.2.1.0
- Encryption plugins from 1.2.1.6 ZIP

Thanks and keep up the great work!
SkyBeam
 
Posts: 5
Joined: 2012-12-31 11:01

Re: 1.2.1.6 online

Postby Rudi De Vos » 2017-09-15 22:25

Thanks for the site update ... yep was done to fast.
Website changed, looks indeed better

All files recompiled, installers created and uploaded.
Only impact were the XP and non SSE builds. They didn't run ( exe error) on XP


-encryption plugins didn't changed, don't need to the zip one.
Signing and recompiling rebuild all.

If you know inno setup, i can upload the build folder, this allow to replace the default ini
with your own and add the extra files from the addon. ( For GPL reason, we can't create a single installer)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: 1.2.1.6 online

Postby SkyBeam » 2017-09-15 22:34

Hurray, many thanks for the update. Indeed I would say this clarifies things for many downloaders.

Unfortunately I still get 0-Byte downloads for the MSI files. I will check again tomorrow as this might be proxy caching issue only (on my side).

Thanks also for clarification on encryption plugins and license. Now I understand why there are multiple packages.
I personally don't need to re-pack the installer. Basically for my purpose I am creating a custom installer. So I need the MSI only to extract it (or the EXE, but EXE is more difficult to extract). The ZIP files are unusable for me too as I have seen the structure often changes and last time I checked I was unable to find a ZIP which contains all DLLs and files the installer contains. Didn't bother sorting it out and just went for the MSI (extract it, zip it up and send it over to my test systems or distribute MSI using WPKG).

Thank you, I will report if I encounter any further issues.
SkyBeam
 
Posts: 5
Joined: 2012-12-31 11:01

Re: 1.2.1.6 online

Postby Rudi De Vos » 2017-09-15 22:47

Retested download (edge) and this seems to work.
All server moved to HTTPS, so you can try also with https

Give me a pm if it still fail, the i pass the direct links
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: 1.2.1.6 online

Postby ddbivens » 2017-09-16 01:01

Thank you so much for the new downloadables...
I downloaded directly from web site so I did not test the download links. I have already copied the exe installers to my work PC and I have pushed them to Win7 32/64bit systems and to WinXP 32bit PCs. Everything is installing great. I won't get a chance to do any serious use until I get back to work on Monday. Thanks again for the quick work!!!
ddbivens
20
20
 
Posts: 49
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA

Re: 1.2.1.6 online

Postby nzsolt » 2017-09-18 07:09

Hi,

could anybody check the folder file transfer? It seems it is not working.
nzsolt
8
8
 
Posts: 16
Joined: 2010-02-08 10:35

Re: 1.2.1.6 online

Postby ddbivens » 2017-09-19 01:58

Transfer folders to a Windows XP PC does not work. However, you can create the folder on the remote PC manually and select all the files in the local folder and then transfer the files into the folder on the Windows XP PC.
ddbivens
20
20
 
Posts: 49
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA

Re: 1.2.1.6 online

Postby nzsolt » 2017-09-19 19:14

In the earlier version the folder was recursively compressed and extracted.
It seems it is not working (send or receive too) if Windows XP is used on server or client side.
Maybe the compressing has problem or rights ?
nzsolt
8
8
 
Posts: 16
Joined: 2010-02-08 10:35

Re: 1.2.1.6 online

Postby Rudi De Vos » 2017-09-19 20:30

Need more info because it's working on the test pc's ' running win10 to win10

Test between win10 and win10
-select folder
-select destination folder
-press send
Now, i see the files being zipped, send, and unzipped
removed local folder
-press recv

Does it work woth the previous version ?
Are you using the 1216 veiwer and server ?
Something must be different..
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: 1.2.1.6 online

Postby Rudi De Vos » 2017-09-19 20:46

second test win10<->XP looks like folder zip fail
As test i rebuilded the vncviewer.exe with VS2010... and this works.
Looks like VS2017 can not be stable used for XP.

I will try to update all XP bins tomorrow suing an older VS compiler.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: 1.2.1.6 online

Postby nzsolt » 2017-09-19 21:02

Maybe the zip functions not working on XP? (both server and viewer)
I tested other vncviewer (not ultravnc) and that worked on XP too.
nzsolt
8
8
 
Posts: 16
Joined: 2010-02-08 10:35

Re: 1.2.1.6 online

Postby Rudi De Vos » 2017-09-19 21:06

indeed, zip/unzip functions are broken by the new VS compiler for XP.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: 1.2.1.6 online

Postby ddbivens » 2017-09-20 00:52

I am glad you have found the issue. I look forward to the update when released. Thank you.
ddbivens
20
20
 
Posts: 49
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA

Re: 1.2.1.6 online

Postby Rudi De Vos » 2017-09-20 19:53

updated xp files in all downloads
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5410
Joined: 2004-04-23 10:21

Re: 1.2.1.6 online

Postby nzsolt » 2017-09-21 16:29

Thanks, it works!
nzsolt
8
8
 
Posts: 16
Joined: 2010-02-08 10:35

Re: 1.2.1.6 online

Postby ddbivens » 2017-09-21 23:44

Thanks so much. Yes, File Transfers to/from XP PCs are working great. I am sure all other OSs will work as well. :D
ddbivens
20
20
 
Posts: 49
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA


Return to 1.2.1.x

Who is online

Users browsing this forum: No registered users and 1 guest