Noticible performance degradation

Noticible performance degradation

Postby voyager1993 » 2017-11-15 22:13

Hello all UltraVNC gurus!

We have been successfully using single click version of the VNC server (Z_SC_2010) a few years ago (year 2015) between PCs.
The version of Windows we have been running on I believe was Windows 7.
Recently we tried to run it on Windows 10 - just to discover that this old version of VNC server is simply not usable any more.
The delay in updating of the client screen is somewhere from 15 to 25 seconds. Clearly something changed in the Windows APIs
implementation, since it looks like the update of the client screen only takes place from the full poll on the server side (and
not on changes).
We downloaded and compiled the latest version of the single click UltraVNC code (Z_SC_2015(Feb)). This version definitely
works better then the old one (Z_SC_2010), since from what I see server is constantly polling the full screen and sends the
updates to the client all the time (hence such high CPU utilization - 4%). But still, the performance is significantly worst then
the working case scenario of the Z_SC_2010. It takes a noticeable delay in time and visually for the moved window to get
redrawn on the screen. Pretty much the same performance we are getting with the installable version of the UltraVNC server
(version 1.2.1.6).

Is there anything can be done to improve the performance? What is the reason for such significant change in performance?
I would like to believe that there is simply something we are doing wrong or missing.

Any piece of advice is greatly appreciated.

Thanks!
voyager1993
 
Posts: 1
Joined: 2017-11-15 21:48

Return to 1.2.1.x

Who is online

Users browsing this forum: No registered users and 2 guests